print/chktex - The NetBSD Packages Collection

LaTeX semantic checker

This program has been written in frustration because some constructs in LaTeX
are sometimes non-intuitive, and easy to forget. It is _not_ a replacement
for the built-in checker in LaTeX; however it catches some typographic errors
LaTeX oversees. In other words, it is Lint for LaTeX. Filters are also
provided for checking the LaTeX parts of CWEB documents.

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

www/lynx lang/perl5 devel/pcre devel/pcre

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfchktex-1.7.6nb4.tgz
NetBSD 8.0earmv7hfchktex-1.7.6nb4.tgz
NetBSD 8.0earmv7hfchktex-1.7.6nb4.tgz
NetBSD 8.0i386chktex-1.7.6nb4.tgz
NetBSD 8.0i386chktex-1.7.6nb4.tgz
NetBSD 8.0i386chktex-1.7.6nb4.tgz
NetBSD 8.0powerpcchktex-1.7.6nb4.tgz
NetBSD 8.0powerpcchktex-1.7.6nb4.tgz
NetBSD 8.0powerpcchktex-1.7.6nb4.tgz
NetBSD 8.0powerpcchktex-1.7.6nb4.tgz
NetBSD 8.0x86_64chktex-1.7.6nb4.tgz
NetBSD 8.0x86_64chktex-1.7.6nb4.tgz
NetBSD 8.0x86_64chktex-1.7.6nb4.tgz
NetBSD 9.0aarch64chktex-1.7.6nb4.tgz
NetBSD 9.0aarch64chktex-1.7.6nb4.tgz
NetBSD 9.0aarch64chktex-1.7.6nb4.tgz
NetBSD 9.0alphachktex-1.7.6nb4.tgz
NetBSD 9.0earmchktex-1.7.6nb4.tgz
NetBSD 9.0earmchktex-1.7.6nb4.tgz
NetBSD 9.0earmv6hfchktex-1.7.6nb4.tgz
NetBSD 9.0earmv6hfchktex-1.7.6nb4.tgz
NetBSD 9.0earmv6hfchktex-1.7.6nb4.tgz
NetBSD 9.0earmv6hfchktex-1.7.6nb4.tgz
NetBSD 9.0earmv7hfchktex-1.7.6nb4.tgz
NetBSD 9.0earmv7hfchktex-1.7.6nb4.tgz
NetBSD 9.0earmv7hfchktex-1.7.6nb4.tgz
NetBSD 9.0earmv7hfchktex-1.7.6nb4.tgz
NetBSD 9.0earmv7hfchktex-1.7.6nb4.tgz
NetBSD 9.0i386chktex-1.7.6nb4.tgz
NetBSD 9.0i386chktex-1.7.6nb4.tgz
NetBSD 9.0i386chktex-1.7.6nb4.tgz
NetBSD 9.0mips64ebchktex-1.7.6nb4.tgz
NetBSD 9.0powerpcchktex-1.7.6nb4.tgz
NetBSD 9.0powerpcchktex-1.7.6nb4.tgz
NetBSD 9.0powerpcchktex-1.7.6nb4.tgz
NetBSD 9.0powerpcchktex-1.7.6nb4.tgz
NetBSD 9.0sh3elchktex-1.7.6nb4.tgz
NetBSD 9.0sparc64chktex-1.7.6nb4.tgz
NetBSD 9.0sparcchktex-1.7.6nb4.tgz
NetBSD 9.0vaxchktex-1.7.6nb4.tgz
NetBSD 9.0x86_64chktex-1.7.6nb4.tgz
NetBSD 9.0x86_64chktex-1.7.6nb4.tgz
NetBSD 9.0x86_64chktex-1.7.6nb4.tgz
NetBSD 9.0x86_64chktex-1.7.6nb4.tgz
NetBSD 9.0x86_64chktex-1.7.6nb4.tgz
NetBSD 9.0x86_64chktex-1.7.6nb4.tgz
NetBSD 9.0x86_64chktex-1.7.6nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.