pkgtools/libkver - The NetBSD Packages Collection

Shared library and sysctl(1) replacement to override system version

This package provides a shared library and a replacement for
sysctl(1) (when needed i.e. when the original one is statically linked)
so that the real version numbers and strings of the running NetBSD
kernel as returned by sysctl(3) and uname(3) are overridden by
those the library is configured to report.

This is useful for -among other things- building packages in
sandboxed/chrooted environment for a different NetBSD release than the
system hosting the sandbox/chroot.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibkver-0.7.2.tgz
NetBSD 8.0earmv7hflibkver-0.7.2.tgz
NetBSD 8.0earmv7hflibkver-0.7.2.tgz
NetBSD 8.0i386libkver-0.7.2.tgz
NetBSD 8.0i386libkver-0.7.2.tgz
NetBSD 8.0i386libkver-0.7.2.tgz
NetBSD 8.0i386libkver-0.7.2.tgz
NetBSD 8.0powerpclibkver-0.7.2.tgz
NetBSD 8.0powerpclibkver-0.7.2.tgz
NetBSD 8.0powerpclibkver-0.7.2.tgz
NetBSD 8.0powerpclibkver-0.7.2.tgz
NetBSD 8.0x86_64libkver-0.7.2.tgz
NetBSD 8.0x86_64libkver-0.7.2.tgz
NetBSD 8.0x86_64libkver-0.7.2.tgz
NetBSD 8.0x86_64libkver-0.7.2.tgz
NetBSD 9.0aarch64libkver-0.7.2.tgz
NetBSD 9.0aarch64libkver-0.7.2.tgz
NetBSD 9.0aarch64libkver-0.7.2.tgz
NetBSD 9.0aarch64libkver-0.7.2.tgz
NetBSD 9.0alphalibkver-0.7.2.tgz
NetBSD 9.0alphalibkver-0.7.2.tgz
NetBSD 9.0earmlibkver-0.7.2.tgz
NetBSD 9.0earmv6hflibkver-0.7.2.tgz
NetBSD 9.0earmv6hflibkver-0.7.2.tgz
NetBSD 9.0earmv6hflibkver-0.7.2.tgz
NetBSD 9.0earmv6hflibkver-0.7.2.tgz
NetBSD 9.0earmv6hflibkver-0.7.2.tgz
NetBSD 9.0earmv7hflibkver-0.7.2.tgz
NetBSD 9.0earmv7hflibkver-0.7.2.tgz
NetBSD 9.0earmv7hflibkver-0.7.2.tgz
NetBSD 9.0earmv7hflibkver-0.7.2.tgz
NetBSD 9.0earmv7hflibkver-0.7.2.tgz
NetBSD 9.0earmv7hflibkver-0.7.2.tgz
NetBSD 9.0earmv7hflibkver-0.7.2.tgz
NetBSD 9.0i386libkver-0.7.2.tgz
NetBSD 9.0i386libkver-0.7.2.tgz
NetBSD 9.0i386libkver-0.7.2.tgz
NetBSD 9.0i386libkver-0.7.2.tgz
NetBSD 9.0mips64eblibkver-0.7.2.tgz
NetBSD 9.0mips64eblibkver-0.7.2.tgz
NetBSD 9.0mips64eblibkver-0.7.2.tgz
NetBSD 9.0powerpclibkver-0.7.2.tgz
NetBSD 9.0powerpclibkver-0.7.2.tgz
NetBSD 9.0powerpclibkver-0.7.2.tgz
NetBSD 9.0powerpclibkver-0.7.2.tgz
NetBSD 9.0powerpclibkver-0.7.2.tgz
NetBSD 9.0sparc64libkver-0.7.2.tgz
NetBSD 9.0sparclibkver-0.7.2.tgz
NetBSD 9.0sparclibkver-0.7.2.tgz
NetBSD 9.0x86_64libkver-0.7.2.tgz
NetBSD 9.0x86_64libkver-0.7.2.tgz
NetBSD 9.0x86_64libkver-0.7.2.tgz
NetBSD 9.0x86_64libkver-0.7.2.tgz
NetBSD 9.0x86_64libkver-0.7.2.tgz
NetBSD 9.0x86_64libkver-0.7.2.tgz
NetBSD 9.0x86_64libkver-0.7.2.tgz
NetBSD 9.0x86_64libkver-0.7.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.