pkgtools/compat_headers - The NetBSD Packages Collection

Compatibility headers

This package attempts to resolve deficiencies in system headers by
providing missing types, definitions and prototypes in shadow headers.

When use of compat_headers has been enabled on a platform, this package will
become a compile-time dependency for every package. It will provide customized
header files that take preference over some system provided ones (that may
not even exist). This happens transparently through use of buildlink3.

To enable use of this package, set FIX_SYSTEM_HEADERS=yes in mk.conf.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfcompat_headers-0.2.tgz
NetBSD 8.0earmv7hfcompat_headers-0.2.tgz
NetBSD 8.0earmv7hfcompat_headers-0.2.tgz
NetBSD 8.0i386compat_headers-0.2.tgz
NetBSD 8.0i386compat_headers-0.2.tgz
NetBSD 8.0i386compat_headers-0.2.tgz
NetBSD 8.0i386compat_headers-0.2.tgz
NetBSD 8.0powerpccompat_headers-0.2.tgz
NetBSD 8.0powerpccompat_headers-0.2.tgz
NetBSD 8.0powerpccompat_headers-0.2.tgz
NetBSD 8.0powerpccompat_headers-0.2.tgz
NetBSD 8.0x86_64compat_headers-0.2.tgz
NetBSD 8.0x86_64compat_headers-0.2.tgz
NetBSD 8.0x86_64compat_headers-0.2.tgz
NetBSD 8.0x86_64compat_headers-0.2.tgz
NetBSD 9.0aarch64compat_headers-0.2.tgz
NetBSD 9.0aarch64compat_headers-0.2.tgz
NetBSD 9.0aarch64compat_headers-0.2.tgz
NetBSD 9.0aarch64compat_headers-0.2.tgz
NetBSD 9.0alphacompat_headers-0.2.tgz
NetBSD 9.0alphacompat_headers-0.2.tgz
NetBSD 9.0earmcompat_headers-0.2.tgz
NetBSD 9.0earmcompat_headers-0.2.tgz
NetBSD 9.0earmv6hfcompat_headers-0.2.tgz
NetBSD 9.0earmv6hfcompat_headers-0.2.tgz
NetBSD 9.0earmv6hfcompat_headers-0.2.tgz
NetBSD 9.0earmv6hfcompat_headers-0.2.tgz
NetBSD 9.0earmv6hfcompat_headers-0.2.tgz
NetBSD 9.0earmv7hfcompat_headers-0.2.tgz
NetBSD 9.0earmv7hfcompat_headers-0.2.tgz
NetBSD 9.0earmv7hfcompat_headers-0.2.tgz
NetBSD 9.0earmv7hfcompat_headers-0.2.tgz
NetBSD 9.0earmv7hfcompat_headers-0.2.tgz
NetBSD 9.0earmv7hfcompat_headers-0.2.tgz
NetBSD 9.0earmv7hfcompat_headers-0.2.tgz
NetBSD 9.0i386compat_headers-0.2.tgz
NetBSD 9.0i386compat_headers-0.2.tgz
NetBSD 9.0i386compat_headers-0.2.tgz
NetBSD 9.0i386compat_headers-0.2.tgz
NetBSD 9.0mips64ebcompat_headers-0.2.tgz
NetBSD 9.0mips64ebcompat_headers-0.2.tgz
NetBSD 9.0mips64ebcompat_headers-0.2.tgz
NetBSD 9.0mips64ebcompat_headers-0.2.tgz
NetBSD 9.0powerpccompat_headers-0.2.tgz
NetBSD 9.0powerpccompat_headers-0.2.tgz
NetBSD 9.0powerpccompat_headers-0.2.tgz
NetBSD 9.0powerpccompat_headers-0.2.tgz
NetBSD 9.0powerpccompat_headers-0.2.tgz
NetBSD 9.0sparc64compat_headers-0.2.tgz
NetBSD 9.0sparc64compat_headers-0.2.tgz
NetBSD 9.0sparccompat_headers-0.2.tgz
NetBSD 9.0sparccompat_headers-0.2.tgz
NetBSD 9.0sparccompat_headers-0.2.tgz
NetBSD 9.0x86_64compat_headers-0.2.tgz
NetBSD 9.0x86_64compat_headers-0.2.tgz
NetBSD 9.0x86_64compat_headers-0.2.tgz
NetBSD 9.0x86_64compat_headers-0.2.tgz
NetBSD 9.0x86_64compat_headers-0.2.tgz
NetBSD 9.0x86_64compat_headers-0.2.tgz
NetBSD 9.0x86_64compat_headers-0.2.tgz
NetBSD 9.0x86_64compat_headers-0.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.