news/libcanlock - The NetBSD Packages Collection

Standalone RFC 8315 Netnews Cancel-Lock implementation

libcanlock is a library for creating and verifying RFC 8315 Netnews
Cancel-Locks. This implementation uses the recommended algorithm from
Section 4 with HMAC based on the same hash function as .

A command line utility "canlock" is built together with the library.

Additional header parsers (for the receiving side) are available in the
package canlock-hp.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

(none)

Available binary packages

aarch64:libcanlock-3.2.0.tgz(NetBSD 9.0)
aarch64:libcanlock-3.2.0.tgz(NetBSD 9.0)
aarch64:libcanlock-3.2.1.tgz(NetBSD 9.0)
alpha:libcanlock-3.2.1.tgz(NetBSD 9.0)
alpha:libcanlock-3.2.0.tgz(NetBSD 9.0)
alpha:libcanlock-3.2.0.tgz(NetBSD 9.0)
earm:libcanlock-3.2.0.tgz(NetBSD 9.0)
earm:libcanlock-3.1.1.tgz(NetBSD 9.0)
earmv6hf:libcanlock-3.2.1.tgz(NetBSD 9.0)
earmv6hf:libcanlock-3.2.0.tgz(NetBSD 9.0)
earmv6hf:libcanlock-3.2.0.tgz(NetBSD 9.0)
earmv6hf:libcanlock-3.2.1.tgz(NetBSD 9.0)
earmv7hf:libcanlock-3.2.1.tgz(NetBSD 8.0)
earmv7hf:libcanlock-3.1.1.tgz(NetBSD 8.0)
earmv7hf:libcanlock-3.2.0.tgz(NetBSD 8.0)
earmv7hf:libcanlock-3.2.0.tgz(NetBSD 8.0)
earmv7hf:libcanlock-3.2.1.tgz(NetBSD 9.0)
earmv7hf:libcanlock-3.1.1.tgz(NetBSD 9.0)
earmv7hf:libcanlock-3.2.0.tgz(NetBSD 9.0)
earmv7hf:libcanlock-3.2.0.tgz(NetBSD 9.0)
earmv7hf:libcanlock-3.2.1.tgz(NetBSD 9.0)
i386:libcanlock-3.2.0.tgz(NetBSD 8.0)
i386:libcanlock-3.2.0.tgz(NetBSD 8.0)
i386:libcanlock-3.2.1.tgz(NetBSD 8.0)
i386:libcanlock-3.2.0.tgz(NetBSD 9.0)
i386:libcanlock-3.2.0.tgz(NetBSD 9.0)
i386:libcanlock-3.2.1.tgz(NetBSD 9.0)
m68k:libcanlock-3.1.1.tgz(NetBSD 9.0)
mips64eb:libcanlock-3.2.0.tgz(NetBSD 9.0)
mips64eb:libcanlock-3.2.1.tgz(NetBSD 9.0)
powerpc:libcanlock-3.2.0.tgz(NetBSD 8.0)
powerpc:libcanlock-3.2.0.tgz(NetBSD 8.0)
powerpc:libcanlock-3.2.1.tgz(NetBSD 8.0)
powerpc:libcanlock-3.2.1.tgz(NetBSD 9.0)
powerpc:libcanlock-3.2.0.tgz(NetBSD 9.0)
powerpc:libcanlock-3.2.0.tgz(NetBSD 9.0)
sparc64:libcanlock-3.2.1.tgz(NetBSD 9.0)
sparc64:libcanlock-3.2.0.tgz(NetBSD 9.0)
sparc64:libcanlock-3.2.0.tgz(NetBSD 9.0)
sparc:libcanlock-3.2.0.tgz(NetBSD 9.0)
sparc:libcanlock-3.2.0.tgz(NetBSD 9.0)
sparc:libcanlock-3.2.1.tgz(NetBSD 9.0)
x86_64:libcanlock-3.2.0.tgz(NetBSD 9.0)
x86_64:libcanlock-3.2.1.tgz(NetBSD 9.0)
x86_64:libcanlock-3.2.2.tgz(NetBSD 9.0)
x86_64:libcanlock-3.2.0.tgz(NetBSD 9.0)
x86_64:libcanlock-3.2.0.tgz(NetBSD 8.0)
x86_64:libcanlock-3.2.0.tgz(NetBSD 8.0)
x86_64:libcanlock-3.2.1.tgz(NetBSD 8.0)
x86_64:libcanlock-3.2.0.tgz(NetBSD 9.0)
x86_64:libcanlock-3.2.0.tgz(NetBSD 9.0)
x86_64:libcanlock-3.2.1.tgz(NetBSD 9.0)
x86_64:libcanlock-3.2.2.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]