net/ucspi-ssl - The NetBSD Packages Collection

Command-line tools for SSL client-server applications

sslserver and sslclient are command-line tools for building SSL
client-server applications. They conform to the UNIX Client-Server
Program Interface, UCSPI.

sslserver listens for connections, and runs a program for each
connection it accepts. The program environment includes variables
that hold the local and remote host names, IP addresses, and port
numbers. sslserver offers a concurrency limit on acceptance of new
connections, and selective handling of connections based on client
identity.

sslclient requests a connection to a TCP socket, and runs a program.
The program environment includes the same variables as for sslserver.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

net/ucspi-tcp net/fehqlibs

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfucspi-ssl-0.999.11.6a.tgz
NetBSD 8.0earmv7hfucspi-ssl-0.999.11.6a.tgz
NetBSD 8.0earmv7hfucspi-ssl-0.999.11.6a.tgz
NetBSD 8.0i386ucspi-ssl-0.999.11.6a.tgz
NetBSD 8.0i386ucspi-ssl-0.999.11.6a.tgz
NetBSD 8.0i386ucspi-ssl-0.999.11.6a.tgz
NetBSD 8.0powerpcucspi-ssl-0.999.11.6a.tgz
NetBSD 8.0powerpcucspi-ssl-0.999.11.6a.tgz
NetBSD 8.0powerpcucspi-ssl-0.999.11.6a.tgz
NetBSD 8.0powerpcucspi-ssl-0.999.11.6a.tgz
NetBSD 8.0x86_64ucspi-ssl-0.999.11.6a.tgz
NetBSD 8.0x86_64ucspi-ssl-0.999.11.6a.tgz
NetBSD 8.0x86_64ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0aarch64ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0aarch64ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0aarch64ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0alphaucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0alphaucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0alphaucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0earmv6hfucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0earmv6hfucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0earmv6hfucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0earmv6hfucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0earmv7hfucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0earmv7hfucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0earmv7hfucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0earmv7hfucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0earmv7hfucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0i386ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0i386ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0i386ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0m68kucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0powerpcucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0powerpcucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0powerpcucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0powerpcucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0sparc64ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0sparc64ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0x86_64ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0x86_64ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0x86_64ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0x86_64ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0x86_64ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0x86_64ucspi-ssl-0.999.11.6a.tgz
NetBSD 9.0x86_64ucspi-ssl-0.999.11.6a.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

inet6
Enable support for IPv6.
perl
Enable Perl support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.