net/ucspi-ipc - The NetBSD Packages Collection

UCSPI local-domain client-server command-line tools

The ipcserver and ipcclient programs are command-line tools for building
local-domain client-server applications. They conform to the UNIX
Client-Server Program Interface, UCSPI.

The ipcserver program listens for connections on a local-domain
stream socket, and runs a program for each connection it accepts. The
program environment includes variables that hold the local and remote
socket addresses, and the effective user and group IDs of the process
that called connect. ipcserver offers a concurrency limit on
acceptance of new connections, and selective handling of connections
based on client identity.

The ipcclient program requests a connection to a local-domain socket,
and runs a program. The program environment includes a variable that
holds the local socket address.

The ipcperl program is an example of an ipchandle server. It invokes a
perl subroutine for each request.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfucspi-ipc-0.67.tgz
NetBSD 8.0earmv7hfucspi-ipc-0.67.tgz
NetBSD 8.0i386ucspi-ipc-0.67.tgz
NetBSD 8.0i386ucspi-ipc-0.67.tgz
NetBSD 8.0powerpcucspi-ipc-0.67.tgz
NetBSD 8.0powerpcucspi-ipc-0.67.tgz
NetBSD 8.0powerpcucspi-ipc-0.67.tgz
NetBSD 8.0x86_64ucspi-ipc-0.67.tgz
NetBSD 8.0x86_64ucspi-ipc-0.67.tgz
NetBSD 9.0aarch64ucspi-ipc-0.67.tgz
NetBSD 9.0aarch64ucspi-ipc-0.67.tgz
NetBSD 9.0alphaucspi-ipc-0.67.tgz
NetBSD 9.0alphaucspi-ipc-0.67.tgz
NetBSD 9.0earmv6hfucspi-ipc-0.67.tgz
NetBSD 9.0earmv6hfucspi-ipc-0.67.tgz
NetBSD 9.0earmv6hfucspi-ipc-0.67.tgz
NetBSD 9.0earmv7hfucspi-ipc-0.67.tgz
NetBSD 9.0earmv7hfucspi-ipc-0.67.tgz
NetBSD 9.0earmv7hfucspi-ipc-0.67.tgz
NetBSD 9.0earmv7hfucspi-ipc-0.67.tgz
NetBSD 9.0i386ucspi-ipc-0.67.tgz
NetBSD 9.0i386ucspi-ipc-0.67.tgz
NetBSD 9.0mips64ebucspi-ipc-0.67.tgz
NetBSD 9.0mips64ebucspi-ipc-0.67.tgz
NetBSD 9.0powerpcucspi-ipc-0.67.tgz
NetBSD 9.0powerpcucspi-ipc-0.67.tgz
NetBSD 9.0powerpcucspi-ipc-0.67.tgz
NetBSD 9.0sparc64ucspi-ipc-0.67.tgz
NetBSD 9.0sparc64ucspi-ipc-0.67.tgz
NetBSD 9.0sparcucspi-ipc-0.67.tgz
NetBSD 9.0x86_64ucspi-ipc-0.67.tgz
NetBSD 9.0x86_64ucspi-ipc-0.67.tgz
NetBSD 9.0x86_64ucspi-ipc-0.67.tgz
NetBSD 9.0x86_64ucspi-ipc-0.67.tgz
NetBSD 9.0x86_64ucspi-ipc-0.67.tgz
NetBSD 9.0x86_64ucspi-ipc-0.67.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

perl
Enable Perl support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.