net/ruby-winrm-elevated - The NetBSD Packages Collection

Ruby library for running commands as elevated

Runs PowerShell commands as elevated over Windows Remote Management (WinRM)
via a scheduled task

This gem allows you to break out of the magical WinRM constraints thus
allowing to reach out to network shares and even install Windows updates,
.NET, SQL Server etc.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

textproc/ruby-erubi net/ruby-winrm-fs lang/ruby26-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby25-winrm-elevated-1.2.3.tgz
NetBSD 8.0earmv7hfruby26-winrm-elevated-1.2.3.tgz
NetBSD 8.0earmv7hfruby27-winrm-elevated-1.2.3.tgz
NetBSD 8.0i386ruby25-winrm-elevated-1.2.3.tgz
NetBSD 8.0i386ruby26-winrm-elevated-1.2.3.tgz
NetBSD 8.0i386ruby27-winrm-elevated-1.2.3.tgz
NetBSD 8.0powerpcruby25-winrm-elevated-1.2.3.tgz
NetBSD 8.0powerpcruby26-winrm-elevated-1.2.3.tgz
NetBSD 8.0powerpcruby27-winrm-elevated-1.2.3.tgz
NetBSD 8.0powerpcruby25-winrm-elevated-1.2.3.tgz
NetBSD 8.0powerpcruby26-winrm-elevated-1.2.3.tgz
NetBSD 8.0powerpcruby27-winrm-elevated-1.2.3.tgz
NetBSD 8.0x86_64ruby25-winrm-elevated-1.2.3.tgz
NetBSD 8.0x86_64ruby26-winrm-elevated-1.2.3.tgz
NetBSD 8.0x86_64ruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0aarch64ruby25-winrm-elevated-1.2.3.tgz
NetBSD 9.0aarch64ruby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0aarch64ruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0aarch64ruby30-winrm-elevated-1.2.3.tgz
NetBSD 9.0alpharuby25-winrm-elevated-1.2.3.tgz
NetBSD 9.0alpharuby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0alpharuby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0earmv6hfruby25-winrm-elevated-1.2.3.tgz
NetBSD 9.0earmv6hfruby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0earmv6hfruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0earmv6hfruby30-winrm-elevated-1.2.3.tgz
NetBSD 9.0earmv7hfruby25-winrm-elevated-1.2.3.tgz
NetBSD 9.0earmv7hfruby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0earmv7hfruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0earmv7hfruby30-winrm-elevated-1.2.3.tgz
NetBSD 9.0earmv7hfruby25-winrm-elevated-1.2.3.tgz
NetBSD 9.0earmv7hfruby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0earmv7hfruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0earmv7hfruby30-winrm-elevated-1.2.3.tgz
NetBSD 9.0i386ruby25-winrm-elevated-1.2.3.tgz
NetBSD 9.0i386ruby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0i386ruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0i386ruby30-winrm-elevated-1.2.3.tgz
NetBSD 9.0mips64ebruby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0mips64ebruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0mips64ebruby30-winrm-elevated-1.2.3.tgz
NetBSD 9.0powerpcruby25-winrm-elevated-1.2.3.tgz
NetBSD 9.0powerpcruby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0powerpcruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0powerpcruby30-winrm-elevated-1.2.3.tgz
NetBSD 9.0powerpcruby25-winrm-elevated-1.2.3.tgz
NetBSD 9.0powerpcruby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0powerpcruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0powerpcruby30-winrm-elevated-1.2.3.tgz
NetBSD 9.0sparc64ruby25-winrm-elevated-1.2.3.tgz
NetBSD 9.0sparc64ruby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0sparc64ruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0sparc64ruby30-winrm-elevated-1.2.3.tgz
NetBSD 9.0x86_64ruby25-winrm-elevated-1.2.3.tgz
NetBSD 9.0x86_64ruby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0x86_64ruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0x86_64ruby25-winrm-elevated-1.2.3.tgz
NetBSD 9.0x86_64ruby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0x86_64ruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0x86_64ruby30-winrm-elevated-1.2.3.tgz
NetBSD 9.0x86_64ruby25-winrm-elevated-1.2.3.tgz
NetBSD 9.0x86_64ruby26-winrm-elevated-1.2.3.tgz
NetBSD 9.0x86_64ruby27-winrm-elevated-1.2.3.tgz
NetBSD 9.0x86_64ruby30-winrm-elevated-1.2.3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.