net/rdist6 - The NetBSD Packages Collection

Network file distribution/synchronisation utility

This is derived from version 6.1 of Rdist from USC.  It is based on
rdist from 4.3BSD (classic).  It includes all fixes for all bugs known
to the CSRG Berkeley folks.  It has been running at USC and numerous
other sites for some time now on a wide variety of platforms.

This version of rdist is not directly compatible with rdist
distributed with 4.3BSD and subsequent vendor releases, but does
indirectly provide full backward compatibility.  See COMPATIBILITY
below for details.

This version of rdist does not need to be setuid "root" at all.  Rdist
now uses the rsh(1c) [remote command] program to make connections to
remote hosts, instead of making the connection directly.  This
eliminates the need to be run as "root".  Many thanks to Chris
Siebenmann  and John DiMarco
 who came up with an rsh version of rcmd() that
makes this possible.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Available binary packages

aarch64:freerdist-0.94nb1.tgz(NetBSD 9.0)
aarch64:freerdist-0.94nb1.tgz(NetBSD 9.0)
aarch64:freerdist-0.94nb1.tgz(NetBSD 9.0)
alpha:freerdist-0.94nb1.tgz(NetBSD 9.0)
alpha:freerdist-0.94nb1.tgz(NetBSD 9.0)
alpha:freerdist-0.94nb1.tgz(NetBSD 9.0)
earm:freerdist-0.94nb1.tgz(NetBSD 9.0)
earm:freerdist-0.94nb1.tgz(NetBSD 9.0)
earmv6hf:freerdist-0.94nb1.tgz(NetBSD 9.0)
earmv6hf:freerdist-0.94nb1.tgz(NetBSD 9.0)
earmv6hf:freerdist-0.94nb1.tgz(NetBSD 9.0)
earmv6hf:freerdist-0.94nb1.tgz(NetBSD 9.0)
earmv7hf:freerdist-0.94nb1.tgz(NetBSD 8.0)
earmv7hf:freerdist-0.94nb1.tgz(NetBSD 8.0)
earmv7hf:freerdist-0.94nb1.tgz(NetBSD 8.0)
earmv7hf:freerdist-0.94nb1.tgz(NetBSD 8.0)
earmv7hf:freerdist-0.94nb1.tgz(NetBSD 9.0)
i386:freerdist-0.94nb1.tgz(NetBSD 8.0)
i386:freerdist-0.94nb1.tgz(NetBSD 8.0)
i386:freerdist-0.94nb1.tgz(NetBSD 8.0)
i386:freerdist-0.94nb1.tgz(NetBSD 9.0)
i386:freerdist-0.94nb1.tgz(NetBSD 9.0)
i386:freerdist-0.94nb1.tgz(NetBSD 9.0)
m68k:freerdist-0.94nb1.tgz(NetBSD 9.0)
powerpc:freerdist-0.94nb1.tgz(NetBSD 8.0)
powerpc:freerdist-0.94nb1.tgz(NetBSD 8.0)
powerpc:freerdist-0.94nb1.tgz(NetBSD 8.0)
sparc64:freerdist-0.94nb1.tgz(NetBSD 9.0)
sparc64:freerdist-0.94nb1.tgz(NetBSD 9.0)
sparc64:freerdist-0.94nb1.tgz(NetBSD 9.0)
sparc:freerdist-0.94nb1.tgz(NetBSD 9.0)
sparc:freerdist-0.94nb1.tgz(NetBSD 9.0)
sparc:freerdist-0.94nb1.tgz(NetBSD 9.0)
x86_64:freerdist-0.94nb1.tgz(NetBSD 9.0)
x86_64:freerdist-0.94nb1.tgz(NetBSD 9.0)
x86_64:freerdist-0.94nb1.tgz(NetBSD 9.0)
x86_64:freerdist-0.94nb1.tgz(NetBSD 9.0)
x86_64:freerdist-0.94nb1.tgz(NetBSD 8.0)
x86_64:freerdist-0.94nb1.tgz(NetBSD 8.0)
x86_64:freerdist-0.94nb1.tgz(NetBSD 8.0)
x86_64:freerdist-0.94nb1.tgz(NetBSD 9.0)
x86_64:freerdist-0.94nb1.tgz(NetBSD 9.0)
x86_64:freerdist-0.94nb1.tgz(NetBSD 9.0)
x86_64:freerdist-0.94nb1.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]