net/proftpd-geoip - The NetBSD Packages Collection

Geolocation module for proftpd

The ProFTPD mod_geoip module allows sites to quickly look up geolocation
information such as country, continent, region, timezone, etc based on
the connecting client's IP address. This information can be logged for
tracking purposes, and used to configure access controls in order to
reduce/prevent connections from locations unauthorized by site policy.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/autoconf textproc/intltool devel/gmake

Runtime dependencies

net/proftpd lang/perl5 net/GeoIP net/GeoIP

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfproftpd-geoip-1.3.6c.tgz
NetBSD 8.0earmv7hfproftpd-geoip-1.3.6c.tgz
NetBSD 8.0earmv7hfproftpd-geoip-1.3.6c.tgz
NetBSD 8.0i386proftpd-geoip-1.3.6c.tgz
NetBSD 8.0i386proftpd-geoip-1.3.6c.tgz
NetBSD 8.0i386proftpd-geoip-1.3.6c.tgz
NetBSD 8.0powerpcproftpd-geoip-1.3.6c.tgz
NetBSD 8.0powerpcproftpd-geoip-1.3.6c.tgz
NetBSD 8.0powerpcproftpd-geoip-1.3.6c.tgz
NetBSD 8.0powerpcproftpd-geoip-1.3.6c.tgz
NetBSD 8.0x86_64proftpd-geoip-1.3.6c.tgz
NetBSD 8.0x86_64proftpd-geoip-1.3.6c.tgz
NetBSD 8.0x86_64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0aarch64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0aarch64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0aarch64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0alphaproftpd-geoip-1.3.6c.tgz
NetBSD 9.0alphaproftpd-geoip-1.3.6c.tgz
NetBSD 9.0alphaproftpd-geoip-1.3.6c.tgz
NetBSD 9.0earmv6hfproftpd-geoip-1.3.6c.tgz
NetBSD 9.0earmv6hfproftpd-geoip-1.3.6c.tgz
NetBSD 9.0earmv6hfproftpd-geoip-1.3.6c.tgz
NetBSD 9.0earmv6hfproftpd-geoip-1.3.6c.tgz
NetBSD 9.0earmv7hfproftpd-geoip-1.3.6c.tgz
NetBSD 9.0earmv7hfproftpd-geoip-1.3.6c.tgz
NetBSD 9.0earmv7hfproftpd-geoip-1.3.6c.tgz
NetBSD 9.0earmv7hfproftpd-geoip-1.3.6c.tgz
NetBSD 9.0earmv7hfproftpd-geoip-1.3.6c.tgz
NetBSD 9.0i386proftpd-geoip-1.3.6c.tgz
NetBSD 9.0i386proftpd-geoip-1.3.6c.tgz
NetBSD 9.0i386proftpd-geoip-1.3.6c.tgz
NetBSD 9.0mips64ebproftpd-geoip-1.3.6c.tgz
NetBSD 9.0mips64ebproftpd-geoip-1.3.6c.tgz
NetBSD 9.0mips64ebproftpd-geoip-1.3.6c.tgz
NetBSD 9.0powerpcproftpd-geoip-1.3.6c.tgz
NetBSD 9.0powerpcproftpd-geoip-1.3.6c.tgz
NetBSD 9.0powerpcproftpd-geoip-1.3.6c.tgz
NetBSD 9.0powerpcproftpd-geoip-1.3.6c.tgz
NetBSD 9.0sparc64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0sparc64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0sparc64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0sparcproftpd-geoip-1.3.6c.tgz
NetBSD 9.0x86_64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0x86_64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0x86_64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0x86_64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0x86_64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0x86_64proftpd-geoip-1.3.6c.tgz
NetBSD 9.0x86_64proftpd-geoip-1.3.6c.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

inet6
Enable support for IPv6.
pam
Enable PAM support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.