net/powerdns-pgsql - The NetBSD Packages Collection

PostgreSQL backend module for PowerDNS

The PowerDNS nameserver is a modern, advanced and high performance
authoritative-only nameserver.  It is written from scratch and conforms
to all the relevant DNS standards documents.  PowerDNS is open source.

The PowerDNS nameserver utilizes a flexible backend architecture that
can access DNS information from any data source.  This includes file
formats, BIND zone files, relational databases or LDAP directories.

This packages provides the PostgreSQL backend module.

Build dependencies

devel/ragel devel/boost-headers devel/boost-libs pkgtools/cwrappers devel/libtool-base devel/bison devel/gmake devel/pkgconf

Runtime dependencies

net/powerdns lang/lua53 www/curl databases/postgresql12-client www/curl databases/postgresql12-client

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpowerdns-pgsql-4.4.0.tgz
NetBSD 8.0earmv7hfpowerdns-pgsql-4.3.1.tgz
NetBSD 8.0earmv7hfpowerdns-pgsql-4.4.1.tgz
NetBSD 8.0i386powerdns-pgsql-4.4.1.tgz
NetBSD 8.0powerpcpowerdns-pgsql-4.4.1.tgz
NetBSD 8.0powerpcpowerdns-pgsql-4.4.1.tgz
NetBSD 8.0x86_64powerdns-pgsql-4.4.1.tgz
NetBSD 8.0x86_64powerdns-pgsql-4.3.1.tgz
NetBSD 8.0x86_64powerdns-pgsql-4.4.0.tgz
NetBSD 9.0aarch64powerdns-pgsql-4.4.1.tgz
NetBSD 9.0aarch64powerdns-pgsql-4.3.1.tgz
NetBSD 9.0aarch64powerdns-pgsql-4.4.0.tgz
NetBSD 9.0earmv6hfpowerdns-pgsql-4.4.1.tgz
NetBSD 9.0earmv6hfpowerdns-pgsql-4.3.1.tgz
NetBSD 9.0earmv6hfpowerdns-pgsql-4.4.0.tgz
NetBSD 9.0earmv6hfpowerdns-pgsql-4.4.0.tgz
NetBSD 9.0earmv7hfpowerdns-pgsql-4.4.1.tgz
NetBSD 9.0earmv7hfpowerdns-pgsql-4.3.1.tgz
NetBSD 9.0earmv7hfpowerdns-pgsql-4.4.0.tgz
NetBSD 9.0earmv7hfpowerdns-pgsql-4.4.0.tgz
NetBSD 9.0earmv7hfpowerdns-pgsql-4.4.1.tgz
NetBSD 9.0i386powerdns-pgsql-4.4.1.tgz
NetBSD 9.0mips64ebpowerdns-pgsql-4.4.1.tgz
NetBSD 9.0mips64ebpowerdns-pgsql-4.3.1.tgz
NetBSD 9.0mips64ebpowerdns-pgsql-4.4.0.tgz
NetBSD 9.0powerpcpowerdns-pgsql-4.4.1.tgz
NetBSD 9.0powerpcpowerdns-pgsql-4.4.1.tgz
NetBSD 9.0sparc64powerdns-pgsql-4.4.1.tgz
NetBSD 9.0sparc64powerdns-pgsql-4.3.1.tgz
NetBSD 9.0sparc64powerdns-pgsql-4.4.0.tgz
NetBSD 9.0x86_64powerdns-pgsql-4.3.1.tgz
NetBSD 9.0x86_64powerdns-pgsql-4.4.0.tgz
NetBSD 9.0x86_64powerdns-pgsql-4.4.0.tgz
NetBSD 9.0x86_64powerdns-pgsql-4.4.1.tgz
NetBSD 9.0x86_64powerdns-pgsql-4.3.1.tgz
NetBSD 9.0x86_64powerdns-pgsql-4.4.0.tgz
NetBSD 9.0x86_64powerdns-pgsql-4.4.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.