net/omniORB - The NetBSD Packages Collection

CORBA ORB

omniORB is a robust high performance CORBA ORB for C++ and Python. It is
freely available under the terms of the GNU Lesser General Public License
(for the libraries), and GNU General Public License (for the tools). It is
one of only three ORBs to have been awarded the Open Group's Open Brand for
CORBA. This means that omniORB has been tested and certified CORBA 2.1
compliant.
The technical highlights are:
  * C++ and Python language bindings.
  * Adheres to the CORBA 2.6 specification.
  * Support for GIOP and IIOP 1.0, 1.1 and 1.2.
  * Fully multithreaded runtime.
  * TypeCode and type Any.
  * CORBA 2.6 DynAny interfaces.
  * Dynamic Invocation and Dynamic Skeleton interfaces.
  * Complete Naming Service, omniNames.
  * Support for wchar, wstring and code set negotiation.
  * Full long long, long double, fixed point support.
  * PortableServer::Current.
  * Unix domain socket transport.
  * Bidirectional GIOP.
  * Interoperable Secure Socket Layer transport.
  * Flexible thread management.
  * Interceptors.
  * Fully interoperable with other CORBA ORBs.

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfomniORB-4.1.7nb3.tgz
NetBSD 8.0earmv7hfomniORB-4.1.7nb2.tgz
NetBSD 8.0earmv7hfomniORB-4.1.7nb3.tgz
NetBSD 8.0i386omniORB-4.1.7nb2.tgz
NetBSD 8.0i386omniORB-4.1.7nb3.tgz
NetBSD 8.0i386omniORB-4.1.7nb3.tgz
NetBSD 8.0powerpcomniORB-4.1.7nb2.tgz
NetBSD 8.0powerpcomniORB-4.1.7nb3.tgz
NetBSD 8.0powerpcomniORB-4.1.7nb3.tgz
NetBSD 8.0powerpcomniORB-4.1.7nb3.tgz
NetBSD 8.0x86_64omniORB-4.1.7nb3.tgz
NetBSD 8.0x86_64omniORB-4.1.7nb2.tgz
NetBSD 8.0x86_64omniORB-4.1.7nb3.tgz
NetBSD 9.0aarch64omniORB-4.1.7nb3.tgz
NetBSD 9.0aarch64omniORB-4.1.7nb2.tgz
NetBSD 9.0aarch64omniORB-4.1.7nb3.tgz
NetBSD 9.0alphaomniORB-4.1.7nb3.tgz
NetBSD 9.0alphaomniORB-4.1.7nb2.tgz
NetBSD 9.0alphaomniORB-4.1.7nb3.tgz
NetBSD 9.0earmomniORB-4.1.7nb2.tgz
NetBSD 9.0earmomniORB-4.1.7nb3.tgz
NetBSD 9.0earmomniORB-4.1.7nb3.tgz
NetBSD 9.0earmv6hfomniORB-4.1.7nb3.tgz
NetBSD 9.0earmv6hfomniORB-4.1.7nb2.tgz
NetBSD 9.0earmv6hfomniORB-4.1.7nb3.tgz
NetBSD 9.0earmv6hfomniORB-4.1.7nb3.tgz
NetBSD 9.0earmv7hfomniORB-4.1.7nb3.tgz
NetBSD 9.0earmv7hfomniORB-4.1.7nb2.tgz
NetBSD 9.0earmv7hfomniORB-4.1.7nb3.tgz
NetBSD 9.0earmv7hfomniORB-4.1.7nb3.tgz
NetBSD 9.0earmv7hfomniORB-4.1.7nb3.tgz
NetBSD 9.0i386omniORB-4.1.7nb2.tgz
NetBSD 9.0i386omniORB-4.1.7nb3.tgz
NetBSD 9.0i386omniORB-4.1.7nb3.tgz
NetBSD 9.0mips64ebomniORB-4.1.7nb3.tgz
NetBSD 9.0mips64ebomniORB-4.1.7nb2.tgz
NetBSD 9.0mips64ebomniORB-4.1.7nb3.tgz
NetBSD 9.0mipselomniORB-4.1.7nb3.tgz
NetBSD 9.0mipselomniORB-4.1.7nb3.tgz
NetBSD 9.0powerpcomniORB-4.1.7nb3.tgz
NetBSD 9.0powerpcomniORB-4.1.7nb2.tgz
NetBSD 9.0powerpcomniORB-4.1.7nb3.tgz
NetBSD 9.0powerpcomniORB-4.1.7nb3.tgz
NetBSD 9.0sh3elomniORB-4.1.7nb3.tgz
NetBSD 9.0sh3elomniORB-4.1.7nb3.tgz
NetBSD 9.0sparc64omniORB-4.1.7nb3.tgz
NetBSD 9.0sparc64omniORB-4.1.7nb2.tgz
NetBSD 9.0sparc64omniORB-4.1.7nb2.tgz
NetBSD 9.0sparc64omniORB-4.1.7nb3.tgz
NetBSD 9.0sparcomniORB-4.1.7nb3.tgz
NetBSD 9.0sparcomniORB-4.1.7nb2.tgz
NetBSD 9.0sparcomniORB-4.1.7nb3.tgz
NetBSD 9.0x86_64omniORB-4.1.7nb2.tgz
NetBSD 9.0x86_64omniORB-4.1.7nb3.tgz
NetBSD 9.0x86_64omniORB-4.1.7nb3.tgz
NetBSD 9.0x86_64omniORB-4.1.7nb3.tgz
NetBSD 9.0x86_64omniORB-4.1.7nb2.tgz
NetBSD 9.0x86_64omniORB-4.1.7nb3.tgz
NetBSD 9.0x86_64omniORB-4.1.7nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

inet6
Enable support for IPv6.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.