net/lftp - The NetBSD Packages Collection

Powerful command line file transfer client

lftp is powerful file transfer client. It uses GNU readline to read
commands and shell-like command syntax allowing you to launch several
commands in parallel in background. lftp has reliable put, reput, mirror,
and many other commands. lftp supports ftp, http, https, fish and sftp
protocols.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/autoconf devel/bison

Runtime dependencies

devel/readline graphics/hicolor-icon-theme devel/readline graphics/hicolor-icon-theme

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflftp-4.9.2nb1.tgz
NetBSD 8.0earmv7hflftp-4.9.2nb1.tgz
NetBSD 8.0earmv7hflftp-4.9.2nb1.tgz
NetBSD 8.0i386lftp-4.9.2nb1.tgz
NetBSD 8.0i386lftp-4.9.2nb1.tgz
NetBSD 8.0i386lftp-4.9.2nb1.tgz
NetBSD 8.0powerpclftp-4.9.2nb1.tgz
NetBSD 8.0powerpclftp-4.9.2nb1.tgz
NetBSD 8.0powerpclftp-4.9.2nb1.tgz
NetBSD 8.0powerpclftp-4.9.2nb1.tgz
NetBSD 8.0x86_64lftp-4.9.2nb1.tgz
NetBSD 8.0x86_64lftp-4.9.2nb1.tgz
NetBSD 8.0x86_64lftp-4.9.2nb1.tgz
NetBSD 9.0aarch64lftp-4.9.2nb1.tgz
NetBSD 9.0aarch64lftp-4.9.2nb1.tgz
NetBSD 9.0aarch64lftp-4.9.2nb1.tgz
NetBSD 9.0alphalftp-4.9.2nb1.tgz
NetBSD 9.0alphalftp-4.9.2nb1.tgz
NetBSD 9.0alphalftp-4.9.2nb1.tgz
NetBSD 9.0earmlftp-4.9.2nb1.tgz
NetBSD 9.0earmv6hflftp-4.9.2nb1.tgz
NetBSD 9.0earmv6hflftp-4.9.2nb1.tgz
NetBSD 9.0earmv6hflftp-4.9.2nb1.tgz
NetBSD 9.0earmv6hflftp-4.9.2nb1.tgz
NetBSD 9.0earmv7hflftp-4.9.2nb1.tgz
NetBSD 9.0earmv7hflftp-4.9.2nb1.tgz
NetBSD 9.0earmv7hflftp-4.9.2nb1.tgz
NetBSD 9.0earmv7hflftp-4.9.2nb1.tgz
NetBSD 9.0earmv7hflftp-4.9.2nb1.tgz
NetBSD 9.0i386lftp-4.9.2nb1.tgz
NetBSD 9.0i386lftp-4.9.2nb1.tgz
NetBSD 9.0i386lftp-4.9.2nb1.tgz
NetBSD 9.0mips64eblftp-4.9.2nb1.tgz
NetBSD 9.0mips64eblftp-4.9.2nb1.tgz
NetBSD 9.0mips64eblftp-4.9.2nb1.tgz
NetBSD 9.0powerpclftp-4.9.2nb1.tgz
NetBSD 9.0powerpclftp-4.9.2nb1.tgz
NetBSD 9.0powerpclftp-4.9.2nb1.tgz
NetBSD 9.0powerpclftp-4.9.2nb1.tgz
NetBSD 9.0sparc64lftp-4.9.2nb1.tgz
NetBSD 9.0sparc64lftp-4.9.1nb2.tgz
NetBSD 9.0sparc64lftp-4.9.2nb1.tgz
NetBSD 9.0sparc64lftp-4.9.2nb1.tgz
NetBSD 9.0sparclftp-4.9.2nb1.tgz
NetBSD 9.0sparclftp-4.9.2nb1.tgz
NetBSD 9.0sparclftp-4.9.2nb1.tgz
NetBSD 9.0x86_64lftp-4.9.2nb1.tgz
NetBSD 9.0x86_64lftp-4.9.2nb1.tgz
NetBSD 9.0x86_64lftp-4.9.2nb1.tgz
NetBSD 9.0x86_64lftp-4.9.2nb1.tgz
NetBSD 9.0x86_64lftp-4.9.2nb1.tgz
NetBSD 9.0x86_64lftp-4.9.2nb1.tgz
NetBSD 9.0x86_64lftp-4.9.2nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

dnssec
Enable DNSSEC validation.
perl
Enable Perl support.
gnutls
Enable GNU TLS support.
ssl
Enable SSL support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.