net/gnome-vfs-smb - The NetBSD Packages Collection

GNOME Virtual File System (v2) - smb plugin

GNOME VFS provides an abstraction layer of the file system; applications
use this layer to access many different protocols and simulate that they
are part of the local file system.

This package provides the smb module for GNOME VFS, which allows it to
surf networks using the SMB protocol (also known as Microsoft Networks).

Build dependencies

pkgtools/cwrappers devel/glib2-tools devel/libtool-base textproc/intltool devel/gmake lang/perl5 devel/pkgconf

Runtime dependencies

sysutils/gnome-vfs sysutils/gnome-vfs devel/GConf devel/glib2 sysutils/dbus-glib textproc/libxml2 net/samba sysutils/gnome-vfs devel/GConf devel/glib2 sysutils/dbus-glib textproc/libxml2 net/samba

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 8.0earmv7hfgnome-vfs-smb-2.24.4nb37.tgz
NetBSD 8.0earmv7hfgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 8.0i386gnome-vfs-smb-2.24.4nb37.tgz
NetBSD 8.0i386gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 8.0i386gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 8.0powerpcgnome-vfs-smb-2.24.4nb37.tgz
NetBSD 8.0powerpcgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 8.0powerpcgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 8.0powerpcgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 8.0x86_64gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 8.0x86_64gnome-vfs-smb-2.24.4nb37.tgz
NetBSD 8.0x86_64gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0aarch64gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0aarch64gnome-vfs-smb-2.24.4nb37.tgz
NetBSD 9.0aarch64gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0alphagnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0alphagnome-vfs-smb-2.24.4nb37.tgz
NetBSD 9.0alphagnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0earmv6hfgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0earmv6hfgnome-vfs-smb-2.24.4nb37.tgz
NetBSD 9.0earmv6hfgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0earmv6hfgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0earmv7hfgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0earmv7hfgnome-vfs-smb-2.24.4nb37.tgz
NetBSD 9.0earmv7hfgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0earmv7hfgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0earmv7hfgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0i386gnome-vfs-smb-2.24.4nb37.tgz
NetBSD 9.0i386gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0i386gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0mips64ebgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0mips64ebgnome-vfs-smb-2.24.4nb37.tgz
NetBSD 9.0mips64ebgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0powerpcgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0powerpcgnome-vfs-smb-2.24.4nb37.tgz
NetBSD 9.0powerpcgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0powerpcgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0sparc64gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0sparc64gnome-vfs-smb-2.24.4nb37.tgz
NetBSD 9.0sparc64gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0sparcgnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0x86_64gnome-vfs-smb-2.24.4nb38.tgz
NetBSD 9.0x86_64gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0x86_64gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0x86_64gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0x86_64gnome-vfs-smb-2.24.4nb37.tgz
NetBSD 9.0x86_64gnome-vfs-smb-2.24.4nb39.tgz
NetBSD 9.0x86_64gnome-vfs-smb-2.24.4nb39.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.