net/exabgp - The NetBSD Packages Collection

ExaBGP is a userspace BGP daemon written in python

Unlike BIRD or Quagga, ExaBGP was not designed to transform a general purpose
server into a router, but to allow engineers to control their BGP (rfc4271)
network easily. Think of it as Software Defined Networking for people with
"commodity" routers.

ExaBGP transform BGP (rfc4271) messages into friendly plain text or JSON
which can be easily manipulate by scripts.

It allows the creation of tools such as:
 * advanced looking glass graphically display the routing of prefix
 * high availability tool which automatically isolate broken services
 * DDOS mitigation
 * an anycasted server

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/py-ipaddr devel/py-setuptools44 lang/perl5 lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfexabgp-3.4.23nb5.tgz
NetBSD 8.0earmv7hfexabgp-3.4.23nb5.tgz
NetBSD 8.0i386exabgp-3.4.23nb4.tgz
NetBSD 8.0i386exabgp-3.4.23nb5.tgz
NetBSD 8.0i386exabgp-3.4.23nb5.tgz
NetBSD 8.0powerpcexabgp-3.4.23nb4.tgz
NetBSD 8.0powerpcexabgp-3.4.23nb5.tgz
NetBSD 8.0powerpcexabgp-3.4.23nb5.tgz
NetBSD 8.0powerpcexabgp-3.4.23nb5.tgz
NetBSD 8.0x86_64exabgp-3.4.23nb5.tgz
NetBSD 8.0x86_64exabgp-3.4.23nb4.tgz
NetBSD 8.0x86_64exabgp-3.4.23nb5.tgz
NetBSD 9.0aarch64exabgp-3.4.23nb5.tgz
NetBSD 9.0aarch64exabgp-3.4.23nb4.tgz
NetBSD 9.0aarch64exabgp-3.4.23nb5.tgz
NetBSD 9.0alphaexabgp-3.4.23nb5.tgz
NetBSD 9.0alphaexabgp-3.4.23nb4.tgz
NetBSD 9.0alphaexabgp-3.4.23nb5.tgz
NetBSD 9.0earmv6hfexabgp-3.4.23nb5.tgz
NetBSD 9.0earmv6hfexabgp-3.4.23nb4.tgz
NetBSD 9.0earmv6hfexabgp-3.4.23nb5.tgz
NetBSD 9.0earmv6hfexabgp-3.4.23nb5.tgz
NetBSD 9.0earmv7hfexabgp-3.4.23nb5.tgz
NetBSD 9.0earmv7hfexabgp-3.4.23nb4.tgz
NetBSD 9.0earmv7hfexabgp-3.4.23nb5.tgz
NetBSD 9.0earmv7hfexabgp-3.4.23nb5.tgz
NetBSD 9.0earmv7hfexabgp-3.4.23nb5.tgz
NetBSD 9.0i386exabgp-3.4.23nb4.tgz
NetBSD 9.0i386exabgp-3.4.23nb5.tgz
NetBSD 9.0i386exabgp-3.4.23nb5.tgz
NetBSD 9.0mips64ebexabgp-3.4.23nb5.tgz
NetBSD 9.0mips64ebexabgp-3.4.23nb4.tgz
NetBSD 9.0mips64ebexabgp-3.4.23nb5.tgz
NetBSD 9.0powerpcexabgp-3.4.23nb5.tgz
NetBSD 9.0powerpcexabgp-3.4.23nb4.tgz
NetBSD 9.0powerpcexabgp-3.4.23nb5.tgz
NetBSD 9.0powerpcexabgp-3.4.23nb5.tgz
NetBSD 9.0sparc64exabgp-3.4.23nb5.tgz
NetBSD 9.0sparc64exabgp-3.4.23nb4.tgz
NetBSD 9.0sparc64exabgp-3.4.23nb5.tgz
NetBSD 9.0sparcexabgp-3.4.23nb5.tgz
NetBSD 9.0x86_64exabgp-3.4.23nb4.tgz
NetBSD 9.0x86_64exabgp-3.4.23nb5.tgz
NetBSD 9.0x86_64exabgp-3.4.23nb5.tgz
NetBSD 9.0x86_64exabgp-3.4.23nb5.tgz
NetBSD 9.0x86_64exabgp-3.4.23nb4.tgz
NetBSD 9.0x86_64exabgp-3.4.23nb5.tgz
NetBSD 9.0x86_64exabgp-3.4.23nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.