net/dctc - The NetBSD Packages Collection

Direct Connect clone (Direct Connect Text Client)

DCTC is a Direct Connect clone, a windows client allowing users to
share their files and talk (like IRC but more software sharing
oriented) using a proprietary protocol.

DCTC stands for Direct Connect Text Client.

DCTC is not designed to be used by human. It doesn't contains any
GUI or CLI. The goal of this project is to build a Direct Connect
client which can be used by other programs. So even if you can
enter command using the keyboard, don't say the human interface is
poor.

Build dependencies

pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

lang/perl5 devel/glib2 security/libgcrypt textproc/libxml2 databases/db4 devel/glib2 security/libgcrypt textproc/libxml2

Available binary packages

aarch64:dctc-0.85.9nb17.tgz(NetBSD 9.0)
aarch64:dctc-0.85.9nb18.tgz(NetBSD 9.0)
aarch64:dctc-0.85.9nb19.tgz(NetBSD 9.0)
alpha:dctc-0.85.9nb19.tgz(NetBSD 9.0)
alpha:dctc-0.85.9nb18.tgz(NetBSD 9.0)
earm:dctc-0.85.9nb18.tgz(NetBSD 9.0)
earmv6hf:dctc-0.85.9nb19.tgz(NetBSD 9.0)
earmv6hf:dctc-0.85.9nb17.tgz(NetBSD 9.0)
earmv6hf:dctc-0.85.9nb18.tgz(NetBSD 9.0)
earmv6hf:dctc-0.85.9nb19.tgz(NetBSD 9.0)
earmv7hf:dctc-0.85.9nb19.tgz(NetBSD 8.0)
earmv7hf:dctc-0.85.9nb16.tgz(NetBSD 8.0)
earmv7hf:dctc-0.85.9nb17.tgz(NetBSD 8.0)
earmv7hf:dctc-0.85.9nb18.tgz(NetBSD 8.0)
earmv7hf:dctc-0.85.9nb19.tgz(NetBSD 9.0)
earmv7hf:dctc-0.85.9nb16.tgz(NetBSD 9.0)
earmv7hf:dctc-0.85.9nb17.tgz(NetBSD 9.0)
earmv7hf:dctc-0.85.9nb18.tgz(NetBSD 9.0)
earmv7hf:dctc-0.85.9nb19.tgz(NetBSD 9.0)
i386:dctc-0.85.9nb17.tgz(NetBSD 8.0)
i386:dctc-0.85.9nb18.tgz(NetBSD 8.0)
i386:dctc-0.85.9nb19.tgz(NetBSD 8.0)
i386:dctc-0.85.9nb17.tgz(NetBSD 9.0)
i386:dctc-0.85.9nb18.tgz(NetBSD 9.0)
i386:dctc-0.85.9nb19.tgz(NetBSD 9.0)
mips64eb:dctc-0.85.9nb18.tgz(NetBSD 9.0)
mips64eb:dctc-0.85.9nb19.tgz(NetBSD 9.0)
powerpc:dctc-0.85.9nb17.tgz(NetBSD 8.0)
powerpc:dctc-0.85.9nb19.tgz(NetBSD 8.0)
powerpc:dctc-0.85.9nb18.tgz(NetBSD 8.0)
powerpc:dctc-0.85.9nb18.tgz(NetBSD 9.0)
powerpc:dctc-0.85.9nb17.tgz(NetBSD 9.0)
sparc64:dctc-0.85.9nb19.tgz(NetBSD 9.0)
sparc64:dctc-0.85.9nb17.tgz(NetBSD 9.0)
sparc64:dctc-0.85.9nb18.tgz(NetBSD 9.0)
x86_64:dctc-0.85.9nb19.tgz(NetBSD 9.0)
x86_64:dctc-0.85.9nb19.tgz(NetBSD 9.0)
x86_64:dctc-0.85.9nb19.tgz(NetBSD 9.0)
x86_64:dctc-0.85.9nb18.tgz(NetBSD 9.0)
x86_64:dctc-0.85.9nb18.tgz(NetBSD 8.0)
x86_64:dctc-0.85.9nb17.tgz(NetBSD 8.0)
x86_64:dctc-0.85.9nb19.tgz(NetBSD 8.0)
x86_64:dctc-0.85.9nb17.tgz(NetBSD 9.0)
x86_64:dctc-0.85.9nb18.tgz(NetBSD 9.0)
x86_64:dctc-0.85.9nb19.tgz(NetBSD 9.0)
x86_64:dctc-0.85.9nb19.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]