misc/ocaml-magic-mime - The NetBSD Packages Collection

Convert file extensions to MIME types

This library contains a database of MIME types that maps filename extensions
into MIME types suitable for use in many Internet protocols such as HTTP or
e-mail. It is generated from the mime.types file found in Unix systems, but has
no dependency on a filesystem since it includes the contents of the database as
an ML datastructure.

Build dependencies

misc/ocaml-opaline pkgtools/cwrappers misc/ocaml-opaline

Runtime dependencies

devel/ocaml-dune devel/ocaml-findlib lang/ocaml devel/ocaml-dune devel/ocaml-findlib

Binary packages

OSArchitectureVersion
NetBSD 8.0i386ocaml-magic-mime-1.1.2.tgz
NetBSD 8.0i386ocaml-magic-mime-1.1.2.tgz
NetBSD 8.0i386ocaml-magic-mime-1.1.2nb1.tgz
NetBSD 8.0powerpcocaml-magic-mime-1.1.2.tgz
NetBSD 8.0powerpcocaml-magic-mime-1.1.2.tgz
NetBSD 8.0x86_64ocaml-magic-mime-1.1.2.tgz
NetBSD 8.0x86_64ocaml-magic-mime-1.1.2.tgz
NetBSD 9.0aarch64ocaml-magic-mime-1.1.2nb1.tgz
NetBSD 9.0aarch64ocaml-magic-mime-1.1.2.tgz
NetBSD 9.0aarch64ocaml-magic-mime-1.1.2.tgz
NetBSD 9.0earmv6hfocaml-magic-mime-1.1.2nb1.tgz
NetBSD 9.0earmv6hfocaml-magic-mime-1.1.2.tgz
NetBSD 9.0earmv6hfocaml-magic-mime-1.1.2.tgz
NetBSD 9.0earmv7hfocaml-magic-mime-1.1.2nb1.tgz
NetBSD 9.0earmv7hfocaml-magic-mime-1.1.2.tgz
NetBSD 9.0earmv7hfocaml-magic-mime-1.1.2.tgz
NetBSD 9.0i386ocaml-magic-mime-1.1.2.tgz
NetBSD 9.0i386ocaml-magic-mime-1.1.2.tgz
NetBSD 9.0i386ocaml-magic-mime-1.1.2nb1.tgz
NetBSD 9.0powerpcocaml-magic-mime-1.1.2.tgz
NetBSD 9.0x86_64ocaml-magic-mime-1.1.2.tgz
NetBSD 9.0x86_64ocaml-magic-mime-1.1.2.tgz
NetBSD 9.0x86_64ocaml-magic-mime-1.1.2.tgz
NetBSD 9.0x86_64ocaml-magic-mime-1.1.2.tgz
NetBSD 9.0x86_64ocaml-magic-mime-1.1.2.tgz
NetBSD 9.0x86_64ocaml-magic-mime-1.1.2nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.