misc/kchmviewer - The NetBSD Packages Collection

CHM (MS HTML help file format) viewer

KchmViewer is a CHM (MS HTML help file format) viewer, written in
C++. Unlike most existing CHM viewers for Unix, it uses Trolltech
Qt widget library with optional KDE libraries. It does not require
KDE, but may be compiled with full KDE support, including KDE
widgets and KIO/KHTML.

The main advantage of KchmViewer is extra support for non-English
languages. Unlike other viewers, KchmViewer in most cases is able
to detect help file encoding, correctly shows tables of context of
Russian, Korean, Chinese and Japanese help files, and does correct
search in non-English help files (search for MBCS languages -
ja/ko/ch is still in progress).

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake

Runtime dependencies

archivers/libzip devel/chmlib x11/qt5-qtbase x11/qt5-qtwebkit archivers/libzip devel/chmlib x11/qt5-qtbase x11/qt5-qtwebkit

Available binary packages

aarch64:kchmviewer-7.2.1nb52.tgz(NetBSD 9.0)
aarch64:kchmviewer-7.2.1nb53.tgz(NetBSD 9.0)
aarch64:kchmviewer-7.2.1nb54.tgz(NetBSD 9.0)
i386:kchmviewer-7.2.1nb52.tgz(NetBSD 8.0)
i386:kchmviewer-7.2.1nb53.tgz(NetBSD 8.0)
i386:kchmviewer-7.2.1nb54.tgz(NetBSD 8.0)
i386:kchmviewer-7.2.1nb52.tgz(NetBSD 9.0)
i386:kchmviewer-7.2.1nb53.tgz(NetBSD 9.0)
i386:kchmviewer-7.2.1nb54.tgz(NetBSD 9.0)
x86_64:kchmviewer-7.2.1nb54.tgz(NetBSD 9.0)
x86_64:kchmviewer-7.2.1nb54.tgz(NetBSD 9.0)
x86_64:kchmviewer-7.2.1nb54.tgz(NetBSD 9.0)
x86_64:kchmviewer-7.2.1nb53.tgz(NetBSD 9.0)
x86_64:kchmviewer-7.2.1nb53.tgz(NetBSD 8.0)
x86_64:kchmviewer-7.2.1nb52.tgz(NetBSD 8.0)
x86_64:kchmviewer-7.2.1nb54.tgz(NetBSD 8.0)
x86_64:kchmviewer-7.2.1nb52.tgz(NetBSD 9.0)
x86_64:kchmviewer-7.2.1nb53.tgz(NetBSD 9.0)
x86_64:kchmviewer-7.2.1nb54.tgz(NetBSD 9.0)
x86_64:kchmviewer-7.2.1nb54.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]