misc/gwaei - The NetBSD Packages Collection

Japanese dictionary for GNOME

gWaei is a Japanese-English dictionary program for the GNOME desktop.
It is made to be a modern drop in replacement for Gjiten with many
of the same features. The dictionary files it uses are from Jim
Breen's WWWJDIC project and are installed separately through the
program.

Features
  * Easy dictionary installation with a click of a button.
  * Support for searching using regular expressions.
  * Streams results so the interface is never frozen.
  * Click Kanji in the results pane to look information on it.
  * Simple interface that makes sense.
  * Intelligent design. Tab switches dictionaries.
  * Organizes relevant matches to the top of the results.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto textproc/gnome-doc-utils pkgtools/cwrappers devel/glib2-tools devel/libtool-base textproc/intltool devel/gmake lang/perl5 devel/pkgconf

Runtime dependencies

sysutils/desktop-file-utils x11/libunique3 textproc/rarian devel/glib2 devel/glib2 www/curl www/curl x11/gtk3 x11/gtk3 textproc/hunspell textproc/mecab-base devel/ncursesw sysutils/gsettings-desktop-schemas sysutils/desktop-file-utils devel/glib2 www/curl x11/gtk3 textproc/hunspell devel/ncursesw

Available binary packages

aarch64:gwaei-3.6.2nb35.tgz(NetBSD 9.0)
aarch64:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
aarch64:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
alpha:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
earmv6hf:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
earmv6hf:gwaei-3.6.2nb35.tgz(NetBSD 9.0)
earmv6hf:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
earmv6hf:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
earmv7hf:gwaei-3.6.2nb37.tgz(NetBSD 8.0)
earmv7hf:gwaei-3.6.2nb33.tgz(NetBSD 8.0)
earmv7hf:gwaei-3.6.2nb35.tgz(NetBSD 8.0)
earmv7hf:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
earmv7hf:gwaei-3.6.2nb33.tgz(NetBSD 9.0)
earmv7hf:gwaei-3.6.2nb35.tgz(NetBSD 9.0)
earmv7hf:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
earmv7hf:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
i386:gwaei-3.6.2nb35.tgz(NetBSD 8.0)
i386:gwaei-3.6.2nb37.tgz(NetBSD 8.0)
i386:gwaei-3.6.2nb37.tgz(NetBSD 8.0)
i386:gwaei-3.6.2nb35.tgz(NetBSD 9.0)
i386:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
i386:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
mips64eb:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
powerpc:gwaei-3.6.2nb35.tgz(NetBSD 8.0)
powerpc:gwaei-3.6.2nb37.tgz(NetBSD 8.0)
powerpc:gwaei-3.6.2nb37.tgz(NetBSD 8.0)
powerpc:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
powerpc:gwaei-3.6.2nb35.tgz(NetBSD 9.0)
sparc64:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
sparc64:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
x86_64:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
x86_64:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
x86_64:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
x86_64:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
x86_64:gwaei-3.6.2nb37.tgz(NetBSD 8.0)
x86_64:gwaei-3.6.2nb35.tgz(NetBSD 8.0)
x86_64:gwaei-3.6.2nb37.tgz(NetBSD 8.0)
x86_64:gwaei-3.6.2nb35.tgz(NetBSD 9.0)
x86_64:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
x86_64:gwaei-3.6.2nb37.tgz(NetBSD 9.0)
x86_64:gwaei-3.6.2nb37.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gnome
Enable GNOME support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]