misc/celestia - The NetBSD Packages Collection

Free real-time 3D space simulator

Celestia is a free real-time space simulation that lets you experience our
universe in three dimensions.  Unlike most planetarium software, Celestia
doesn't confine you to the surface of the Earth.  You can travel throughout
the solar system, to any of over 100,000 stars, or even beyond the galaxy.
All travel in Celestia is seamless; the exponential zoom feature lets you
explore space across a huge range of scales, from galaxy clusters down to
spacecraft only a few meters across.  A 'point-and-goto' interface makes it
simple to navigate through the universe to the object you want to visit.

This is the base package with data and simple GLUT-driven display window.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

lang/lua51 graphics/gtkglext graphics/png graphics/glu graphics/glu multimedia/libtheora graphics/jpeg sysutils/desktop-file-utils graphics/gtkglext graphics/png graphics/glu multimedia/libtheora graphics/jpeg sysutils/desktop-file-utils

Available binary packages

aarch64:celestia-1.6.1nb24.tgz(NetBSD 9.0)
aarch64:celestia-1.6.1nb25.tgz(NetBSD 9.0)
aarch64:celestia-1.6.1nb26.tgz(NetBSD 9.0)
alpha:celestia-1.6.1nb25.tgz(NetBSD 9.0)
earmv6hf:celestia-1.6.1nb26.tgz(NetBSD 9.0)
earmv6hf:celestia-1.6.1nb24.tgz(NetBSD 9.0)
earmv6hf:celestia-1.6.1nb25.tgz(NetBSD 9.0)
earmv6hf:celestia-1.6.1nb26.tgz(NetBSD 9.0)
earmv7hf:celestia-1.6.1nb26.tgz(NetBSD 8.0)
earmv7hf:celestia-1.6.1nb23.tgz(NetBSD 8.0)
earmv7hf:celestia-1.6.1nb24.tgz(NetBSD 8.0)
earmv7hf:celestia-1.6.1nb26.tgz(NetBSD 9.0)
earmv7hf:celestia-1.6.1nb23.tgz(NetBSD 9.0)
earmv7hf:celestia-1.6.1nb24.tgz(NetBSD 9.0)
earmv7hf:celestia-1.6.1nb25.tgz(NetBSD 9.0)
earmv7hf:celestia-1.6.1nb26.tgz(NetBSD 9.0)
i386:celestia-1.6.1nb24.tgz(NetBSD 8.0)
i386:celestia-1.6.1nb25.tgz(NetBSD 8.0)
i386:celestia-1.6.1nb26.tgz(NetBSD 8.0)
i386:celestia-1.6.1nb24.tgz(NetBSD 9.0)
i386:celestia-1.6.1nb25.tgz(NetBSD 9.0)
i386:celestia-1.6.1nb26.tgz(NetBSD 9.0)
mips64eb:celestia-1.6.1nb25.tgz(NetBSD 9.0)
powerpc:celestia-1.6.1nb24.tgz(NetBSD 8.0)
powerpc:celestia-1.6.1nb26.tgz(NetBSD 8.0)
powerpc:celestia-1.6.1nb25.tgz(NetBSD 8.0)
powerpc:celestia-1.6.1nb25.tgz(NetBSD 9.0)
powerpc:celestia-1.6.1nb24.tgz(NetBSD 9.0)
sparc64:celestia-1.6.1nb26.tgz(NetBSD 9.0)
sparc64:celestia-1.6.1nb25.tgz(NetBSD 9.0)
x86_64:celestia-1.6.1nb26.tgz(NetBSD 9.0)
x86_64:celestia-1.6.1nb26.tgz(NetBSD 9.0)
x86_64:celestia-1.6.1nb26.tgz(NetBSD 9.0)
x86_64:celestia-1.6.1nb25.tgz(NetBSD 9.0)
x86_64:celestia-1.6.1nb25.tgz(NetBSD 8.0)
x86_64:celestia-1.6.1nb24.tgz(NetBSD 8.0)
x86_64:celestia-1.6.1nb26.tgz(NetBSD 8.0)
x86_64:celestia-1.6.1nb24.tgz(NetBSD 9.0)
x86_64:celestia-1.6.1nb25.tgz(NetBSD 9.0)
x86_64:celestia-1.6.1nb26.tgz(NetBSD 9.0)
x86_64:celestia-1.6.1nb26.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

lua
Enable Lua support.
glut
gnome
Enable GNOME support.
gtk
Enable support for GTK.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]