meta-pkgs/gnuradio - The NetBSD Packages Collection

Collection of GNU Radio (meta package, easy to install whole thing)

Meta package for collection of gnuradio:
GNU Radio is a collection of software that when combined with minimal hardware,
allows the construction of radios where the actual waveforms transmitted and
received are defined by software. What this means is that it turns the digital
modulation schemes used in today's high performance wireless devices into
software problems.

This is a meta package to install all of the GNU Radio modules.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

ham/gnuradio-channels ham/gnuradio-network ham/gnuradio-companion ham/gnuradio-core ham/gnuradio-ctrlport ham/gnuradio-digital ham/gnuradio-doxygen ham/gnuradio-dtv ham/gnuradio-fec ham/gnuradio-qtgui ham/gnuradio-trellis ham/gnuradio-uhd ham/gnuradio-utils ham/gnuradio-video-sdl ham/gnuradio-vocoder ham/gnuradio-wavelet ham/gnuradio-zeromq

Binary packages

OSArchitectureVersion
NetBSD 8.0i386gnuradio-3.8.1.0.tgz
NetBSD 8.0x86_64gnuradio-3.8.1.0.tgz
NetBSD 8.0x86_64gnuradio-3.8.1.0.tgz
NetBSD 8.0x86_64gnuradio-3.8.1.0.tgz
NetBSD 9.0aarch64gnuradio-3.8.1.0.tgz
NetBSD 9.0aarch64gnuradio-3.8.1.0.tgz
NetBSD 9.0aarch64gnuradio-3.8.1.0.tgz
NetBSD 9.0i386gnuradio-3.8.1.0.tgz
NetBSD 9.0i386gnuradio-3.8.1.0.tgz
NetBSD 9.0i386gnuradio-3.8.1.0.tgz
NetBSD 9.0x86_64gnuradio-3.8.1.0.tgz
NetBSD 9.0x86_64gnuradio-3.8.1.0.tgz
NetBSD 9.0x86_64gnuradio-3.8.1.0.tgz
NetBSD 9.0x86_64gnuradio-3.8.1.0.tgz
NetBSD 9.0x86_64gnuradio-3.8.1.0.tgz
NetBSD 9.0x86_64gnuradio-3.8.1.0.tgz
NetBSD 9.0x86_64gnuradio-3.8.1.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.