math/sc-im - The NetBSD Packages Collection

Curses-based spreadsheet program based on sc

'SC Improved', a curses-based spreadsheet program based on sc.  New features
include undo and redo, colors, sorting, plotting and XLS[X] support.

Build dependencies

pkgtools/cwrappers devel/gmake devel/pkgconf

Runtime dependencies

shells/bash devel/ncursesw textproc/libxls archivers/libzip textproc/libxml2 textproc/libxlsxwriter lang/lua51 devel/ncursesw archivers/libzip textproc/libxml2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfsc-im-0.7.0nb19.tgz
NetBSD 8.0earmv7hfsc-im-0.7.0nb16.tgz
NetBSD 8.0earmv7hfsc-im-0.8.0.tgz
NetBSD 8.0earmv7hfsc-im-0.8.0nb2.tgz
NetBSD 8.0i386sc-im-0.7.0nb16.tgz
NetBSD 8.0i386sc-im-0.7.0nb19.tgz
NetBSD 8.0i386sc-im-0.8.0.tgz
NetBSD 8.0i386sc-im-0.8.0nb2.tgz
NetBSD 8.0powerpcsc-im-0.7.0nb16.tgz
NetBSD 8.0powerpcsc-im-0.7.0nb19.tgz
NetBSD 8.0powerpcsc-im-0.8.0.tgz
NetBSD 8.0powerpcsc-im-0.8.0nb2.tgz
NetBSD 8.0powerpcsc-im-0.8.0nb2.tgz
NetBSD 8.0x86_64sc-im-0.8.0.tgz
NetBSD 8.0x86_64sc-im-0.7.0nb16.tgz
NetBSD 8.0x86_64sc-im-0.7.0nb19.tgz
NetBSD 8.0x86_64sc-im-0.8.0nb2.tgz
NetBSD 9.0aarch64sc-im-0.8.0nb2.tgz
NetBSD 9.0aarch64sc-im-0.7.0nb16.tgz
NetBSD 9.0aarch64sc-im-0.7.0nb19.tgz
NetBSD 9.0aarch64sc-im-0.8.0.tgz
NetBSD 9.0alphasc-im-0.8.0nb2.tgz
NetBSD 9.0alphasc-im-0.7.0nb19.tgz
NetBSD 9.0alphasc-im-0.8.0.tgz
NetBSD 9.0earmv6hfsc-im-0.8.0nb2.tgz
NetBSD 9.0earmv6hfsc-im-0.7.0nb16.tgz
NetBSD 9.0earmv6hfsc-im-0.7.0nb19.tgz
NetBSD 9.0earmv6hfsc-im-0.7.0nb19.tgz
NetBSD 9.0earmv6hfsc-im-0.8.0.tgz
NetBSD 9.0earmv7hfsc-im-0.8.0nb2.tgz
NetBSD 9.0earmv7hfsc-im-0.7.0nb16.tgz
NetBSD 9.0earmv7hfsc-im-0.7.0nb19.tgz
NetBSD 9.0earmv7hfsc-im-0.7.0nb19.tgz
NetBSD 9.0earmv7hfsc-im-0.8.0.tgz
NetBSD 9.0earmv7hfsc-im-0.8.0.tgz
NetBSD 9.0earmv7hfsc-im-0.8.0nb2.tgz
NetBSD 9.0i386sc-im-0.7.0nb16.tgz
NetBSD 9.0i386sc-im-0.7.0nb19.tgz
NetBSD 9.0i386sc-im-0.8.0.tgz
NetBSD 9.0i386sc-im-0.8.0nb2.tgz
NetBSD 9.0mips64ebsc-im-0.8.0nb2.tgz
NetBSD 9.0mips64ebsc-im-0.7.0nb16.tgz
NetBSD 9.0mips64ebsc-im-0.7.0nb19.tgz
NetBSD 9.0mips64ebsc-im-0.7.0nb19.tgz
NetBSD 9.0mips64ebsc-im-0.8.0.tgz
NetBSD 9.0powerpcsc-im-0.8.0nb2.tgz
NetBSD 9.0powerpcsc-im-0.7.0nb16.tgz
NetBSD 9.0powerpcsc-im-0.7.0nb19.tgz
NetBSD 9.0powerpcsc-im-0.8.0.tgz
NetBSD 9.0powerpcsc-im-0.8.0nb2.tgz
NetBSD 9.0sparc64sc-im-0.8.0nb2.tgz
NetBSD 9.0sparc64sc-im-0.7.0nb19.tgz
NetBSD 9.0sparc64sc-im-0.8.0.tgz
NetBSD 9.0sparcsc-im-0.8.0nb2.tgz
NetBSD 9.0sparcsc-im-0.8.0.tgz
NetBSD 9.0x86_64sc-im-0.7.0nb19.tgz
NetBSD 9.0x86_64sc-im-0.8.0nb2.tgz
NetBSD 9.0x86_64sc-im-0.8.0.tgz
NetBSD 9.0x86_64sc-im-0.8.0nb2.tgz
NetBSD 9.0x86_64sc-im-0.7.0nb16.tgz
NetBSD 9.0x86_64sc-im-0.7.0nb19.tgz
NetBSD 9.0x86_64sc-im-0.8.0.tgz
NetBSD 9.0x86_64sc-im-0.8.0nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

color
Enable color support.
lua
Enable Lua support.
xls
Enable XLS support.
xlsx
Enable XLSX support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.