math/py-numarray - The NetBSD Packages Collection

Array manipulation

Numarray is an array processing package designed to efficiently
manipulate large multi-dimensional arrays.  Numarray is modelled after
Numeric and features c-code generated from python template scripts,
the capacity to operate directly on arrays in files, and improved type
promotions.  Numarray provides support for manipulating arrays
consisting of numbers, strings, records, or objects using the same
basic infrastructure and syntax.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy27-numarray-1.5.2nb1.tgz
NetBSD 8.0earmv7hfpy27-numarray-1.5.2nb1.tgz
NetBSD 8.0earmv7hfpy27-numarray-1.5.2nb1.tgz
NetBSD 8.0earmv7hfpy27-numarray-1.5.2nb1.tgz
NetBSD 8.0i386py27-numarray-1.5.2nb1.tgz
NetBSD 8.0i386py27-numarray-1.5.2nb1.tgz
NetBSD 8.0i386py27-numarray-1.5.2nb1.tgz
NetBSD 8.0i386py27-numarray-1.5.2nb1.tgz
NetBSD 8.0powerpcpy27-numarray-1.5.2nb1.tgz
NetBSD 8.0powerpcpy27-numarray-1.5.2nb1.tgz
NetBSD 8.0powerpcpy27-numarray-1.5.2nb1.tgz
NetBSD 8.0powerpcpy27-numarray-1.5.2nb1.tgz
NetBSD 8.0powerpcpy27-numarray-1.5.2nb1.tgz
NetBSD 8.0x86_64py27-numarray-1.5.2nb1.tgz
NetBSD 8.0x86_64py27-numarray-1.5.2nb1.tgz
NetBSD 8.0x86_64py27-numarray-1.5.2nb1.tgz
NetBSD 8.0x86_64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0aarch64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0aarch64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0aarch64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0aarch64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0alphapy27-numarray-1.5.2nb1.tgz
NetBSD 9.0alphapy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmv6hfpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmv6hfpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmv6hfpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmv6hfpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmv6hfpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmv7hfpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmv7hfpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmv7hfpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmv7hfpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmv7hfpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmv7hfpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0earmv7hfpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0i386py27-numarray-1.5.2nb1.tgz
NetBSD 9.0i386py27-numarray-1.5.2nb1.tgz
NetBSD 9.0i386py27-numarray-1.5.2nb1.tgz
NetBSD 9.0i386py27-numarray-1.5.2nb1.tgz
NetBSD 9.0mips64ebpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0mips64ebpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0mips64ebpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0mips64ebpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0mipselpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0mipselpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0mipselpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0powerpcpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0powerpcpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0powerpcpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0powerpcpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0powerpcpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0sh3elpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0sh3elpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0sh3elpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0sparc64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0sparc64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0sparcpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0sparcpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0sparcpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0sparcpy27-numarray-1.5.2nb1.tgz
NetBSD 9.0x86_64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0x86_64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0x86_64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0x86_64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0x86_64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0x86_64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0x86_64py27-numarray-1.5.2nb1.tgz
NetBSD 9.0x86_64py27-numarray-1.5.2nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.