math/openfst - The NetBSD Packages Collection

OpenFst is a library for manipulating transducers

OpenFst is a library for constructing, combining, optimizing, and
searching weighted finite-state transducers (FSTs). Weighted
finite-state transducers are automata where each transition has an
input label, an output label, and a weight. The more familiar
finite-state acceptor is represented as a transducer with each
transition's input and output label equal. Finite-state acceptors
are used to represent sets of strings (specifically, regular or
rational sets); finite-state transducers are used to represent
binary relations between pairs of strings (specifically, rational
transductions). The weights can be used to represent the cost of
taking a particular transition.

This library was developed by contributors from Google Research
and NYU's Courant Institute. It is intended to be comprehensive,
flexible, efficient and scale well to large problems. it has been
extensively tested. It is an open source project distributed under
the Apache license.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfopenfst-1.1.tgz
NetBSD 8.0earmv7hfopenfst-1.1.tgz
NetBSD 8.0earmv7hfopenfst-1.1.tgz
NetBSD 8.0earmv7hfopenfst-1.1.tgz
NetBSD 8.0i386openfst-1.1.tgz
NetBSD 8.0i386openfst-1.1.tgz
NetBSD 8.0i386openfst-1.1.tgz
NetBSD 8.0i386openfst-1.1.tgz
NetBSD 8.0powerpcopenfst-1.1.tgz
NetBSD 8.0powerpcopenfst-1.1.tgz
NetBSD 8.0powerpcopenfst-1.1.tgz
NetBSD 8.0powerpcopenfst-1.1.tgz
NetBSD 8.0powerpcopenfst-1.1.tgz
NetBSD 8.0x86_64openfst-1.1.tgz
NetBSD 8.0x86_64openfst-1.1.tgz
NetBSD 8.0x86_64openfst-1.1.tgz
NetBSD 8.0x86_64openfst-1.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.