math/eigen3 - The NetBSD Packages Collection

C++ template library for linear algebra

Eigen 3 is a C++ template library for linear algebra: It is:
* Versatile. Eigen handles and in a completely integrated way:
  o both fixed-size and dynamic-size matrices and vectors.
  o both dense and sparse matrices and vectors.
  o both plain matrices/vectors and abstract expressions.
  o both column-major (the default) and row-major matrix storage.
  o both basic matrix/vector manipulation and many more advanced, specialized
    modules providing algorithms for linear algebra, geometry, quaternions,
    or advanced array manipulation.
* Fast.
  o Expression templates allow to intelligently remove temporaries and enable
    lazy evaluation, when that is appropriate.
  o Explicit vectorization is performed for the SSE (2 and later) and AltiVec
    instruction sets, with graceful fallback to non-vectorized code.
  o With fixed-size objects, dynamic memory allocation is avoided, and the
    loops are unrolled when that makes sense.
  o For large matrices, special attention is paid to cache-friendliness.
* Elegant. The API is extremely clean and expressive, thanks to expression
  templates. Implementing an algorithm on top of Eigen feels like just copying
  pseudocode. You can use complex expressions and still rely on Eigen to
  produce optimized code: there is no need for you to manually decompose
  expressions into small steps.
* Compiler-friendy. Eigen has good compiler support, is standard C++98 and
  maintains very reasonable compilation times.

Build dependencies

pkgtools/cwrappers devel/cmake

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfeigen3-3.3.7nb2.tgz
NetBSD 8.0earmv7hfeigen3-3.3.7nb2.tgz
NetBSD 8.0earmv7hfeigen3-3.3.9.tgz
NetBSD 8.0i386eigen3-3.3.7nb2.tgz
NetBSD 8.0i386eigen3-3.3.7nb2.tgz
NetBSD 8.0i386eigen3-3.3.9.tgz
NetBSD 8.0powerpceigen3-3.3.7nb2.tgz
NetBSD 8.0powerpceigen3-3.3.7nb2.tgz
NetBSD 8.0powerpceigen3-3.3.7nb2.tgz
NetBSD 8.0x86_64eigen3-3.3.9.tgz
NetBSD 8.0x86_64eigen3-3.3.7nb2.tgz
NetBSD 8.0x86_64eigen3-3.3.7nb2.tgz
NetBSD 9.0aarch64eigen3-3.3.9.tgz
NetBSD 9.0aarch64eigen3-3.3.7nb2.tgz
NetBSD 9.0aarch64eigen3-3.3.7nb2.tgz
NetBSD 9.0alphaeigen3-3.3.9.tgz
NetBSD 9.0alphaeigen3-3.3.7nb2.tgz
NetBSD 9.0alphaeigen3-3.3.7nb2.tgz
NetBSD 9.0earmeigen3-3.3.7nb2.tgz
NetBSD 9.0earmeigen3-3.3.7nb2.tgz
NetBSD 9.0earmeigen3-3.3.9.tgz
NetBSD 9.0earmv6hfeigen3-3.3.9.tgz
NetBSD 9.0earmv6hfeigen3-3.3.7nb2.tgz
NetBSD 9.0earmv6hfeigen3-3.3.7nb2.tgz
NetBSD 9.0earmv6hfeigen3-3.3.7nb2.tgz
NetBSD 9.0earmv7hfeigen3-3.3.9.tgz
NetBSD 9.0earmv7hfeigen3-3.3.7nb2.tgz
NetBSD 9.0earmv7hfeigen3-3.3.7nb2.tgz
NetBSD 9.0earmv7hfeigen3-3.3.7nb2.tgz
NetBSD 9.0i386eigen3-3.3.7nb2.tgz
NetBSD 9.0i386eigen3-3.3.7nb2.tgz
NetBSD 9.0i386eigen3-3.3.9.tgz
NetBSD 9.0m68keigen3-3.3.7nb2.tgz
NetBSD 9.0m68keigen3-3.3.7nb2.tgz
NetBSD 9.0mips64ebeigen3-3.3.9.tgz
NetBSD 9.0mips64ebeigen3-3.3.7nb2.tgz
NetBSD 9.0mips64ebeigen3-3.3.7nb2.tgz
NetBSD 9.0mipseleigen3-3.3.9.tgz
NetBSD 9.0powerpceigen3-3.3.7nb2.tgz
NetBSD 9.0powerpceigen3-3.3.7nb2.tgz
NetBSD 9.0sh3eleigen3-3.3.7nb2.tgz
NetBSD 9.0sh3eleigen3-3.3.7nb2.tgz
NetBSD 9.0sh3eleigen3-3.3.9.tgz
NetBSD 9.0sparc64eigen3-3.3.9.tgz
NetBSD 9.0sparc64eigen3-3.3.7nb2.tgz
NetBSD 9.0sparc64eigen3-3.3.7nb2.tgz
NetBSD 9.0sparc64eigen3-3.3.7nb2.tgz
NetBSD 9.0sparceigen3-3.3.9.tgz
NetBSD 9.0sparceigen3-3.3.7nb2.tgz
NetBSD 9.0sparceigen3-3.3.7nb2.tgz
NetBSD 9.0x86_64eigen3-3.3.7nb2.tgz
NetBSD 9.0x86_64eigen3-3.3.7nb2.tgz
NetBSD 9.0x86_64eigen3-3.3.7nb2.tgz
NetBSD 9.0x86_64eigen3-3.3.9.tgz
NetBSD 9.0x86_64eigen3-3.3.7nb2.tgz
NetBSD 9.0x86_64eigen3-3.3.7nb2.tgz
NetBSD 9.0x86_64eigen3-3.3.9.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.