mail/roundcube-plugin-enigma - The NetBSD Packages Collection

Enigma Plugin for Roundcube

Enigma Plugin for Roundcube

This plugin adds support for viewing and sending of signed and encrypted
messages in PGP (RFC 2440) and PGP/MIME (RFC 3156) format.

The plugin uses gpg binary on the server and stores all keys
(including private keys of the users) on the server.
Encryption/decryption is done server-side. So, this plugin
is for users that trust the server.


Implemented features:
---------------------
+ PGP: signatures verification
+ PGP: messages decryption
+ PGP: Sending of encrypted/signed messages
+ PGP: keys management UI (key import, export, delete)
+ PGP: key generation (client- or server-side)
+ Handling of PGP keys attached to incoming messages
+ User preferences to disable plugin features
+ Attaching public keys to email

Build dependencies

www/apache24 pkgtools/cwrappers www/apache24 lang/perl5

Runtime dependencies

security/pear-Crypt_GPG mail/roundcube databases/php-pdo_mysql converters/php-iconv net/php-sockets graphics/php-gd lang/python38 lang/python38

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfphp56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 8.0earmv7hfphp72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 8.0earmv7hfphp73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 8.0earmv7hfphp74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 8.0earmv7hfphp56-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 8.0earmv7hfphp72-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 8.0earmv7hfphp73-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 8.0earmv7hfphp74-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 8.0earmv7hfphp56-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 8.0earmv7hfphp73-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 8.0earmv7hfphp74-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 8.0earmv7hfphp80-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 8.0i386php56-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 8.0i386php72-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 8.0i386php73-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 8.0i386php74-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 8.0i386php56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 8.0i386php72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 8.0i386php73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 8.0i386php74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 8.0i386php56-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 8.0i386php73-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 8.0i386php74-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 8.0i386php80-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 8.0x86_64php56-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 8.0x86_64php73-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 8.0x86_64php74-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 8.0x86_64php80-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 8.0x86_64php56-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 8.0x86_64php72-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 8.0x86_64php73-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 8.0x86_64php74-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 8.0x86_64php56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 8.0x86_64php72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 8.0x86_64php73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 8.0x86_64php74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0aarch64php56-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0aarch64php73-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0aarch64php74-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0aarch64php80-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0aarch64php56-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0aarch64php72-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0aarch64php73-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0aarch64php74-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0aarch64php56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0aarch64php72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0aarch64php73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0aarch64php74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv6hfphp56-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0earmv6hfphp73-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0earmv6hfphp74-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0earmv6hfphp80-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0earmv6hfphp56-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0earmv6hfphp72-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0earmv6hfphp73-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0earmv6hfphp74-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0earmv6hfphp56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv6hfphp72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv6hfphp73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv6hfphp74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv6hfphp56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv6hfphp72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv6hfphp73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv6hfphp74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv7hfphp56-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0earmv7hfphp73-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0earmv7hfphp74-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0earmv7hfphp80-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0earmv7hfphp56-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0earmv7hfphp72-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0earmv7hfphp73-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0earmv7hfphp74-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0earmv7hfphp56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv7hfphp72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv7hfphp73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv7hfphp74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv7hfphp56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv7hfphp72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv7hfphp73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv7hfphp74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0earmv7hfphp56-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0earmv7hfphp73-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0earmv7hfphp74-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0earmv7hfphp80-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0i386php56-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0i386php72-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0i386php73-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0i386php74-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0i386php56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0i386php72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0i386php73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0i386php74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0i386php56-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0i386php73-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0i386php74-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0i386php80-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0mips64ebphp56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0mips64ebphp56-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0mips64ebphp72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0mips64ebphp73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0mips64ebphp73-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0mips64ebphp74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0mips64ebphp74-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0mips64ebphp80-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0mips64ebphp56-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0mips64ebphp72-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0mips64ebphp73-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0mips64ebphp74-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0mips64ebphp56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0mips64ebphp72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0mips64ebphp73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0mips64ebphp74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0sparc64php56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0sparc64php56-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0sparc64php72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0sparc64php73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0sparc64php73-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0sparc64php74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0sparc64php74-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0sparc64php80-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0sparc64php56-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0sparc64php72-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0sparc64php73-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0sparc64php74-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0sparc64php56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0sparc64php72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0sparc64php73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0sparc64php74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0x86_64php56-roundcube-plugin-enigma-1.4.9.tgz
NetBSD 9.0x86_64php72-roundcube-plugin-enigma-1.4.9.tgz
NetBSD 9.0x86_64php73-roundcube-plugin-enigma-1.4.9.tgz
NetBSD 9.0x86_64php74-roundcube-plugin-enigma-1.4.9.tgz
NetBSD 9.0x86_64php56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0x86_64php72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0x86_64php73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0x86_64php74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0x86_64php56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0x86_64php73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0x86_64php74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0x86_64php56-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0x86_64php73-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0x86_64php74-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0x86_64php80-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0x86_64php56-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0x86_64php72-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0x86_64php73-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0x86_64php74-roundcube-plugin-enigma-1.4.8.tgz
NetBSD 9.0x86_64php56-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0x86_64php72-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0x86_64php73-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0x86_64php74-roundcube-plugin-enigma-1.4.10.tgz
NetBSD 9.0x86_64php56-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0x86_64php73-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0x86_64php74-roundcube-plugin-enigma-1.4.11.tgz
NetBSD 9.0x86_64php80-roundcube-plugin-enigma-1.4.11.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gd
Use GD to render graphical output.
iconv
Use iconv for character encoding conversion.
ldap
Enable LDAP support.
php-sockets
Enable php-sockets support.
mysql
Enable MySQL support.
pgsql
Enable PostgreSQL support.
sqlite
Enable SQLite support.
apache
Enable support for Apache web server.
lighttpd
nginx
Enable support for Nginx web server.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.