mail/queue-fix - The NetBSD Packages Collection

Check and repair the qmail queue structure

This is a small utility for checking and repairing the qmail queue
structure.  It will fix uid/gid settings and permissions.  It will
rename the message files to match their inodes.  It will even create
directories and files that don't exist that should be there (you can
even create a queue from scratch).  It will also print warnings for
any files it finds that should not exist.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfqueue-fix-1.4nb1.tgz
NetBSD 8.0earmv7hfqueue-fix-1.4nb1.tgz
NetBSD 8.0earmv7hfqueue-fix-1.4nb1.tgz
NetBSD 8.0earmv7hfqueue-fix-1.4nb1.tgz
NetBSD 8.0i386queue-fix-1.4nb1.tgz
NetBSD 8.0i386queue-fix-1.4nb1.tgz
NetBSD 8.0i386queue-fix-1.4nb1.tgz
NetBSD 8.0i386queue-fix-1.4nb1.tgz
NetBSD 8.0powerpcqueue-fix-1.4nb1.tgz
NetBSD 8.0powerpcqueue-fix-1.4nb1.tgz
NetBSD 8.0powerpcqueue-fix-1.4nb1.tgz
NetBSD 8.0powerpcqueue-fix-1.4nb1.tgz
NetBSD 8.0powerpcqueue-fix-1.4nb1.tgz
NetBSD 8.0x86_64queue-fix-1.4nb1.tgz
NetBSD 8.0x86_64queue-fix-1.4nb1.tgz
NetBSD 8.0x86_64queue-fix-1.4nb1.tgz
NetBSD 8.0x86_64queue-fix-1.4nb1.tgz
NetBSD 9.0aarch64queue-fix-1.4nb1.tgz
NetBSD 9.0aarch64queue-fix-1.4nb1.tgz
NetBSD 9.0aarch64queue-fix-1.4nb1.tgz
NetBSD 9.0aarch64queue-fix-1.4nb1.tgz
NetBSD 9.0alphaqueue-fix-1.4nb1.tgz
NetBSD 9.0alphaqueue-fix-1.4nb1.tgz
NetBSD 9.0earmqueue-fix-1.4nb1.tgz
NetBSD 9.0earmqueue-fix-1.4nb1.tgz
NetBSD 9.0earmv6hfqueue-fix-1.4nb1.tgz
NetBSD 9.0earmv6hfqueue-fix-1.4nb1.tgz
NetBSD 9.0earmv6hfqueue-fix-1.4nb1.tgz
NetBSD 9.0earmv6hfqueue-fix-1.4nb1.tgz
NetBSD 9.0earmv6hfqueue-fix-1.4nb1.tgz
NetBSD 9.0earmv7hfqueue-fix-1.4nb1.tgz
NetBSD 9.0earmv7hfqueue-fix-1.4nb1.tgz
NetBSD 9.0earmv7hfqueue-fix-1.4nb1.tgz
NetBSD 9.0earmv7hfqueue-fix-1.4nb1.tgz
NetBSD 9.0earmv7hfqueue-fix-1.4nb1.tgz
NetBSD 9.0earmv7hfqueue-fix-1.4nb1.tgz
NetBSD 9.0earmv7hfqueue-fix-1.4nb1.tgz
NetBSD 9.0i386queue-fix-1.4nb1.tgz
NetBSD 9.0i386queue-fix-1.4nb1.tgz
NetBSD 9.0i386queue-fix-1.4nb1.tgz
NetBSD 9.0i386queue-fix-1.4nb1.tgz
NetBSD 9.0mips64ebqueue-fix-1.4nb1.tgz
NetBSD 9.0mips64ebqueue-fix-1.4nb1.tgz
NetBSD 9.0mips64ebqueue-fix-1.4nb1.tgz
NetBSD 9.0mips64ebqueue-fix-1.4nb1.tgz
NetBSD 9.0powerpcqueue-fix-1.4nb1.tgz
NetBSD 9.0powerpcqueue-fix-1.4nb1.tgz
NetBSD 9.0powerpcqueue-fix-1.4nb1.tgz
NetBSD 9.0powerpcqueue-fix-1.4nb1.tgz
NetBSD 9.0powerpcqueue-fix-1.4nb1.tgz
NetBSD 9.0sparc64queue-fix-1.4nb1.tgz
NetBSD 9.0sparc64queue-fix-1.4nb1.tgz
NetBSD 9.0sparcqueue-fix-1.4nb1.tgz
NetBSD 9.0sparcqueue-fix-1.4nb1.tgz
NetBSD 9.0sparcqueue-fix-1.4nb1.tgz
NetBSD 9.0x86_64queue-fix-1.4nb1.tgz
NetBSD 9.0x86_64queue-fix-1.4nb1.tgz
NetBSD 9.0x86_64queue-fix-1.4nb1.tgz
NetBSD 9.0x86_64queue-fix-1.4nb1.tgz
NetBSD 9.0x86_64queue-fix-1.4nb1.tgz
NetBSD 9.0x86_64queue-fix-1.4nb1.tgz
NetBSD 9.0x86_64queue-fix-1.4nb1.tgz
NetBSD 9.0x86_64queue-fix-1.4nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.