mail/postgrey - The NetBSD Packages Collection

Postfix Greylist Policy Server

Postgrey is a Postfix policy server implementing greylisting developed
by David Schweikert.

Compared to greylist.pl included with Postfix (2.1.1), Postgrey has the
following additional features:
- Safer database handling: Postgrey does use the logging and transaction
  features of BerkeleyDB to maximize reliability.
- Automatical cleaning of the database: Entries that were last seen
  more than a defined amount of time get removed automatically.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

databases/p5-BerkeleyDB devel/p5-IO-Multiplex net/p5-Net-Server net/p5-NetAddr-IP lang/perl5 databases/db4

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpostgrey-1.36nb7.tgz
NetBSD 8.0earmv7hfpostgrey-1.36nb7.tgz
NetBSD 8.0earmv7hfpostgrey-1.36nb7.tgz
NetBSD 8.0earmv7hfpostgrey-1.36nb8.tgz
NetBSD 8.0i386postgrey-1.36nb7.tgz
NetBSD 8.0i386postgrey-1.36nb7.tgz
NetBSD 8.0i386postgrey-1.36nb7.tgz
NetBSD 8.0i386postgrey-1.36nb8.tgz
NetBSD 8.0powerpcpostgrey-1.36nb7.tgz
NetBSD 8.0powerpcpostgrey-1.36nb7.tgz
NetBSD 8.0powerpcpostgrey-1.36nb7.tgz
NetBSD 8.0powerpcpostgrey-1.36nb8.tgz
NetBSD 8.0powerpcpostgrey-1.36nb8.tgz
NetBSD 8.0x86_64postgrey-1.36nb7.tgz
NetBSD 8.0x86_64postgrey-1.36nb7.tgz
NetBSD 8.0x86_64postgrey-1.36nb7.tgz
NetBSD 8.0x86_64postgrey-1.36nb8.tgz
NetBSD 9.0aarch64postgrey-1.36nb8.tgz
NetBSD 9.0aarch64postgrey-1.36nb7.tgz
NetBSD 9.0aarch64postgrey-1.36nb7.tgz
NetBSD 9.0aarch64postgrey-1.36nb7.tgz
NetBSD 9.0alphapostgrey-1.36nb8.tgz
NetBSD 9.0alphapostgrey-1.36nb7.tgz
NetBSD 9.0earmv6hfpostgrey-1.36nb8.tgz
NetBSD 9.0earmv6hfpostgrey-1.36nb7.tgz
NetBSD 9.0earmv6hfpostgrey-1.36nb7.tgz
NetBSD 9.0earmv6hfpostgrey-1.36nb7.tgz
NetBSD 9.0earmv6hfpostgrey-1.36nb7.tgz
NetBSD 9.0earmv7hfpostgrey-1.36nb8.tgz
NetBSD 9.0earmv7hfpostgrey-1.36nb7.tgz
NetBSD 9.0earmv7hfpostgrey-1.36nb7.tgz
NetBSD 9.0earmv7hfpostgrey-1.36nb7.tgz
NetBSD 9.0earmv7hfpostgrey-1.36nb7.tgz
NetBSD 9.0earmv7hfpostgrey-1.36nb7.tgz
NetBSD 9.0earmv7hfpostgrey-1.36nb8.tgz
NetBSD 9.0i386postgrey-1.36nb7.tgz
NetBSD 9.0i386postgrey-1.36nb7.tgz
NetBSD 9.0i386postgrey-1.36nb7.tgz
NetBSD 9.0i386postgrey-1.36nb8.tgz
NetBSD 9.0mips64ebpostgrey-1.36nb8.tgz
NetBSD 9.0mips64ebpostgrey-1.36nb7.tgz
NetBSD 9.0mips64ebpostgrey-1.36nb7.tgz
NetBSD 9.0mips64ebpostgrey-1.36nb7.tgz
NetBSD 9.0powerpcpostgrey-1.36nb8.tgz
NetBSD 9.0powerpcpostgrey-1.36nb7.tgz
NetBSD 9.0powerpcpostgrey-1.36nb7.tgz
NetBSD 9.0powerpcpostgrey-1.36nb7.tgz
NetBSD 9.0powerpcpostgrey-1.36nb8.tgz
NetBSD 9.0sparc64postgrey-1.36nb8.tgz
NetBSD 9.0sparc64postgrey-1.36nb7.tgz
NetBSD 9.0x86_64postgrey-1.36nb7.tgz
NetBSD 9.0x86_64postgrey-1.36nb8.tgz
NetBSD 9.0x86_64postgrey-1.36nb7.tgz
NetBSD 9.0x86_64postgrey-1.36nb8.tgz
NetBSD 9.0x86_64postgrey-1.36nb7.tgz
NetBSD 9.0x86_64postgrey-1.36nb7.tgz
NetBSD 9.0x86_64postgrey-1.36nb7.tgz
NetBSD 9.0x86_64postgrey-1.36nb8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

postgrey-targrey
Enable the Postgrey taRgrey tarpitting patch.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.