mail/perdition - The NetBSD Packages Collection

IMAP/POP3 proxy redirector (main program)

Perdition is a fully featured POP3 and IMAP4 proxy server. It is able to
handle both SSL and non-SSL connections and redirect users to a
real-server based on a database lookup. Perdition supports modular based
database access. ODBC, MySQL, PostgreSQL, GDBM, POSIX Regular Expression
and NIS modules ship with the distribution. The API for modules is open
allowing abitary modules to be written to allow access to any data store.

Perdition can be used to: Create large mail systems where a users mailbox
may be stored on one of several hosts.  Integrate different mail systems
together. Migrate between different email infastructure. And in firewall
applications.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

devel/popt devel/vanessa_adt devel/vanessa_logger devel/vanessa_socket devel/popt devel/vanessa_socket

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfperdition-1.18nb6.tgz
NetBSD 8.0earmv7hfperdition-1.18nb5.tgz
NetBSD 8.0earmv7hfperdition-1.18nb6.tgz
NetBSD 8.0earmv7hfperdition-1.18nb6.tgz
NetBSD 8.0i386perdition-1.18nb5.tgz
NetBSD 8.0i386perdition-1.18nb6.tgz
NetBSD 8.0i386perdition-1.18nb6.tgz
NetBSD 8.0i386perdition-1.18nb6.tgz
NetBSD 8.0powerpcperdition-1.18nb5.tgz
NetBSD 8.0powerpcperdition-1.18nb6.tgz
NetBSD 8.0powerpcperdition-1.18nb6.tgz
NetBSD 8.0powerpcperdition-1.18nb6.tgz
NetBSD 8.0powerpcperdition-1.18nb6.tgz
NetBSD 8.0x86_64perdition-1.18nb6.tgz
NetBSD 8.0x86_64perdition-1.18nb5.tgz
NetBSD 8.0x86_64perdition-1.18nb6.tgz
NetBSD 8.0x86_64perdition-1.18nb6.tgz
NetBSD 9.0aarch64perdition-1.18nb6.tgz
NetBSD 9.0aarch64perdition-1.18nb5.tgz
NetBSD 9.0aarch64perdition-1.18nb6.tgz
NetBSD 9.0aarch64perdition-1.18nb6.tgz
NetBSD 9.0alphaperdition-1.18nb6.tgz
NetBSD 9.0alphaperdition-1.18nb6.tgz
NetBSD 9.0earmperdition-1.18nb6.tgz
NetBSD 9.0earmperdition-1.18nb6.tgz
NetBSD 9.0earmv6hfperdition-1.18nb6.tgz
NetBSD 9.0earmv6hfperdition-1.18nb5.tgz
NetBSD 9.0earmv6hfperdition-1.18nb6.tgz
NetBSD 9.0earmv6hfperdition-1.18nb6.tgz
NetBSD 9.0earmv6hfperdition-1.18nb6.tgz
NetBSD 9.0earmv7hfperdition-1.18nb6.tgz
NetBSD 9.0earmv7hfperdition-1.18nb5.tgz
NetBSD 9.0earmv7hfperdition-1.18nb6.tgz
NetBSD 9.0earmv7hfperdition-1.18nb6.tgz
NetBSD 9.0earmv7hfperdition-1.18nb6.tgz
NetBSD 9.0earmv7hfperdition-1.18nb6.tgz
NetBSD 9.0earmv7hfperdition-1.18nb6.tgz
NetBSD 9.0i386perdition-1.18nb5.tgz
NetBSD 9.0i386perdition-1.18nb6.tgz
NetBSD 9.0i386perdition-1.18nb6.tgz
NetBSD 9.0i386perdition-1.18nb6.tgz
NetBSD 9.0m68kperdition-1.18nb6.tgz
NetBSD 9.0mips64ebperdition-1.18nb6.tgz
NetBSD 9.0mips64ebperdition-1.18nb5.tgz
NetBSD 9.0mips64ebperdition-1.18nb6.tgz
NetBSD 9.0mips64ebperdition-1.18nb6.tgz
NetBSD 9.0mipselperdition-1.18nb6.tgz
NetBSD 9.0mipselperdition-1.18nb6.tgz
NetBSD 9.0mipselperdition-1.18nb6.tgz
NetBSD 9.0powerpcperdition-1.18nb6.tgz
NetBSD 9.0powerpcperdition-1.18nb5.tgz
NetBSD 9.0powerpcperdition-1.18nb6.tgz
NetBSD 9.0powerpcperdition-1.18nb6.tgz
NetBSD 9.0powerpcperdition-1.18nb6.tgz
NetBSD 9.0sh3elperdition-1.18nb6.tgz
NetBSD 9.0sh3elperdition-1.18nb6.tgz
NetBSD 9.0sh3elperdition-1.18nb6.tgz
NetBSD 9.0sparc64perdition-1.18nb6.tgz
NetBSD 9.0sparc64perdition-1.18nb6.tgz
NetBSD 9.0sparcperdition-1.18nb6.tgz
NetBSD 9.0sparcperdition-1.18nb5.tgz
NetBSD 9.0sparcperdition-1.18nb6.tgz
NetBSD 9.0sparcperdition-1.18nb6.tgz
NetBSD 9.0vaxperdition-1.18nb6.tgz
NetBSD 9.0vaxperdition-1.18nb6.tgz
NetBSD 9.0vaxperdition-1.18nb6.tgz
NetBSD 9.0x86_64perdition-1.18nb6.tgz
NetBSD 9.0x86_64perdition-1.18nb6.tgz
NetBSD 9.0x86_64perdition-1.18nb6.tgz
NetBSD 9.0x86_64perdition-1.18nb6.tgz
NetBSD 9.0x86_64perdition-1.18nb5.tgz
NetBSD 9.0x86_64perdition-1.18nb6.tgz
NetBSD 9.0x86_64perdition-1.18nb6.tgz
NetBSD 9.0x86_64perdition-1.18nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

pam
Enable PAM support.
ssl
Enable SSL support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.