mail/newspipe - The NetBSD Packages Collection

Read RSS/Atom feeds as email messages

Newspipe is an RSS/Atom aggregator with a difference: it allows
you to keep track of your feeds through email. You create an OPML
file listing your feeds and Newspipe will collect them, convert
them to e-mail messages and send them to your mailbox.

This means you can read, organize and archive news feeds using your
current mail client (or even webmail), without needing to use a
separate program. Newspipe can send you news items as plaintext or
HTML mail, both as single items or grouped in a digest.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

textproc/py-expat textproc/py-feedparser5 textproc/py-html2text-2019.8.11 lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfnewspipe-1.1.9nb10.tgz
NetBSD 8.0earmv7hfnewspipe-1.1.9nb8.tgz
NetBSD 8.0earmv7hfnewspipe-1.1.9nb10.tgz
NetBSD 8.0earmv7hfnewspipe-1.1.9nb10.tgz
NetBSD 8.0i386newspipe-1.1.9nb8.tgz
NetBSD 8.0i386newspipe-1.1.9nb10.tgz
NetBSD 8.0i386newspipe-1.1.9nb10.tgz
NetBSD 8.0i386newspipe-1.1.9nb10.tgz
NetBSD 8.0powerpcnewspipe-1.1.9nb8.tgz
NetBSD 8.0powerpcnewspipe-1.1.9nb10.tgz
NetBSD 8.0powerpcnewspipe-1.1.9nb10.tgz
NetBSD 8.0powerpcnewspipe-1.1.9nb10.tgz
NetBSD 8.0powerpcnewspipe-1.1.9nb10.tgz
NetBSD 8.0x86_64newspipe-1.1.9nb10.tgz
NetBSD 8.0x86_64newspipe-1.1.9nb8.tgz
NetBSD 8.0x86_64newspipe-1.1.9nb10.tgz
NetBSD 8.0x86_64newspipe-1.1.9nb10.tgz
NetBSD 9.0aarch64newspipe-1.1.9nb10.tgz
NetBSD 9.0aarch64newspipe-1.1.9nb8.tgz
NetBSD 9.0aarch64newspipe-1.1.9nb10.tgz
NetBSD 9.0aarch64newspipe-1.1.9nb10.tgz
NetBSD 9.0alphanewspipe-1.1.9nb10.tgz
NetBSD 9.0alphanewspipe-1.1.9nb10.tgz
NetBSD 9.0earmv6hfnewspipe-1.1.9nb10.tgz
NetBSD 9.0earmv6hfnewspipe-1.1.9nb8.tgz
NetBSD 9.0earmv6hfnewspipe-1.1.9nb10.tgz
NetBSD 9.0earmv6hfnewspipe-1.1.9nb10.tgz
NetBSD 9.0earmv6hfnewspipe-1.1.9nb10.tgz
NetBSD 9.0earmv7hfnewspipe-1.1.9nb10.tgz
NetBSD 9.0earmv7hfnewspipe-1.1.9nb8.tgz
NetBSD 9.0earmv7hfnewspipe-1.1.9nb10.tgz
NetBSD 9.0earmv7hfnewspipe-1.1.9nb10.tgz
NetBSD 9.0earmv7hfnewspipe-1.1.9nb10.tgz
NetBSD 9.0earmv7hfnewspipe-1.1.9nb10.tgz
NetBSD 9.0earmv7hfnewspipe-1.1.9nb10.tgz
NetBSD 9.0i386newspipe-1.1.9nb8.tgz
NetBSD 9.0i386newspipe-1.1.9nb10.tgz
NetBSD 9.0i386newspipe-1.1.9nb10.tgz
NetBSD 9.0i386newspipe-1.1.9nb10.tgz
NetBSD 9.0mips64ebnewspipe-1.1.9nb10.tgz
NetBSD 9.0mips64ebnewspipe-1.1.9nb8.tgz
NetBSD 9.0mips64ebnewspipe-1.1.9nb10.tgz
NetBSD 9.0mips64ebnewspipe-1.1.9nb10.tgz
NetBSD 9.0powerpcnewspipe-1.1.9nb10.tgz
NetBSD 9.0powerpcnewspipe-1.1.9nb8.tgz
NetBSD 9.0powerpcnewspipe-1.1.9nb10.tgz
NetBSD 9.0powerpcnewspipe-1.1.9nb10.tgz
NetBSD 9.0powerpcnewspipe-1.1.9nb10.tgz
NetBSD 9.0sparc64newspipe-1.1.9nb10.tgz
NetBSD 9.0sparc64newspipe-1.1.9nb10.tgz
NetBSD 9.0sparcnewspipe-1.1.9nb10.tgz
NetBSD 9.0sparcnewspipe-1.1.9nb10.tgz
NetBSD 9.0x86_64newspipe-1.1.9nb10.tgz
NetBSD 9.0x86_64newspipe-1.1.9nb10.tgz
NetBSD 9.0x86_64newspipe-1.1.9nb10.tgz
NetBSD 9.0x86_64newspipe-1.1.9nb10.tgz
NetBSD 9.0x86_64newspipe-1.1.9nb8.tgz
NetBSD 9.0x86_64newspipe-1.1.9nb10.tgz
NetBSD 9.0x86_64newspipe-1.1.9nb10.tgz
NetBSD 9.0x86_64newspipe-1.1.9nb10.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.