mail/gmime3 - The NetBSD Packages Collection

Library for the creation and parsing of MIME messages (API v3)

GMime is a C library which may be used for the creation and parsing
of messages using the Multipurpose Internet Mail Extension (MIME),
as defined by numerous IETF specifications.

GMime features an extremely robust high-performance parser designed
to be able to preserve byte-for-byte information allowing developers
to re-seralize the parsed messages back to a stream exactly as the
parser found them. It also features integrated GnuPG and S/MIME
v3.2 support.

Built on top of GObject (the object system used by the GNOME
desktop), many developers should find its API design and memory
management very familiar.

This package contains v3 of the gmime API.

Build dependencies

security/libgpg-error pkgtools/cwrappers security/libgpg-error devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

security/gnupg2 devel/glib2 security/gpgme devel/glib2 security/gpgme

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgmime3-3.2.7.tgz
NetBSD 8.0earmv7hfgmime3-3.2.7.tgz
NetBSD 8.0earmv7hfgmime3-3.2.7.tgz
NetBSD 8.0earmv7hfgmime3-3.2.7.tgz
NetBSD 8.0i386gmime3-3.2.7.tgz
NetBSD 8.0i386gmime3-3.2.7.tgz
NetBSD 8.0i386gmime3-3.2.7.tgz
NetBSD 8.0i386gmime3-3.2.7.tgz
NetBSD 8.0powerpcgmime3-3.2.7.tgz
NetBSD 8.0powerpcgmime3-3.2.7.tgz
NetBSD 8.0powerpcgmime3-3.2.7.tgz
NetBSD 8.0powerpcgmime3-3.2.7.tgz
NetBSD 8.0powerpcgmime3-3.2.7.tgz
NetBSD 8.0x86_64gmime3-3.2.7.tgz
NetBSD 8.0x86_64gmime3-3.2.7.tgz
NetBSD 8.0x86_64gmime3-3.2.7.tgz
NetBSD 8.0x86_64gmime3-3.2.7.tgz
NetBSD 9.0aarch64gmime3-3.2.7.tgz
NetBSD 9.0aarch64gmime3-3.2.7.tgz
NetBSD 9.0aarch64gmime3-3.2.7.tgz
NetBSD 9.0aarch64gmime3-3.2.7.tgz
NetBSD 9.0aarch64gmime3-3.2.7.tgz
NetBSD 9.0alphagmime3-3.2.7.tgz
NetBSD 9.0alphagmime3-3.2.7.tgz
NetBSD 9.0alphagmime3-3.2.7.tgz
NetBSD 9.0earmgmime3-3.2.7.tgz
NetBSD 9.0earmgmime3-3.2.7.tgz
NetBSD 9.0earmgmime3-3.2.7.tgz
NetBSD 9.0earmv6hfgmime3-3.2.7.tgz
NetBSD 9.0earmv6hfgmime3-3.2.7.tgz
NetBSD 9.0earmv6hfgmime3-3.2.7.tgz
NetBSD 9.0earmv6hfgmime3-3.2.7.tgz
NetBSD 9.0earmv6hfgmime3-3.2.7.tgz
NetBSD 9.0earmv6hfgmime3-3.2.7.tgz
NetBSD 9.0earmv7hfgmime3-3.2.7.tgz
NetBSD 9.0earmv7hfgmime3-3.2.7.tgz
NetBSD 9.0earmv7hfgmime3-3.2.7.tgz
NetBSD 9.0earmv7hfgmime3-3.2.7.tgz
NetBSD 9.0earmv7hfgmime3-3.2.7.tgz
NetBSD 9.0earmv7hfgmime3-3.2.7.tgz
NetBSD 9.0earmv7hfgmime3-3.2.7.tgz
NetBSD 9.0earmv7hfgmime3-3.2.7.tgz
NetBSD 9.0i386gmime3-3.2.7.tgz
NetBSD 9.0i386gmime3-3.2.7.tgz
NetBSD 9.0i386gmime3-3.2.7.tgz
NetBSD 9.0i386gmime3-3.2.7.tgz
NetBSD 9.0mips64ebgmime3-3.2.7.tgz
NetBSD 9.0mips64ebgmime3-3.2.7.tgz
NetBSD 9.0mips64ebgmime3-3.2.7.tgz
NetBSD 9.0mips64ebgmime3-3.2.7.tgz
NetBSD 9.0mips64ebgmime3-3.2.7.tgz
NetBSD 9.0mipselgmime3-3.2.7.tgz
NetBSD 9.0mipselgmime3-3.2.7.tgz
NetBSD 9.0mipselgmime3-3.2.7.tgz
NetBSD 9.0mipselgmime3-3.2.7.tgz
NetBSD 9.0powerpcgmime3-3.2.7.tgz
NetBSD 9.0powerpcgmime3-3.2.7.tgz
NetBSD 9.0powerpcgmime3-3.2.7.tgz
NetBSD 9.0powerpcgmime3-3.2.7.tgz
NetBSD 9.0powerpcgmime3-3.2.7.tgz
NetBSD 9.0sh3elgmime3-3.2.7.tgz
NetBSD 9.0sh3elgmime3-3.2.7.tgz
NetBSD 9.0sh3elgmime3-3.2.7.tgz
NetBSD 9.0sh3elgmime3-3.2.7.tgz
NetBSD 9.0sparc64gmime3-3.2.7.tgz
NetBSD 9.0sparc64gmime3-3.2.7.tgz
NetBSD 9.0sparc64gmime3-3.2.7.tgz
NetBSD 9.0sparcgmime3-3.2.7.tgz
NetBSD 9.0sparcgmime3-3.2.7.tgz
NetBSD 9.0sparcgmime3-3.2.7.tgz
NetBSD 9.0sparcgmime3-3.2.7.tgz
NetBSD 9.0sparcgmime3-3.2.7.tgz
NetBSD 9.0x86_64gmime3-3.2.7.tgz
NetBSD 9.0x86_64gmime3-3.2.7.tgz
NetBSD 9.0x86_64gmime3-3.2.7.tgz
NetBSD 9.0x86_64gmime3-3.2.7.tgz
NetBSD 9.0x86_64gmime3-3.2.7.tgz
NetBSD 9.0x86_64gmime3-3.2.7.tgz
NetBSD 9.0x86_64gmime3-3.2.7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.