lang/ruby - The NetBSD Packages Collection

Wrapper package for Ruby programming language

This package is a wrapper for specific releases of the Ruby
programming language, providing commands (ruby, irb, ...) without
any release number information.

The actual Ruby programming language is provided by packages with
release numbers, like ruby16 or ruby18.

No package should depend on this package directly.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/ruby26-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby-2.5.8nb1.tgz
NetBSD 8.0earmv7hfruby-2.6.6nb1.tgz
NetBSD 8.0earmv7hfruby-2.7.2nb1.tgz
NetBSD 8.0earmv7hfruby-2.5.8.tgz
NetBSD 8.0earmv7hfruby-2.6.6.tgz
NetBSD 8.0earmv7hfruby-2.7.1.tgz
NetBSD 8.0earmv7hfruby-2.5.9.tgz
NetBSD 8.0earmv7hfruby-2.6.7.tgz
NetBSD 8.0earmv7hfruby-2.7.3.tgz
NetBSD 8.0i386ruby-2.5.8.tgz
NetBSD 8.0i386ruby-2.6.6.tgz
NetBSD 8.0i386ruby-2.7.2.tgz
NetBSD 8.0i386ruby-2.5.8nb1.tgz
NetBSD 8.0i386ruby-2.6.6nb1.tgz
NetBSD 8.0i386ruby-2.7.2nb1.tgz
NetBSD 8.0i386ruby-2.5.9.tgz
NetBSD 8.0i386ruby-2.6.7.tgz
NetBSD 8.0i386ruby-2.7.3.tgz
NetBSD 8.0powerpcruby-2.5.8.tgz
NetBSD 8.0powerpcruby-2.6.6.tgz
NetBSD 8.0powerpcruby-2.7.1.tgz
NetBSD 8.0powerpcruby-2.5.8.tgz
NetBSD 8.0powerpcruby-2.5.8nb1.tgz
NetBSD 8.0powerpcruby-2.6.6.tgz
NetBSD 8.0powerpcruby-2.6.6nb1.tgz
NetBSD 8.0powerpcruby-2.7.2nb1.tgz
NetBSD 8.0powerpcruby-2.5.8.tgz
NetBSD 8.0powerpcruby-2.5.8nb1.tgz
NetBSD 8.0powerpcruby-2.6.6.tgz
NetBSD 8.0powerpcruby-2.6.6nb1.tgz
NetBSD 8.0powerpcruby-2.7.2nb1.tgz
NetBSD 8.0powerpcruby-2.5.8.tgz
NetBSD 8.0powerpcruby-2.5.8nb1.tgz
NetBSD 8.0powerpcruby-2.6.6.tgz
NetBSD 8.0powerpcruby-2.6.6nb1.tgz
NetBSD 8.0powerpcruby-2.7.2nb1.tgz
NetBSD 8.0x86_64ruby-2.5.9.tgz
NetBSD 8.0x86_64ruby-2.6.7.tgz
NetBSD 8.0x86_64ruby-2.7.3.tgz
NetBSD 8.0x86_64ruby-2.5.8.tgz
NetBSD 8.0x86_64ruby-2.6.6.tgz
NetBSD 8.0x86_64ruby-2.7.2.tgz
NetBSD 8.0x86_64ruby-2.5.8nb1.tgz
NetBSD 8.0x86_64ruby-2.6.6nb1.tgz
NetBSD 8.0x86_64ruby-2.7.2nb1.tgz
NetBSD 9.0aarch64ruby-2.5.9.tgz
NetBSD 9.0aarch64ruby-2.6.7.tgz
NetBSD 9.0aarch64ruby-2.7.3.tgz
NetBSD 9.0aarch64ruby-3.0.1.tgz
NetBSD 9.0aarch64ruby-2.5.8.tgz
NetBSD 9.0aarch64ruby-2.6.6.tgz
NetBSD 9.0aarch64ruby-2.7.2.tgz
NetBSD 9.0aarch64ruby-2.5.8nb1.tgz
NetBSD 9.0aarch64ruby-2.6.6nb1.tgz
NetBSD 9.0aarch64ruby-2.7.2nb1.tgz
NetBSD 9.0alpharuby-2.5.9.tgz
NetBSD 9.0alpharuby-2.6.7.tgz
NetBSD 9.0alpharuby-2.7.3.tgz
NetBSD 9.0alpharuby-2.5.8.tgz
NetBSD 9.0alpharuby-2.6.6.tgz
NetBSD 9.0alpharuby-2.7.2.tgz
NetBSD 9.0alpharuby-2.5.8nb1.tgz
NetBSD 9.0alpharuby-2.6.6nb1.tgz
NetBSD 9.0alpharuby-2.7.2nb1.tgz
NetBSD 9.0earmv6hfruby-2.5.8.tgz
NetBSD 9.0earmv6hfruby-2.6.6.tgz
NetBSD 9.0earmv6hfruby-2.7.1.tgz
NetBSD 9.0earmv6hfruby-2.7.2.tgz
NetBSD 9.0earmv6hfruby-2.5.8nb1.tgz
NetBSD 9.0earmv6hfruby-2.6.6nb1.tgz
NetBSD 9.0earmv6hfruby-2.7.2nb1.tgz
NetBSD 9.0earmv6hfruby-2.5.8nb1.tgz
NetBSD 9.0earmv6hfruby-2.6.6nb1.tgz
NetBSD 9.0earmv6hfruby-2.7.2nb1.tgz
NetBSD 9.0earmv7hfruby-2.5.9.tgz
NetBSD 9.0earmv7hfruby-2.6.7.tgz
NetBSD 9.0earmv7hfruby-2.7.3.tgz
NetBSD 9.0earmv7hfruby-3.0.1.tgz
NetBSD 9.0earmv7hfruby-2.5.8.tgz
NetBSD 9.0earmv7hfruby-2.6.6.tgz
NetBSD 9.0earmv7hfruby-2.7.1.tgz
NetBSD 9.0earmv7hfruby-2.5.8nb1.tgz
NetBSD 9.0earmv7hfruby-2.6.6nb1.tgz
NetBSD 9.0earmv7hfruby-2.7.2nb1.tgz
NetBSD 9.0earmv7hfruby-2.5.8nb1.tgz
NetBSD 9.0earmv7hfruby-2.6.6nb1.tgz
NetBSD 9.0earmv7hfruby-2.7.2nb1.tgz
NetBSD 9.0earmv7hfruby-2.5.9.tgz
NetBSD 9.0earmv7hfruby-2.6.7.tgz
NetBSD 9.0earmv7hfruby-2.7.3.tgz
NetBSD 9.0earmv7hfruby-3.0.1.tgz
NetBSD 9.0i386ruby-2.5.8.tgz
NetBSD 9.0i386ruby-2.6.6.tgz
NetBSD 9.0i386ruby-2.7.2.tgz
NetBSD 9.0i386ruby-2.5.8nb1.tgz
NetBSD 9.0i386ruby-2.6.6nb1.tgz
NetBSD 9.0i386ruby-2.7.2nb1.tgz
NetBSD 9.0i386ruby-2.5.9.tgz
NetBSD 9.0i386ruby-2.6.7.tgz
NetBSD 9.0i386ruby-2.7.3.tgz
NetBSD 9.0i386ruby-3.0.1.tgz
NetBSD 9.0mips64ebruby-2.5.8.tgz
NetBSD 9.0mips64ebruby-2.6.6.tgz
NetBSD 9.0mips64ebruby-2.7.1.tgz
NetBSD 9.0mips64ebruby-2.5.8nb1.tgz
NetBSD 9.0mips64ebruby-2.6.6nb1.tgz
NetBSD 9.0mips64ebruby-2.7.2nb1.tgz
NetBSD 9.0powerpcruby-2.5.8.tgz
NetBSD 9.0powerpcruby-2.5.8nb1.tgz
NetBSD 9.0powerpcruby-2.6.6.tgz
NetBSD 9.0powerpcruby-2.6.6nb1.tgz
NetBSD 9.0powerpcruby-2.7.2nb1.tgz
NetBSD 9.0powerpcruby-2.5.8.tgz
NetBSD 9.0powerpcruby-2.6.6.tgz
NetBSD 9.0powerpcruby-2.7.1.tgz
NetBSD 9.0powerpcruby-2.5.8.tgz
NetBSD 9.0powerpcruby-2.5.8nb1.tgz
NetBSD 9.0powerpcruby-2.6.6.tgz
NetBSD 9.0powerpcruby-2.6.6nb1.tgz
NetBSD 9.0powerpcruby-2.7.2nb1.tgz
NetBSD 9.0powerpcruby-3.0.0nb1.tgz
NetBSD 9.0powerpcruby-2.5.8.tgz
NetBSD 9.0powerpcruby-2.5.8nb1.tgz
NetBSD 9.0powerpcruby-2.6.6.tgz
NetBSD 9.0powerpcruby-2.6.6nb1.tgz
NetBSD 9.0powerpcruby-2.7.2nb1.tgz
NetBSD 9.0powerpcruby-3.0.0nb1.tgz
NetBSD 9.0sparc64ruby-2.5.9.tgz
NetBSD 9.0sparc64ruby-2.6.7.tgz
NetBSD 9.0sparc64ruby-2.7.3.tgz
NetBSD 9.0sparc64ruby-3.0.1.tgz
NetBSD 9.0sparc64ruby-2.5.8.tgz
NetBSD 9.0sparc64ruby-2.6.6.tgz
NetBSD 9.0sparc64ruby-2.7.1.tgz
NetBSD 9.0sparc64ruby-2.5.8.tgz
NetBSD 9.0sparc64ruby-2.6.6.tgz
NetBSD 9.0sparc64ruby-2.7.1.tgz
NetBSD 9.0sparc64ruby-2.7.2.tgz
NetBSD 9.0sparc64ruby-2.5.8nb1.tgz
NetBSD 9.0sparc64ruby-2.6.6nb1.tgz
NetBSD 9.0sparc64ruby-2.7.2nb1.tgz
NetBSD 9.0sparcruby-2.5.8.tgz
NetBSD 9.0sparcruby-2.6.6.tgz
NetBSD 9.0sparcruby-2.7.2.tgz
NetBSD 9.0x86_64ruby-2.5.8.tgz
NetBSD 9.0x86_64ruby-2.6.6.tgz
NetBSD 9.0x86_64ruby-2.7.2.tgz
NetBSD 9.0x86_64ruby-2.5.8nb1.tgz
NetBSD 9.0x86_64ruby-2.6.6nb1.tgz
NetBSD 9.0x86_64ruby-2.7.2nb1.tgz
NetBSD 9.0x86_64ruby-2.5.8nb1.tgz
NetBSD 9.0x86_64ruby-2.6.6nb1.tgz
NetBSD 9.0x86_64ruby-2.7.2nb1.tgz
NetBSD 9.0x86_64ruby-2.5.9.tgz
NetBSD 9.0x86_64ruby-2.6.7.tgz
NetBSD 9.0x86_64ruby-2.7.3.tgz
NetBSD 9.0x86_64ruby-3.0.1.tgz
NetBSD 9.0x86_64ruby-2.5.8.tgz
NetBSD 9.0x86_64ruby-2.6.6.tgz
NetBSD 9.0x86_64ruby-2.7.2.tgz
NetBSD 9.0x86_64ruby-2.5.8nb1.tgz
NetBSD 9.0x86_64ruby-2.6.6nb1.tgz
NetBSD 9.0x86_64ruby-2.7.2nb1.tgz
NetBSD 9.0x86_64ruby-2.5.8nb1.tgz
NetBSD 9.0x86_64ruby-2.6.6nb1.tgz
NetBSD 9.0x86_64ruby-2.7.2nb1.tgz
NetBSD 9.0x86_64ruby-3.0.0nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.