lang/gjs - The NetBSD Packages Collection

Javascript binding for GNOME based on Spidermonkey

Gjs is a Javascript binding for GNOME. It's mainly based on
Spidermonkey javascript engine and the GObject introspection
framework.

Build dependencies

devel/meson pkgtools/x11-links x11/xcb-proto x11/xorgproto pkgtools/cwrappers devel/glib2-tools devel/pkgconf

Runtime dependencies

lang/python38 lang/python38 devel/glib2 devel/libffi devel/gobject-introspection graphics/cairo-gobject graphics/gdk-pixbuf2 lang/mozjs78 sysutils/dbus-glib x11/gtk3 devel/glib2 devel/libffi devel/gobject-introspection graphics/cairo-gobject graphics/gdk-pixbuf2 sysutils/dbus-glib x11/gtk3

Available binary packages

aarch64:gjs-1.53.4nb2.tgz(NetBSD 9.0)
aarch64:gjs-1.53.4nb3.tgz(NetBSD 9.0)
aarch64:gjs-1.66.1.tgz(NetBSD 9.0)
alpha:gjs-1.53.4nb3.tgz(NetBSD 9.0)
earmv7hf:gjs-1.53.4nb2.tgz(NetBSD 8.0)
earmv7hf:gjs-1.53.4nb2.tgz(NetBSD 8.0)
earmv7hf:gjs-1.53.4nb2.tgz(NetBSD 9.0)
earmv7hf:gjs-1.53.4nb2.tgz(NetBSD 9.0)
earmv7hf:gjs-1.53.4nb3.tgz(NetBSD 9.0)
i386:gjs-1.53.4nb2.tgz(NetBSD 8.0)
i386:gjs-1.53.4nb3.tgz(NetBSD 8.0)
i386:gjs-1.53.4nb2.tgz(NetBSD 9.0)
i386:gjs-1.53.4nb3.tgz(NetBSD 9.0)
i386:gjs-1.66.1.tgz(NetBSD 9.0)
powerpc:gjs-1.66.1.tgz(NetBSD 9.0)
sparc64:gjs-1.53.4nb2.tgz(NetBSD 9.0)
sparc64:gjs-1.53.4nb3.tgz(NetBSD 9.0)
x86_64:gjs-1.66.1.tgz(NetBSD 9.0)
x86_64:gjs-1.66.1.tgz(NetBSD 9.0)
x86_64:gjs-1.66.1.tgz(NetBSD 9.0)
x86_64:gjs-1.53.4nb3.tgz(NetBSD 9.0)
x86_64:gjs-1.53.4nb3.tgz(NetBSD 8.0)
x86_64:gjs-1.53.4nb2.tgz(NetBSD 8.0)
x86_64:gjs-1.53.4nb2.tgz(NetBSD 9.0)
x86_64:gjs-1.53.4nb3.tgz(NetBSD 9.0)
x86_64:gjs-1.66.1.tgz(NetBSD 9.0)
x86_64:gjs-1.66.1.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]