lang/gcc6 - The NetBSD Packages Collection

The GNU Compiler Collection (GCC) - 6 Release Series

The GNU Compiler Collection (GCC) includes front ends for C, C++, Objective-C,
Fortran, Java, and Go, as well as libraries for these languages (libstdc++,
libgcj,...).

Build dependencies

pkgtools/cwrappers devel/gmake lang/perl5

Runtime dependencies

textproc/gsed

Available binary packages

alpha:gcc6-6.5.0nb5.tgz(NetBSD 9.0)
alpha:gcc6-6.5.0nb3.tgz(NetBSD 9.0)
alpha:gcc6-6.5.0nb4.tgz(NetBSD 9.0)
i386:gcc6-6.5.0nb3.tgz(NetBSD 8.0)
i386:gcc6-6.5.0nb4.tgz(NetBSD 8.0)
i386:gcc6-6.5.0nb5.tgz(NetBSD 8.0)
powerpc:gcc6-6.5.0nb3.tgz(NetBSD 8.0)
powerpc:gcc6-6.5.0nb5.tgz(NetBSD 8.0)
powerpc:gcc6-6.5.0nb4.tgz(NetBSD 8.0)
powerpc:gcc6-6.5.0nb4.tgz(NetBSD 9.0)
powerpc:gcc6-6.5.0nb3.tgz(NetBSD 9.0)
x86_64:gcc6-6.5.0nb4.tgz(NetBSD 9.0)
x86_64:gcc6-6.5.0nb5.tgz(NetBSD 9.0)
x86_64:gcc6-6.5.0nb5.tgz(NetBSD 9.0)
x86_64:gcc6-6.5.0nb4.tgz(NetBSD 9.0)
x86_64:gcc6-6.5.0nb4.tgz(NetBSD 8.0)
x86_64:gcc6-6.5.0nb3.tgz(NetBSD 8.0)
x86_64:gcc6-6.5.0nb5.tgz(NetBSD 8.0)
x86_64:gcc6-6.5.0nb3.tgz(NetBSD 9.0)
x86_64:gcc6-6.5.0nb4.tgz(NetBSD 9.0)
x86_64:gcc6-6.5.0nb5.tgz(NetBSD 9.0)
x86_64:gcc6-6.5.0nb5.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

always-libgcc
Install libgcc unconditionally, even if it's older.
gcc-c++
Build the gcc C++ frontend and libraries.
gcc-fortran
Build the gcc Fortran frontend and libraries.
gcc-go
Build the gcc Go frontend and libraries.
gcc-graphite
Build the gcc Graphite framework for high-level memory optimisation.
gcc-inplace-math
Build math libs inplace instead of depending on them.
gcc-java
Build the gcc Java frontend, tools and libraries.
gcc-objc
Build the gcc Objective-C frontend and libraries.
gcc-objc++
Build the gcc Objective-C++ frontend and libraries.
nls
Use native language support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]