graphics/zbar - The NetBSD Packages Collection

Bar code reader

ZBar is an open source software suite for reading bar codes from various
sources, such as video streams, image files and raw intensity sensors. It
supports many popular symbologies (types of bar codes) including
EAN-13/UPC-A, UPC-E, EAN-8, Code 128, Code 39, Interleaved 2 of 5 and QR
Code.

The flexible, layered implementation facilitates bar code scanning and
decoding for any application: use it stand-alone with the included GUI and
command line programs, easily integrate a bar code scanning widget into
your Qt, GTK+ or PyGTK GUI application, leverage one of the script or
programming interfaces (Python, Perl, C++) ...all the way down to a
streamlined C library suitable for embedded use.

Build dependencies

pkgtools/x11-links x11/xorgproto pkgtools/cwrappers textproc/xmlto devel/glib2-tools devel/libtool-base devel/pkgconf

Runtime dependencies

graphics/ImageMagick x11/libXv graphics/ImageMagick

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfzbar-0.23.1nb3.tgz
NetBSD 8.0earmv7hfzbar-0.23.90.tgz
NetBSD 8.0i386zbar-0.23.1nb1.tgz
NetBSD 8.0i386zbar-0.23.1nb3.tgz
NetBSD 8.0i386zbar-0.23.90.tgz
NetBSD 8.0i386zbar-0.23.90nb3.tgz
NetBSD 8.0powerpczbar-0.23.90.tgz
NetBSD 8.0powerpczbar-0.23.1nb3.tgz
NetBSD 8.0powerpczbar-0.23.90.tgz
NetBSD 8.0x86_64zbar-0.23.90.tgz
NetBSD 8.0x86_64zbar-0.23.1nb1.tgz
NetBSD 8.0x86_64zbar-0.23.1nb3.tgz
NetBSD 8.0x86_64zbar-0.23.90nb3.tgz
NetBSD 9.0aarch64zbar-0.23.90nb3.tgz
NetBSD 9.0aarch64zbar-0.23.1nb1.tgz
NetBSD 9.0aarch64zbar-0.23.1nb3.tgz
NetBSD 9.0aarch64zbar-0.23.90.tgz
NetBSD 9.0alphazbar-0.23.90.tgz
NetBSD 9.0alphazbar-0.23.90nb3.tgz
NetBSD 9.0earmv6hfzbar-0.23.90.tgz
NetBSD 9.0earmv6hfzbar-0.23.1nb1.tgz
NetBSD 9.0earmv6hfzbar-0.23.1nb3.tgz
NetBSD 9.0earmv6hfzbar-0.23.1nb3.tgz
NetBSD 9.0earmv6hfzbar-0.23.90nb3.tgz
NetBSD 9.0earmv7hfzbar-0.23.90.tgz
NetBSD 9.0earmv7hfzbar-0.23.1nb1.tgz
NetBSD 9.0earmv7hfzbar-0.23.1nb3.tgz
NetBSD 9.0earmv7hfzbar-0.23.1nb3.tgz
NetBSD 9.0earmv7hfzbar-0.23.90.tgz
NetBSD 9.0i386zbar-0.23.1nb1.tgz
NetBSD 9.0i386zbar-0.23.1nb3.tgz
NetBSD 9.0i386zbar-0.23.90.tgz
NetBSD 9.0i386zbar-0.23.90nb3.tgz
NetBSD 9.0powerpczbar-0.23.1nb3.tgz
NetBSD 9.0powerpczbar-0.23.1nb1.tgz
NetBSD 9.0powerpczbar-0.23.90.tgz
NetBSD 9.0powerpczbar-0.23.90.tgz
NetBSD 9.0powerpczbar-0.23.90.tgz
NetBSD 9.0sparc64zbar-0.23.90.tgz
NetBSD 9.0sparczbar-0.23.90.tgz
NetBSD 9.0sparczbar-0.23.1nb1.tgz
NetBSD 9.0x86_64zbar-0.23.1nb3.tgz
NetBSD 9.0x86_64zbar-0.23.90nb3.tgz
NetBSD 9.0x86_64zbar-0.23.90.tgz
NetBSD 9.0x86_64zbar-0.23.90.tgz
NetBSD 9.0x86_64zbar-0.23.1nb1.tgz
NetBSD 9.0x86_64zbar-0.23.1nb3.tgz
NetBSD 9.0x86_64zbar-0.23.90nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

imagemagick
Use ImageMagick as imaging library.
x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.