graphics/xli - The NetBSD Packages Collection

X11 Image Loading Utility

This utility will view several types of images under X11, or load
images onto the X11 root window. Supported image formats include
GIF, JPEG, JFIF, Faces, PNG, PPM and friends, XPM, and XWUD.

A variety of options are available to modify images prior to viewing.
These options include clipping, dithering, depth reduction, zoom
(either X or Y axis independently or both at once), brightening or
darkening, input gamma correction, and image merging.  When applicable,
these options are done automatically (eg. a color image to be displayed
on a monochrome screen will be dithered automatically). A utility (xlito)
is provided that allows these viewing options to be appended to the image
files.

Build dependencies

pkgtools/x11-links pkgtools/cwrappers devel/imake

Runtime dependencies

graphics/jpeg graphics/png graphics/jpeg graphics/png

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfxli-1.17.0nb13.tgz
NetBSD 8.0earmv7hfxli-1.17.0nb13.tgz
NetBSD 8.0earmv7hfxli-1.17.0nb13.tgz
NetBSD 8.0i386xli-1.17.0nb13.tgz
NetBSD 8.0i386xli-1.17.0nb13.tgz
NetBSD 8.0powerpcxli-1.17.0nb13.tgz
NetBSD 8.0powerpcxli-1.17.0nb13.tgz
NetBSD 8.0powerpcxli-1.17.0nb13.tgz
NetBSD 8.0powerpcxli-1.17.0nb13.tgz
NetBSD 8.0x86_64xli-1.17.0nb13.tgz
NetBSD 8.0x86_64xli-1.17.0nb13.tgz
NetBSD 9.0aarch64xli-1.17.0nb13.tgz
NetBSD 9.0aarch64xli-1.17.0nb13.tgz
NetBSD 9.0aarch64xli-1.17.0nb13.tgz
NetBSD 9.0alphaxli-1.17.0nb13.tgz
NetBSD 9.0alphaxli-1.17.0nb13.tgz
NetBSD 9.0alphaxli-1.17.0nb13.tgz
NetBSD 9.0earmv6hfxli-1.17.0nb13.tgz
NetBSD 9.0earmv6hfxli-1.17.0nb13.tgz
NetBSD 9.0earmv6hfxli-1.17.0nb13.tgz
NetBSD 9.0earmv7hfxli-1.17.0nb13.tgz
NetBSD 9.0earmv7hfxli-1.17.0nb13.tgz
NetBSD 9.0earmv7hfxli-1.17.0nb13.tgz
NetBSD 9.0earmv7hfxli-1.17.0nb13.tgz
NetBSD 9.0i386xli-1.17.0nb13.tgz
NetBSD 9.0i386xli-1.17.0nb13.tgz
NetBSD 9.0i386xli-1.17.0nb13.tgz
NetBSD 9.0mips64ebxli-1.17.0nb13.tgz
NetBSD 9.0mips64ebxli-1.17.0nb13.tgz
NetBSD 9.0mips64ebxli-1.17.0nb13.tgz
NetBSD 9.0mips64ebxli-1.17.0nb13.tgz
NetBSD 9.0mips64ebxli-1.17.0nb13.tgz
NetBSD 9.0powerpcxli-1.17.0nb13.tgz
NetBSD 9.0powerpcxli-1.17.0nb13.tgz
NetBSD 9.0powerpcxli-1.17.0nb13.tgz
NetBSD 9.0powerpcxli-1.17.0nb13.tgz
NetBSD 9.0sparc64xli-1.17.0nb13.tgz
NetBSD 9.0sparc64xli-1.17.0nb13.tgz
NetBSD 9.0sparc64xli-1.17.0nb13.tgz
NetBSD 9.0sparcxli-1.17.0nb13.tgz
NetBSD 9.0sparcxli-1.17.0nb13.tgz
NetBSD 9.0sparcxli-1.17.0nb13.tgz
NetBSD 9.0sparcxli-1.17.0nb13.tgz
NetBSD 9.0x86_64xli-1.17.0nb13.tgz
NetBSD 9.0x86_64xli-1.17.0nb13.tgz
NetBSD 9.0x86_64xli-1.17.0nb13.tgz
NetBSD 9.0x86_64xli-1.17.0nb13.tgz
NetBSD 9.0x86_64xli-1.17.0nb13.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.