graphics/tesseract - The NetBSD Packages Collection

Open Source OCR Engine

Tesseract provides an OCR engine and a command line program. It
includes a new neural net (LSTM) based OCR engine which is focused on
line recognition, but also still provides a legacy OCR engine which
works by recognizing character patterns. Tesseract has Unicode (UTF-8)
support, and can recognize more than 100 languages "out of the box".
Tesseract can be trained to recognize other languages. It supports
various output formats: plain text, hOCR (HTML), PDF,
invisible-text-only PDF, and TSV.

Build dependencies

textproc/asciidoc pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/automake devel/autoconf shells/bash devel/gmake devel/pkgconf

Runtime dependencies

devel/pango graphics/cairo graphics/leptonica textproc/icu devel/pango graphics/cairo graphics/leptonica textproc/icu

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hftesseract-4.1.1nb8.tgz
NetBSD 8.0earmv7hftesseract-4.1.1nb7.tgz
NetBSD 8.0earmv7hftesseract-4.1.1nb8.tgz
NetBSD 8.0i386tesseract-4.1.1nb7.tgz
NetBSD 8.0i386tesseract-4.1.1nb8.tgz
NetBSD 8.0powerpctesseract-4.1.1nb7.tgz
NetBSD 8.0powerpctesseract-4.1.1nb8.tgz
NetBSD 8.0powerpctesseract-4.1.1nb8.tgz
NetBSD 8.0powerpctesseract-4.1.1nb8.tgz
NetBSD 8.0x86_64tesseract-4.1.1nb7.tgz
NetBSD 8.0x86_64tesseract-4.1.1nb8.tgz
NetBSD 9.0aarch64tesseract-4.1.1nb8.tgz
NetBSD 9.0aarch64tesseract-4.1.1nb7.tgz
NetBSD 9.0aarch64tesseract-4.1.1nb8.tgz
NetBSD 9.0alphatesseract-4.1.1nb8.tgz
NetBSD 9.0alphatesseract-4.1.1nb7.tgz
NetBSD 9.0alphatesseract-4.1.1nb8.tgz
NetBSD 9.0earmv6hftesseract-4.1.1nb8.tgz
NetBSD 9.0earmv6hftesseract-4.1.1nb7.tgz
NetBSD 9.0earmv6hftesseract-4.1.1nb8.tgz
NetBSD 9.0earmv7hftesseract-4.1.1nb8.tgz
NetBSD 9.0earmv7hftesseract-4.1.1nb7.tgz
NetBSD 9.0earmv7hftesseract-4.1.1nb8.tgz
NetBSD 9.0earmv7hftesseract-4.1.1nb8.tgz
NetBSD 9.0i386tesseract-4.1.1nb7.tgz
NetBSD 9.0i386tesseract-4.1.1nb8.tgz
NetBSD 9.0mips64ebtesseract-4.1.1nb8.tgz
NetBSD 9.0mips64ebtesseract-4.1.1nb6.tgz
NetBSD 9.0mips64ebtesseract-4.1.1nb7.tgz
NetBSD 9.0mips64ebtesseract-4.1.1nb7.tgz
NetBSD 9.0powerpctesseract-4.1.1nb8.tgz
NetBSD 9.0powerpctesseract-4.1.1nb7.tgz
NetBSD 9.0powerpctesseract-4.1.1nb8.tgz
NetBSD 9.0powerpctesseract-4.1.1nb8.tgz
NetBSD 9.0sparc64tesseract-4.1.1nb8.tgz
NetBSD 9.0sparc64tesseract-4.1.1nb7.tgz
NetBSD 9.0sparc64tesseract-4.1.1nb8.tgz
NetBSD 9.0sparctesseract-4.1.1nb8.tgz
NetBSD 9.0sparctesseract-4.1.1nb7.tgz
NetBSD 9.0x86_64tesseract-4.1.1nb8.tgz
NetBSD 9.0x86_64tesseract-4.1.1nb8.tgz
NetBSD 9.0x86_64tesseract-4.1.1nb7.tgz
NetBSD 9.0x86_64tesseract-4.1.1nb8.tgz
NetBSD 9.0x86_64tesseract-4.1.1nb8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.