graphics/plotutils - The NetBSD Packages Collection

Programs and library for plotting scientific data

The GNU plotutils package contains programs for plotting scientific data,
and a function library for drawing vector graphics and doing vector graphics
animations.  The package includes:
* GNU graph, which does two-dimensional plotting in real time. It's designed
  for command-line use, and can be used in shell scripts. It produces output
  on an X Window System display, in Illustrator format, in Postscript format,
  in PCL 5 format, in HP-GL/2 format, in Fig format (editable with the xfig
  drawing editor), in Tektronix format, or in GNU Metafile format. Output in
  Postscript format may be edited with the idraw drawing editor.
* GNU plot, which translates GNU Metafile format to any of the other formats.
* GNU tek2plot, for translating legacy Tektronix data to any of the above
  formats.
* GNU plotfont, for displaying character maps of the fonts that are available
  in the above formats.
* GNU spline, which does spline interpolation of data.
* GNU ode, which numerically integrates a system consisting of one or more
  ordinary differential equations.

The programs graph, plot, tek2plot, and plotfont are based on GNU libplot, a C
function library for device-independent two-dimensional vector graphics. GNU
libplot is compatible with the traditional Unix libplot library, but is much
more powerful. It is installed as part of the package.

Build dependencies

pkgtools/x11-links pkgtools/cwrappers devel/libtool-base

Runtime dependencies

graphics/png graphics/png

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfplotutils-2.6nb4.tgz
NetBSD 8.0earmv7hfplotutils-2.6nb4.tgz
NetBSD 8.0earmv7hfplotutils-2.6nb4.tgz
NetBSD 8.0i386plotutils-2.6nb4.tgz
NetBSD 8.0i386plotutils-2.6nb4.tgz
NetBSD 8.0i386plotutils-2.6nb4.tgz
NetBSD 8.0powerpcplotutils-2.6nb4.tgz
NetBSD 8.0powerpcplotutils-2.6nb4.tgz
NetBSD 8.0powerpcplotutils-2.6nb4.tgz
NetBSD 8.0x86_64plotutils-2.6nb4.tgz
NetBSD 8.0x86_64plotutils-2.6nb4.tgz
NetBSD 8.0x86_64plotutils-2.6nb4.tgz
NetBSD 9.0aarch64plotutils-2.6nb4.tgz
NetBSD 9.0aarch64plotutils-2.6nb4.tgz
NetBSD 9.0aarch64plotutils-2.6nb4.tgz
NetBSD 9.0alphaplotutils-2.6nb4.tgz
NetBSD 9.0alphaplotutils-2.6nb4.tgz
NetBSD 9.0alphaplotutils-2.6nb4.tgz
NetBSD 9.0earmplotutils-2.6nb4.tgz
NetBSD 9.0earmplotutils-2.6nb4.tgz
NetBSD 9.0earmv6hfplotutils-2.6nb4.tgz
NetBSD 9.0earmv6hfplotutils-2.6nb4.tgz
NetBSD 9.0earmv6hfplotutils-2.6nb4.tgz
NetBSD 9.0earmv6hfplotutils-2.6nb4.tgz
NetBSD 9.0earmv7hfplotutils-2.6nb4.tgz
NetBSD 9.0earmv7hfplotutils-2.6nb4.tgz
NetBSD 9.0earmv7hfplotutils-2.6nb4.tgz
NetBSD 9.0earmv7hfplotutils-2.6nb4.tgz
NetBSD 9.0i386plotutils-2.6nb4.tgz
NetBSD 9.0i386plotutils-2.6nb4.tgz
NetBSD 9.0i386plotutils-2.6nb4.tgz
NetBSD 9.0m68kplotutils-2.6nb4.tgz
NetBSD 9.0mips64ebplotutils-2.6nb4.tgz
NetBSD 9.0mips64ebplotutils-2.6nb4.tgz
NetBSD 9.0mips64ebplotutils-2.6nb4.tgz
NetBSD 9.0mipselplotutils-2.6nb4.tgz
NetBSD 9.0mipselplotutils-2.6nb4.tgz
NetBSD 9.0powerpcplotutils-2.6nb4.tgz
NetBSD 9.0powerpcplotutils-2.6nb4.tgz
NetBSD 9.0sh3elplotutils-2.6nb4.tgz
NetBSD 9.0sh3elplotutils-2.6nb4.tgz
NetBSD 9.0sparc64plotutils-2.6nb4.tgz
NetBSD 9.0sparc64plotutils-2.6nb4.tgz
NetBSD 9.0sparc64plotutils-2.6nb4.tgz
NetBSD 9.0sparc64plotutils-2.6nb4.tgz
NetBSD 9.0sparcplotutils-2.6nb4.tgz
NetBSD 9.0sparcplotutils-2.6nb4.tgz
NetBSD 9.0sparcplotutils-2.6nb4.tgz
NetBSD 9.0vaxplotutils-2.6nb4.tgz
NetBSD 9.0vaxplotutils-2.6nb4.tgz
NetBSD 9.0x86_64plotutils-2.6nb4.tgz
NetBSD 9.0x86_64plotutils-2.6nb4.tgz
NetBSD 9.0x86_64plotutils-2.6nb4.tgz
NetBSD 9.0x86_64plotutils-2.6nb4.tgz
NetBSD 9.0x86_64plotutils-2.6nb4.tgz
NetBSD 9.0x86_64plotutils-2.6nb4.tgz
NetBSD 9.0x86_64plotutils-2.6nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.