graphics/opencv - The NetBSD Packages Collection

Library for computer vision problems

OpenCV means Intel(R) Open Source Computer Vision Library. It is a
collection of C functions and a few C++ classes that implement many
popular Image Processing and Computer Vision algorithms.

OpenCV provides cross-platform middle-to-high level API that includes
about 300 C functions and a few C++ classes. Also there are Python
bindings to OpenCV. OpenCV has no strict dependencies on external
libraries, though it can use some (such as libjpeg, ffmpeg, GTK+ etc.)

OpenCV provides transparent interface to Intel(R) Integrated Performance
Primitives (IPP). That is, it loads automatically IPP libraries optimized
for specific processor at runtime, if they are available.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/cmake devel/gmake devel/pkgconf

Runtime dependencies

lang/python38 lang/python38 x11/gtk3 graphics/png devel/protobuf graphics/libwebp graphics/openexr graphics/tiff math/py-numpy x11/gtk3 graphics/png devel/protobuf graphics/libwebp graphics/openexr graphics/tiff math/py-numpy

Binary packages

OSArchitectureVersion
NetBSD 9.0aarch64opencv-3.4.9nb7.tgz
NetBSD 9.0aarch64opencv-3.4.9nb5.tgz
NetBSD 9.0aarch64opencv-3.4.9nb7.tgz
NetBSD 9.0x86_64opencv-3.4.9nb6.tgz
NetBSD 9.0x86_64opencv-3.4.9nb7.tgz
NetBSD 9.0x86_64opencv-3.4.9nb7.tgz
NetBSD 9.0x86_64opencv-3.4.9nb5.tgz
NetBSD 9.0x86_64opencv-3.4.9nb7.tgz
NetBSD 9.0x86_64opencv-3.4.9nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

ffmpeg
Enable ffmpeg support.
gtk
Enable support for GTK.
jasper
Enable JPEG 2000 support using the jasper library.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.