graphics/libxmi - The NetBSD Packages Collection

C/C++ function library for rasterizing 2D vector graphics

libxmi is a machine-independent vector graphics rasterization library.
libxmi is based on the vector graphics code in the sample X server that is
a part of the X Window System distribution. The code has been converted
to ANSI C, extensively rearranged and commented, and somewhat extended.
(In particular, by adding support for multicolored dashing.)

The core API includes functions for creating, manipulating, and destroying
miPaintSet objects. It also includes functions for creating, manipulating,
and destroying miCanvas objects. The function miCopyPaintedSetToCanvas()
moves the points in a miPaintedSet to the next stage of the graphics
pipeline: it merges them onto a miCanvas. There is support in this second
stage for sophisticated pixel-merging algorithms.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/autoconf

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibxmi-1.2.tgz
NetBSD 8.0earmv7hflibxmi-1.2.tgz
NetBSD 8.0earmv7hflibxmi-1.2.tgz
NetBSD 8.0i386libxmi-1.2.tgz
NetBSD 8.0i386libxmi-1.2.tgz
NetBSD 8.0powerpclibxmi-1.2.tgz
NetBSD 8.0powerpclibxmi-1.2.tgz
NetBSD 8.0powerpclibxmi-1.2.tgz
NetBSD 8.0powerpclibxmi-1.2.tgz
NetBSD 8.0x86_64libxmi-1.2.tgz
NetBSD 8.0x86_64libxmi-1.2.tgz
NetBSD 9.0aarch64libxmi-1.2.tgz
NetBSD 9.0aarch64libxmi-1.2.tgz
NetBSD 9.0aarch64libxmi-1.2.tgz
NetBSD 9.0alphalibxmi-1.2.tgz
NetBSD 9.0alphalibxmi-1.2.tgz
NetBSD 9.0alphalibxmi-1.2.tgz
NetBSD 9.0earmlibxmi-1.2.tgz
NetBSD 9.0earmlibxmi-1.2.tgz
NetBSD 9.0earmlibxmi-1.2.tgz
NetBSD 9.0earmv6hflibxmi-1.2.tgz
NetBSD 9.0earmv6hflibxmi-1.2.tgz
NetBSD 9.0earmv6hflibxmi-1.2.tgz
NetBSD 9.0earmv7hflibxmi-1.2.tgz
NetBSD 9.0earmv7hflibxmi-1.2.tgz
NetBSD 9.0earmv7hflibxmi-1.2.tgz
NetBSD 9.0earmv7hflibxmi-1.2.tgz
NetBSD 9.0i386libxmi-1.2.tgz
NetBSD 9.0i386libxmi-1.2.tgz
NetBSD 9.0mips64eblibxmi-1.2.tgz
NetBSD 9.0mips64eblibxmi-1.2.tgz
NetBSD 9.0mips64eblibxmi-1.2.tgz
NetBSD 9.0mips64eblibxmi-1.2.tgz
NetBSD 9.0mips64eblibxmi-1.2.tgz
NetBSD 9.0powerpclibxmi-1.2.tgz
NetBSD 9.0powerpclibxmi-1.2.tgz
NetBSD 9.0powerpclibxmi-1.2.tgz
NetBSD 9.0powerpclibxmi-1.2.tgz
NetBSD 9.0sparc64libxmi-1.2.tgz
NetBSD 9.0sparc64libxmi-1.2.tgz
NetBSD 9.0sparc64libxmi-1.2.tgz
NetBSD 9.0sparclibxmi-1.2.tgz
NetBSD 9.0sparclibxmi-1.2.tgz
NetBSD 9.0sparclibxmi-1.2.tgz
NetBSD 9.0sparclibxmi-1.2.tgz
NetBSD 9.0x86_64libxmi-1.2.tgz
NetBSD 9.0x86_64libxmi-1.2.tgz
NetBSD 9.0x86_64libxmi-1.2.tgz
NetBSD 9.0x86_64libxmi-1.2.tgz
NetBSD 9.0x86_64libxmi-1.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.