graphics/gifsicle - The NetBSD Packages Collection

Create, edit, and inspect GIFs from shell

Gifsicle is a UNIX command-line tool for creating, editing, and getting
information about GIF images and animations.  You can also extract frames from
animations, or replace, delete, or insert frames into existing animations.

Some more gifsicle features:
- Batch mode for changing GIFs in place.
- Prints detailed information about GIFs, including comments.
- Control over interlacing, comments, looping, transparency...
- Creates well-behaved GIFs: removes redundant colors, only uses
  local color tables if it absolutely has to (local color tables
  waste space and can cause viewing artifacts), etc.
- It can shrink colormaps and change images to use the Web-safe
  palette (or any colormap you choose).
- It can optimize your animations!  This stores only the changed
  portion of each frame, and can radically shrink your GIFs.  You
  can also use transparency to make them even smaller.  Gifsicle's
  optimizer is pretty powerful, and usually reduces animations
  to within a couple bytes of the best commercial optimizers.
- Unoptimizing animations, which makes them easier to edit.

Two other programs are included with gifsicle: gifview is a lightweight
animated-GIF viewer which can show animations as slideshows or in real
time, and gifdiff compares two GIFs for identical visual appearance.

Build dependencies

pkgtools/x11-links pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgifsicle-1.92.tgz
NetBSD 8.0earmv7hfgifsicle-1.92.tgz
NetBSD 8.0earmv7hfgifsicle-1.92.tgz
NetBSD 8.0i386gifsicle-1.92.tgz
NetBSD 8.0i386gifsicle-1.92.tgz
NetBSD 8.0i386gifsicle-1.92.tgz
NetBSD 8.0powerpcgifsicle-1.92.tgz
NetBSD 8.0powerpcgifsicle-1.92.tgz
NetBSD 8.0powerpcgifsicle-1.92.tgz
NetBSD 8.0x86_64gifsicle-1.92.tgz
NetBSD 8.0x86_64gifsicle-1.92.tgz
NetBSD 9.0aarch64gifsicle-1.92.tgz
NetBSD 9.0aarch64gifsicle-1.92.tgz
NetBSD 9.0aarch64gifsicle-1.92.tgz
NetBSD 9.0alphagifsicle-1.92.tgz
NetBSD 9.0alphagifsicle-1.92.tgz
NetBSD 9.0alphagifsicle-1.92.tgz
NetBSD 9.0earmgifsicle-1.92.tgz
NetBSD 9.0earmgifsicle-1.92.tgz
NetBSD 9.0earmv6hfgifsicle-1.92.tgz
NetBSD 9.0earmv6hfgifsicle-1.92.tgz
NetBSD 9.0earmv6hfgifsicle-1.92.tgz
NetBSD 9.0earmv6hfgifsicle-1.92.tgz
NetBSD 9.0earmv7hfgifsicle-1.92.tgz
NetBSD 9.0earmv7hfgifsicle-1.92.tgz
NetBSD 9.0earmv7hfgifsicle-1.92.tgz
NetBSD 9.0earmv7hfgifsicle-1.92.tgz
NetBSD 9.0i386gifsicle-1.92.tgz
NetBSD 9.0i386gifsicle-1.92.tgz
NetBSD 9.0i386gifsicle-1.92.tgz
NetBSD 9.0mips64ebgifsicle-1.92.tgz
NetBSD 9.0mips64ebgifsicle-1.92.tgz
NetBSD 9.0mips64ebgifsicle-1.92.tgz
NetBSD 9.0mipselgifsicle-1.92.tgz
NetBSD 9.0mipselgifsicle-1.92.tgz
NetBSD 9.0powerpcgifsicle-1.92.tgz
NetBSD 9.0powerpcgifsicle-1.92.tgz
NetBSD 9.0sh3elgifsicle-1.92.tgz
NetBSD 9.0sh3elgifsicle-1.92.tgz
NetBSD 9.0sparc64gifsicle-1.92.tgz
NetBSD 9.0sparc64gifsicle-1.92.tgz
NetBSD 9.0sparc64gifsicle-1.92.tgz
NetBSD 9.0sparc64gifsicle-1.92.tgz
NetBSD 9.0sparcgifsicle-1.92.tgz
NetBSD 9.0sparcgifsicle-1.92.tgz
NetBSD 9.0sparcgifsicle-1.92.tgz
NetBSD 9.0vaxgifsicle-1.92.tgz
NetBSD 9.0vaxgifsicle-1.92.tgz
NetBSD 9.0x86_64gifsicle-1.92.tgz
NetBSD 9.0x86_64gifsicle-1.92.tgz
NetBSD 9.0x86_64gifsicle-1.92.tgz
NetBSD 9.0x86_64gifsicle-1.92.tgz
NetBSD 9.0x86_64gifsicle-1.92.tgz
NetBSD 9.0x86_64gifsicle-1.92.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.