graphics/comix - The NetBSD Packages Collection

Image viewer specifically designed to handle comic books

Comix is an image viewer specifically designed to handle comic books.
It reads ZIP, RAR and tar archives (also gzip or bzip2 compressed), as
well as plain image files. It has a simple and user-friendly GUI using
PyGTK.

Build dependencies

pkgtools/x11-links devel/py-gobject-shared x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/py-gobject-shared devel/glib2-tools

Runtime dependencies

archivers/unrar databases/py-sqlite3 devel/GConf databases/shared-mime-info graphics/hicolor-icon-theme graphics/py-imaging graphics/py-imaging sysutils/desktop-file-utils x11/py-gtk2 x11/py-gtk2 devel/GConf databases/shared-mime-info graphics/hicolor-icon-theme graphics/py-imaging sysutils/desktop-file-utils x11/py-gtk2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfcomix-4.0.4nb43.tgz
NetBSD 8.0earmv7hfcomix-4.0.4nb42.tgz
NetBSD 8.0earmv7hfcomix-4.0.4nb43.tgz
NetBSD 8.0i386comix-4.0.4nb42.tgz
NetBSD 8.0i386comix-4.0.4nb43.tgz
NetBSD 8.0powerpccomix-4.0.4nb42.tgz
NetBSD 8.0powerpccomix-4.0.4nb43.tgz
NetBSD 8.0powerpccomix-4.0.4nb43.tgz
NetBSD 8.0powerpccomix-4.0.4nb43.tgz
NetBSD 8.0x86_64comix-4.0.4nb42.tgz
NetBSD 8.0x86_64comix-4.0.4nb43.tgz
NetBSD 9.0aarch64comix-4.0.4nb43.tgz
NetBSD 9.0aarch64comix-4.0.4nb42.tgz
NetBSD 9.0aarch64comix-4.0.4nb43.tgz
NetBSD 9.0alphacomix-4.0.4nb43.tgz
NetBSD 9.0alphacomix-4.0.4nb42.tgz
NetBSD 9.0alphacomix-4.0.4nb43.tgz
NetBSD 9.0earmv6hfcomix-4.0.4nb43.tgz
NetBSD 9.0earmv6hfcomix-4.0.4nb42.tgz
NetBSD 9.0earmv6hfcomix-4.0.4nb43.tgz
NetBSD 9.0earmv7hfcomix-4.0.4nb43.tgz
NetBSD 9.0earmv7hfcomix-4.0.4nb42.tgz
NetBSD 9.0earmv7hfcomix-4.0.4nb43.tgz
NetBSD 9.0earmv7hfcomix-4.0.4nb43.tgz
NetBSD 9.0i386comix-4.0.4nb42.tgz
NetBSD 9.0i386comix-4.0.4nb43.tgz
NetBSD 9.0mips64ebcomix-4.0.4nb43.tgz
NetBSD 9.0mips64ebcomix-4.0.4nb40.tgz
NetBSD 9.0mips64ebcomix-4.0.4nb42.tgz
NetBSD 9.0mips64ebcomix-4.0.4nb42.tgz
NetBSD 9.0mips64ebcomix-4.0.4nb43.tgz
NetBSD 9.0powerpccomix-4.0.4nb43.tgz
NetBSD 9.0powerpccomix-4.0.4nb42.tgz
NetBSD 9.0powerpccomix-4.0.4nb43.tgz
NetBSD 9.0powerpccomix-4.0.4nb43.tgz
NetBSD 9.0sparc64comix-4.0.4nb43.tgz
NetBSD 9.0sparc64comix-4.0.4nb42.tgz
NetBSD 9.0sparc64comix-4.0.4nb43.tgz
NetBSD 9.0sparccomix-4.0.4nb43.tgz
NetBSD 9.0sparccomix-4.0.4nb42.tgz
NetBSD 9.0sparccomix-4.0.4nb43.tgz
NetBSD 9.0x86_64comix-4.0.4nb43.tgz
NetBSD 9.0x86_64comix-4.0.4nb43.tgz
NetBSD 9.0x86_64comix-4.0.4nb42.tgz
NetBSD 9.0x86_64comix-4.0.4nb43.tgz
NetBSD 9.0x86_64comix-4.0.4nb43.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gnome
Enable GNOME support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.