Daemon Power

The NetBSD Packages Collection: graphics/ImageMagick

Brief description of the package:
Package for display and interactive manipulation of images

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.imagemagick.org/.

Please note that this package has a gnu-gpl-v3 license.

The package is located in the "graphics/ImageMagick" directory. The current source version of the package is "ImageMagick-7.0.10.13nb2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for graphics/ImageMagick :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: pkgconf-[0-9]* cwrappers>=20150314 openjpeg>=2.1.0 lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 png>=1.2.4 png>=1.6.0nb1 liblqr>=0.4.1 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 meson-[0-9]* ninja-build>=1.7 python37>=3.7 libuuid>=2.18 openssl>=1.1.1 openssl>=1.1.1dnb2 readline>=2.2 readline>=6.0 python37>=3.7.0 re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.7 glib2>=2.64.0nb1 libltdl>=2.4.2 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 libwebp>=0.2.0 giflib>=5.2.1 fftw>=3.0 ghostscript>=8.63nb1 ghostscript-agpl-[0-9]* ghostscript-fonts>=6.0 perl>=5.0 freetype2>=2.10.0 libidn>=0.4.6 jbig2dec>=0.17 jbig2dec>=0.16 libpaper>=1.1.22 fontconfig>=2.13.0 libidn>=1.20nb1 x11-links>=1.31 osabi-NetBSD-8.1_STABLE libxml2>=2.6.2 xmlcatmgr>=2.0beta1 liblqr>=0.4.2nb1 libltdl>=2.2.6 libwebp>=0.6.0 fftw>=3.1nb1 ghostscript>=9.05nb22 libxml2>=2.9.10nb2 .

This package requires the following package(s) to run: pkgconf-[0-9]* openjpeg>=2.1.0 lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 png>=1.2.4 png>=1.6.0nb1 liblqr>=0.4.1 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.3nb1 glib2>=2.64.0nb1 libltdl>=2.4.2 fontconfig>=2.11.91 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 libwebp>=0.2.0 giflib>=5.2.1 fftw>=3.0 ghostscript>=8.63nb1 ghostscript-agpl-[0-9]* ghostscript-fonts>=6.0 perl>=5.0 freetype2>=2.10.0 libidn>=0.4.6 jbig2dec>=0.17 jbig2dec>=0.16 libpaper>=1.1.22 fontconfig>=2.13.0 libidn>=1.20nb1 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 liblqr>=0.4.2nb1 libltdl>=2.2.6 libwebp>=0.6.0 fftw>=3.1nb1 ghostscript>=9.05nb22 libxml2>=2.9.10nb2 .

This package supports the following build-time options:

djvu
Enable DjVuLibRe support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:ImageMagick-7.0.9.5.tgz(NetBSD 9.0)
alpha:ImageMagick-7.0.8.61.tgz(NetBSD 8.0)
alpha:ImageMagick-7.0.9.5.tgz(NetBSD 9.0)
earm:ImageMagick-6.9.1.7.tgz(NetBSD 7.0)
earm:ImageMagick-7.0.8.49.tgz(NetBSD 8.0)
earm:ImageMagick-7.0.9.5.tgz(NetBSD 9.0)
earmv4:ImageMagick-7.0.8.61.tgz(NetBSD 8.0)
earmv6hf:ImageMagick-7.0.9.5.tgz(NetBSD 8.0)
earmv6hf:ImageMagick-7.0.9.5.tgz(NetBSD 9.0)
earmv7hf:ImageMagick-7.0.10.1.tgz(NetBSD 8.0)
earmv7hf:ImageMagick-7.0.9.5.tgz(NetBSD 8.0)
earmv7hf:ImageMagick-7.0.9.5.tgz(NetBSD 9.0)
i386:ImageMagick-7.0.10.1.tgz(NetBSD 9.0)
i386:ImageMagick-7.0.9.5.tgz(NetBSD 7.0)
i386:ImageMagick-7.0.9.2.tgz(NetBSD 7.0)
i386:ImageMagick-7.0.9.2.tgz(NetBSD 7.1)
i386:ImageMagick-7.0.9.5.tgz(NetBSD 7.1)
i386:ImageMagick-7.0.10.1.tgz(NetBSD 7.1)
i386:ImageMagick-7.0.9.2.tgz(NetBSD 8.0)
i386:ImageMagick-7.0.9.5.tgz(NetBSD 8.0)
i386:ImageMagick-7.0.10.1.tgz(NetBSD 8.0)
i386:ImageMagick-7.0.10.1.tgz(NetBSD 9.0)
i386:ImageMagick-7.0.9.5.tgz(NetBSD 9.0)
i386:ImageMagick-6.6.9.8.tgz(QNX 6.5.0)
m68k:ImageMagick-7.0.8.61.tgz(NetBSD 8.0)
mips64eb:ImageMagick-7.0.8.61.tgz(NetBSD 8.0)
mips64eb:ImageMagick-7.0.9.5.tgz(NetBSD 9.0)
powerpc:ImageMagick-7.0.8.34.tgz(NetBSD 7.1)
powerpc:ImageMagick-7.0.8.16.tgz(NetBSD 7.1)
powerpc:ImageMagick-7.0.9.5.tgz(NetBSD 8.0)
powerpc:ImageMagick-7.0.9.5.tgz(NetBSD 9.0)
sparc64:ImageMagick-7.0.8.2.tgz(NetBSD 7.1)
sparc64:ImageMagick-7.0.8.61.tgz(NetBSD 8.0)
sparc64:ImageMagick-7.0.9.5.tgz(NetBSD 9.0)
sparc:ImageMagick-6.9.1.7.tgz(NetBSD 7.0)
sparc:ImageMagick-7.0.3.0.tgz(NetBSD 7.0)
sparc:ImageMagick-7.0.9.5.tgz(NetBSD 8.0)
x86_64:ImageMagick-7.0.10.6.tgz(NetBSD 9.0)
x86_64:ImageMagick-7.0.10.10.tgz(NetBSD 9.0)
x86_64:ImageMagick-7.0.9.5.tgz(NetBSD 7.0)
x86_64:ImageMagick-7.0.9.2.tgz(NetBSD 7.0)
x86_64:ImageMagick-7.0.9.5.tgz(NetBSD 7.1)
x86_64:ImageMagick-7.0.9.2.tgz(NetBSD 7.1)
x86_64:ImageMagick-7.0.10.1.tgz(NetBSD 7.1)
x86_64:ImageMagick-7.0.10.1.tgz(NetBSD 8.0)
x86_64:ImageMagick-7.0.9.2.tgz(NetBSD 8.0)
x86_64:ImageMagick-7.0.9.5.tgz(NetBSD 8.0)
x86_64:ImageMagick-7.0.10.1.tgz(NetBSD 9.0)
x86_64:ImageMagick-7.0.9.5.tgz(NetBSD 9.0)
x86_64:ImageMagick-7.0.10.13nb1.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]