emulators/xtrs - The NetBSD Packages Collection

TRS-80 Model I/III/4 Emulator for Unix

xtrs is a Radio Shack TRS-80 Model I/III/4/4P emulator for Unix
and the X Window System.  It includes lower case, the real time
clock, hi-res graphics, serial port, parallel printer, mouse,
cassette, sound and music output (requires OSS), 5" and 8" floppy
disk drives in single and double density, and even hard disk drives.
The emulated floppy and hard disk file formats are compatible with
the popular MSDOS-based emulators by Jeff Vavasour, Matthew Reed,
and David Keil, and (if you choose a capable enough file format),
all features of the original TRS-80 floppy disk controller are
emulated.  Under Linux, physical floppy disk drives are also
supported.  Physical cassettes can be read and written too. The
user interface is a bit spartan, but it gets the job done.

Build dependencies

pkgtools/x11-links pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfxtrs-4.9dnb3.tgz
NetBSD 8.0earmv7hfxtrs-4.9dnb3.tgz
NetBSD 8.0earmv7hfxtrs-4.9dnb3.tgz
NetBSD 8.0i386xtrs-4.9dnb3.tgz
NetBSD 8.0i386xtrs-4.9dnb3.tgz
NetBSD 8.0i386xtrs-4.9dnb3.tgz
NetBSD 8.0powerpcxtrs-4.9dnb3.tgz
NetBSD 8.0powerpcxtrs-4.9dnb3.tgz
NetBSD 8.0powerpcxtrs-4.9dnb3.tgz
NetBSD 8.0x86_64xtrs-4.9dnb3.tgz
NetBSD 8.0x86_64xtrs-4.9dnb3.tgz
NetBSD 9.0aarch64xtrs-4.9dnb3.tgz
NetBSD 9.0aarch64xtrs-4.9dnb3.tgz
NetBSD 9.0aarch64xtrs-4.9dnb3.tgz
NetBSD 9.0alphaxtrs-4.9dnb3.tgz
NetBSD 9.0alphaxtrs-4.9dnb3.tgz
NetBSD 9.0alphaxtrs-4.9dnb3.tgz
NetBSD 9.0earmv6hfxtrs-4.9dnb3.tgz
NetBSD 9.0earmv6hfxtrs-4.9dnb3.tgz
NetBSD 9.0earmv6hfxtrs-4.9dnb3.tgz
NetBSD 9.0earmv6hfxtrs-4.9dnb3.tgz
NetBSD 9.0earmv7hfxtrs-4.9dnb3.tgz
NetBSD 9.0earmv7hfxtrs-4.9dnb3.tgz
NetBSD 9.0earmv7hfxtrs-4.9dnb3.tgz
NetBSD 9.0earmv7hfxtrs-4.9dnb3.tgz
NetBSD 9.0i386xtrs-4.9dnb3.tgz
NetBSD 9.0i386xtrs-4.9dnb3.tgz
NetBSD 9.0mips64ebxtrs-4.9dnb3.tgz
NetBSD 9.0mips64ebxtrs-4.9dnb3.tgz
NetBSD 9.0mips64ebxtrs-4.9dnb3.tgz
NetBSD 9.0powerpcxtrs-4.9dnb3.tgz
NetBSD 9.0powerpcxtrs-4.9dnb3.tgz
NetBSD 9.0sparc64xtrs-4.9dnb3.tgz
NetBSD 9.0sparc64xtrs-4.9dnb3.tgz
NetBSD 9.0sparc64xtrs-4.9dnb3.tgz
NetBSD 9.0sparc64xtrs-4.9dnb3.tgz
NetBSD 9.0sparcxtrs-4.9dnb3.tgz
NetBSD 9.0x86_64xtrs-4.9dnb3.tgz
NetBSD 9.0x86_64xtrs-4.9dnb3.tgz
NetBSD 9.0x86_64xtrs-4.9dnb3.tgz
NetBSD 9.0x86_64xtrs-4.9dnb3.tgz
NetBSD 9.0x86_64xtrs-4.9dnb3.tgz
NetBSD 9.0x86_64xtrs-4.9dnb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.