editors/leafpad - The NetBSD Packages Collection

Simple and light text editor using GTK+

Leafpad is a GTK+ based simple text editor and is ideal as a file viewer.
The user interface is similar to "notepad", aims to be lighter than GEdit
and KWrite, and to be as useful as them.

Its features are:

* Minimum requirements: for portability.
* Minimal menu items: to make full use of features and to learn easily.
* No toolbar: to maximize the text area.
* Single document interface (SDI): to set out windows to view at a time.
* Character coding auto detection: to open file quickly without multi-codeset
  problems.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools textproc/intltool devel/gmake lang/perl5 devel/pkgconf

Runtime dependencies

graphics/hicolor-icon-theme sysutils/desktop-file-utils x11/gtk2 graphics/hicolor-icon-theme sysutils/desktop-file-utils x11/gtk2

Available binary packages

aarch64:leafpad-0.8.18.1nb3.tgz(NetBSD 9.0)
aarch64:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
aarch64:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
alpha:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
earmv6hf:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
earmv6hf:leafpad-0.8.18.1nb3.tgz(NetBSD 9.0)
earmv6hf:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
earmv6hf:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
earmv7hf:leafpad-0.8.18.1nb4.tgz(NetBSD 8.0)
earmv7hf:leafpad-0.8.18.1nb3.tgz(NetBSD 8.0)
earmv7hf:leafpad-0.8.18.1nb3.tgz(NetBSD 8.0)
earmv7hf:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
earmv7hf:leafpad-0.8.18.1nb3.tgz(NetBSD 9.0)
earmv7hf:leafpad-0.8.18.1nb3.tgz(NetBSD 9.0)
earmv7hf:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
earmv7hf:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
i386:leafpad-0.8.18.1nb3.tgz(NetBSD 8.0)
i386:leafpad-0.8.18.1nb4.tgz(NetBSD 8.0)
i386:leafpad-0.8.18.1nb4.tgz(NetBSD 8.0)
i386:leafpad-0.8.18.1nb3.tgz(NetBSD 9.0)
i386:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
i386:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
mips64eb:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
powerpc:leafpad-0.8.18.1nb3.tgz(NetBSD 8.0)
powerpc:leafpad-0.8.18.1nb4.tgz(NetBSD 8.0)
powerpc:leafpad-0.8.18.1nb4.tgz(NetBSD 8.0)
powerpc:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
powerpc:leafpad-0.8.18.1nb3.tgz(NetBSD 9.0)
powerpc:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
sparc64:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
sparc64:leafpad-0.8.18.1nb3.tgz(NetBSD 9.0)
sparc64:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
sparc:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
x86_64:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
x86_64:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
x86_64:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
x86_64:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
x86_64:leafpad-0.8.18.1nb4.tgz(NetBSD 8.0)
x86_64:leafpad-0.8.18.1nb3.tgz(NetBSD 8.0)
x86_64:leafpad-0.8.18.1nb4.tgz(NetBSD 8.0)
x86_64:leafpad-0.8.18.1nb3.tgz(NetBSD 9.0)
x86_64:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
x86_64:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)
x86_64:leafpad-0.8.18.1nb4.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]