editors/gate - The NetBSD Packages Collection

Lightweight text editor

Gate is text-gatherer. A text-gatherer is like a text-editor, but much
more lightweight and unobtrusive.
If you have a program or shell script that asks people to enter a small
chunk of text, a text-gatherer like Gate is a good way to do it. It
doesn't clear the screen (annoying if there were just some instructions
printed there). It doesn't require you to know a lot of obscure editing
commands. It doesn't make excessive demands on the intelligence of your
terminal emulation software.
It does provide a number of features that make it easier for novice users
to produce good text. It does word-wrap, prints a prompt on each new line,
and allows backspacing from the currently line onto previous lines. It
also provides features that a more experienced user can use. You can call
up normal editor, or use some of gate's simple-minded editing
commands. You can read in files, or save your text to a file. You can
filter your text through something like the unix "fmt" command. It
provides a nice spell-checking interface too.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Available binary packages

aarch64:gate-2.06nb1.tgz(NetBSD 9.0)
aarch64:gate-2.06nb1.tgz(NetBSD 9.0)
aarch64:gate-2.06nb1.tgz(NetBSD 9.0)
alpha:gate-2.06nb1.tgz(NetBSD 9.0)
alpha:gate-2.06nb1.tgz(NetBSD 9.0)
earm:gate-2.06nb1.tgz(NetBSD 9.0)
earmv6hf:gate-2.06nb1.tgz(NetBSD 9.0)
earmv6hf:gate-2.06nb1.tgz(NetBSD 9.0)
earmv6hf:gate-2.06nb1.tgz(NetBSD 9.0)
earmv6hf:gate-2.06nb1.tgz(NetBSD 9.0)
earmv7hf:gate-2.06nb1.tgz(NetBSD 8.0)
earmv7hf:gate-2.06nb1.tgz(NetBSD 8.0)
earmv7hf:gate-2.06nb1.tgz(NetBSD 8.0)
earmv7hf:gate-2.06nb1.tgz(NetBSD 8.0)
earmv7hf:gate-2.06nb1.tgz(NetBSD 9.0)
earmv7hf:gate-2.06nb1.tgz(NetBSD 9.0)
earmv7hf:gate-2.06nb1.tgz(NetBSD 9.0)
earmv7hf:gate-2.06nb1.tgz(NetBSD 9.0)
earmv7hf:gate-2.06nb1.tgz(NetBSD 9.0)
i386:gate-2.06nb1.tgz(NetBSD 8.0)
i386:gate-2.06nb1.tgz(NetBSD 8.0)
i386:gate-2.06nb1.tgz(NetBSD 8.0)
i386:gate-2.06nb1.tgz(NetBSD 9.0)
i386:gate-2.06nb1.tgz(NetBSD 9.0)
i386:gate-2.06nb1.tgz(NetBSD 9.0)
mips64eb:gate-2.06nb1.tgz(NetBSD 9.0)
powerpc:gate-2.06nb1.tgz(NetBSD 8.0)
powerpc:gate-2.06nb1.tgz(NetBSD 8.0)
powerpc:gate-2.06nb1.tgz(NetBSD 8.0)
powerpc:gate-2.06nb1.tgz(NetBSD 9.0)
powerpc:gate-2.06nb1.tgz(NetBSD 9.0)
sparc64:gate-2.06nb1.tgz(NetBSD 9.0)
sparc64:gate-2.06nb1.tgz(NetBSD 9.0)
sparc64:gate-2.06nb1.tgz(NetBSD 9.0)
sparc:gate-2.06nb1.tgz(NetBSD 9.0)
x86_64:gate-2.06nb1.tgz(NetBSD 9.0)
x86_64:gate-2.06nb1.tgz(NetBSD 9.0)
x86_64:gate-2.06nb1.tgz(NetBSD 9.0)
x86_64:gate-2.06nb1.tgz(NetBSD 9.0)
x86_64:gate-2.06nb1.tgz(NetBSD 8.0)
x86_64:gate-2.06nb1.tgz(NetBSD 8.0)
x86_64:gate-2.06nb1.tgz(NetBSD 8.0)
x86_64:gate-2.06nb1.tgz(NetBSD 9.0)
x86_64:gate-2.06nb1.tgz(NetBSD 9.0)
x86_64:gate-2.06nb1.tgz(NetBSD 9.0)
x86_64:gate-2.06nb1.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]