devel/userspace-rcu - The NetBSD Packages Collection

Userspace RCU (Read Copy Update)

liburcu is a userspace RCU (read-copy-update) library. This data
synchronization library provides read-side access which scales linearly
with the number of cores. It does so by allowing multiples copies of a
given data structure to live at the same time, and by monitoring the
data structure accesses to detect grace periods after which memory
reclamation is possible.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfuserspace-rcu-0.12.1.tgz
NetBSD 8.0earmv7hfuserspace-rcu-0.12.1.tgz
NetBSD 8.0earmv7hfuserspace-rcu-0.12.1.tgz
NetBSD 8.0i386userspace-rcu-0.12.1.tgz
NetBSD 8.0i386userspace-rcu-0.12.1.tgz
NetBSD 8.0powerpcuserspace-rcu-0.12.1.tgz
NetBSD 8.0powerpcuserspace-rcu-0.12.1.tgz
NetBSD 8.0powerpcuserspace-rcu-0.12.1.tgz
NetBSD 8.0powerpcuserspace-rcu-0.12.1.tgz
NetBSD 8.0x86_64userspace-rcu-0.12.1.tgz
NetBSD 8.0x86_64userspace-rcu-0.12.1.tgz
NetBSD 9.0aarch64userspace-rcu-0.12.1.tgz
NetBSD 9.0aarch64userspace-rcu-0.12.1.tgz
NetBSD 9.0aarch64userspace-rcu-0.12.1.tgz
NetBSD 9.0alphauserspace-rcu-0.12.1.tgz
NetBSD 9.0alphauserspace-rcu-0.12.1.tgz
NetBSD 9.0alphauserspace-rcu-0.12.1.tgz
NetBSD 9.0earmuserspace-rcu-0.12.1.tgz
NetBSD 9.0earmuserspace-rcu-0.12.1.tgz
NetBSD 9.0earmuserspace-rcu-0.12.1.tgz
NetBSD 9.0earmv6hfuserspace-rcu-0.12.1.tgz
NetBSD 9.0earmv6hfuserspace-rcu-0.12.1.tgz
NetBSD 9.0earmv6hfuserspace-rcu-0.12.1.tgz
NetBSD 9.0earmv7hfuserspace-rcu-0.12.1.tgz
NetBSD 9.0earmv7hfuserspace-rcu-0.12.1.tgz
NetBSD 9.0earmv7hfuserspace-rcu-0.12.1.tgz
NetBSD 9.0earmv7hfuserspace-rcu-0.12.1.tgz
NetBSD 9.0i386userspace-rcu-0.12.1.tgz
NetBSD 9.0i386userspace-rcu-0.12.1.tgz
NetBSD 9.0i386userspace-rcu-0.12.1.tgz
NetBSD 9.0mips64ebuserspace-rcu-0.12.1.tgz
NetBSD 9.0mips64ebuserspace-rcu-0.12.1.tgz
NetBSD 9.0mips64ebuserspace-rcu-0.12.1.tgz
NetBSD 9.0mips64ebuserspace-rcu-0.12.1.tgz
NetBSD 9.0mips64ebuserspace-rcu-0.12.1.tgz
NetBSD 9.0mipseluserspace-rcu-0.12.1.tgz
NetBSD 9.0mipseluserspace-rcu-0.12.1.tgz
NetBSD 9.0mipseluserspace-rcu-0.12.1.tgz
NetBSD 9.0mipseluserspace-rcu-0.12.1.tgz
NetBSD 9.0powerpcuserspace-rcu-0.12.1.tgz
NetBSD 9.0powerpcuserspace-rcu-0.12.1.tgz
NetBSD 9.0powerpcuserspace-rcu-0.12.1.tgz
NetBSD 9.0powerpcuserspace-rcu-0.12.1.tgz
NetBSD 9.0sparc64userspace-rcu-0.12.1.tgz
NetBSD 9.0sparc64userspace-rcu-0.12.1.tgz
NetBSD 9.0sparc64userspace-rcu-0.12.1.tgz
NetBSD 9.0x86_64userspace-rcu-0.12.1.tgz
NetBSD 9.0x86_64userspace-rcu-0.12.1.tgz
NetBSD 9.0x86_64userspace-rcu-0.12.1.tgz
NetBSD 9.0x86_64userspace-rcu-0.12.1.tgz
NetBSD 9.0x86_64userspace-rcu-0.12.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.