devel/simde - The NetBSD Packages Collection

Header-only library for SIMD intrinsics

The SIMDe header-only library provides fast, portable implementations of SIMD
intrinsics on hardware which doesn't natively support them, such as calling SSE
functions on ARM. There is no performance penalty if the hardware supports the
native implementation (e.g., SSE/AVX runs at full speed on x86, NEON on ARM,
etc.).

Build dependencies

devel/meson pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64simde-0.7.2.tgz
NetBSD 10.0aarch64simde-0.7.2.tgz
NetBSD 10.0earmv6hfsimde-0.7.2.tgz
NetBSD 10.0earmv6hfsimde-0.7.2.tgz
NetBSD 10.0earmv7hfsimde-0.7.2.tgz
NetBSD 10.0earmv7hfsimde-0.7.2.tgz
NetBSD 10.0i386simde-0.7.2.tgz
NetBSD 10.0powerpcsimde-0.7.2.tgz
NetBSD 10.0powerpcsimde-0.7.2.tgz
NetBSD 10.0x86_64simde-0.7.2.tgz
NetBSD 10.0x86_64simde-0.7.2.tgz
NetBSD 8.0i386simde-0.7.2.tgz
NetBSD 8.0i386simde-0.7.2.tgz
NetBSD 8.0powerpcsimde-0.7.2.tgz
NetBSD 8.0powerpcsimde-0.7.2.tgz
NetBSD 8.0x86_64simde-0.7.2.tgz
NetBSD 8.0x86_64simde-0.7.2.tgz
NetBSD 9.0aarch64simde-0.7.2.tgz
NetBSD 9.0aarch64simde-0.7.2.tgz
NetBSD 9.0aarch64simde-0.7.2.tgz
NetBSD 9.0alphasimde-0.7.2.tgz
NetBSD 9.0alphasimde-0.7.2.tgz
NetBSD 9.0alphasimde-0.7.2.tgz
NetBSD 9.0earmv6hfsimde-0.7.2.tgz
NetBSD 9.0earmv6hfsimde-0.7.2.tgz
NetBSD 9.0earmv6hfsimde-0.7.2.tgz
NetBSD 9.0earmv7hfsimde-0.7.2.tgz
NetBSD 9.0earmv7hfsimde-0.7.2.tgz
NetBSD 9.0earmv7hfsimde-0.7.2.tgz
NetBSD 9.0i386simde-0.7.2.tgz
NetBSD 9.0i386simde-0.7.2.tgz
NetBSD 9.0i386simde-0.7.2.tgz
NetBSD 9.0powerpcsimde-0.7.2.tgz
NetBSD 9.0powerpcsimde-0.7.2.tgz
NetBSD 9.0powerpcsimde-0.7.2.tgz
NetBSD 9.0sparc64simde-0.7.2.tgz
NetBSD 9.0sparc64simde-0.7.2.tgz
NetBSD 9.0sparc64simde-0.7.2.tgz
NetBSD 9.0sparcsimde-0.7.2.tgz
NetBSD 9.0sparcsimde-0.7.2.tgz
NetBSD 9.0sparcsimde-0.7.2.tgz
NetBSD 9.0x86_64simde-0.7.2.tgz
NetBSD 9.0x86_64simde-0.7.2.tgz
NetBSD 9.0x86_64simde-0.7.2.tgz
NetBSD 9.0x86_64simde-0.7.2.tgz
NetBSD 9.0x86_64simde-0.7.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.