devel/semantic - The NetBSD Packages Collection

Lexer, parser-generator, and parser written for Emacs

The Semantic Bovinator is a lexer, parser-generator, and parser. It is
written in Emacs Lisp and is customized to the way Emacs thinks about
language files, and is optimized to use Emacs' parsing capabilities.

The Semantic Bovinator's goal is to provide an intermediate API for
authors of language agnostic tools who want to deal with languages in
a generic way. It also provides a simple way for Mode Authors who are
experts in their language to provide a parser for those tool
authors, without knowing anything about those tools.

The Semantic Bovinator is made up of these important pieces:
    1. lexer
    2. parser
    3. parser-generator
    4. language definitions
    5. navigator
    6. speedbar browser
    7. Documentation generator

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

editors/emacs26 editors/speedbar lang/eieio

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfsemantic-1.4.4nb2.tgz
NetBSD 8.0earmv7hfsemantic-1.4.4nb2.tgz
NetBSD 8.0earmv7hfsemantic-1.4.4nb2.tgz
NetBSD 8.0i386semantic-1.4.4nb2.tgz
NetBSD 8.0i386semantic-1.4.4nb2.tgz
NetBSD 8.0powerpcsemantic-1.4.4nb2.tgz
NetBSD 8.0powerpcsemantic-1.4.4nb2.tgz
NetBSD 8.0powerpcsemantic-1.4.4nb2.tgz
NetBSD 8.0powerpcsemantic-1.4.4nb2.tgz
NetBSD 8.0x86_64semantic-1.4.4nb2.tgz
NetBSD 8.0x86_64semantic-1.4.4nb2.tgz
NetBSD 9.0aarch64semantic-1.4.4nb2.tgz
NetBSD 9.0aarch64semantic-1.4.4nb2.tgz
NetBSD 9.0aarch64semantic-1.4.4nb2.tgz
NetBSD 9.0alphasemantic-1.4.4nb2.tgz
NetBSD 9.0alphasemantic-1.4.4nb2.tgz
NetBSD 9.0alphasemantic-1.4.4nb2.tgz
NetBSD 9.0earmsemantic-1.4.4nb2.tgz
NetBSD 9.0earmsemantic-1.4.4nb2.tgz
NetBSD 9.0earmsemantic-1.4.4nb2.tgz
NetBSD 9.0earmv6hfsemantic-1.4.4nb2.tgz
NetBSD 9.0earmv6hfsemantic-1.4.4nb2.tgz
NetBSD 9.0earmv6hfsemantic-1.4.4nb2.tgz
NetBSD 9.0earmv7hfsemantic-1.4.4nb2.tgz
NetBSD 9.0earmv7hfsemantic-1.4.4nb2.tgz
NetBSD 9.0earmv7hfsemantic-1.4.4nb2.tgz
NetBSD 9.0earmv7hfsemantic-1.4.4nb2.tgz
NetBSD 9.0i386semantic-1.4.4nb2.tgz
NetBSD 9.0i386semantic-1.4.4nb2.tgz
NetBSD 9.0i386semantic-1.4.4nb2.tgz
NetBSD 9.0powerpcsemantic-1.4.4nb2.tgz
NetBSD 9.0powerpcsemantic-1.4.4nb2.tgz
NetBSD 9.0powerpcsemantic-1.4.4nb2.tgz
NetBSD 9.0powerpcsemantic-1.4.4nb2.tgz
NetBSD 9.0sparc64semantic-1.4.4nb2.tgz
NetBSD 9.0sparc64semantic-1.4.4nb2.tgz
NetBSD 9.0sparc64semantic-1.4.4nb2.tgz
NetBSD 9.0sparcsemantic-1.4.4nb2.tgz
NetBSD 9.0sparcsemantic-1.4.4nb2.tgz
NetBSD 9.0sparcsemantic-1.4.4nb2.tgz
NetBSD 9.0sparcsemantic-1.4.4nb2.tgz
NetBSD 9.0sparcsemantic-1.4.4nb2.tgz
NetBSD 9.0x86_64semantic-1.4.4nb2.tgz
NetBSD 9.0x86_64semantic-1.4.4nb2.tgz
NetBSD 9.0x86_64semantic-1.4.4nb2.tgz
NetBSD 9.0x86_64semantic-1.4.4nb2.tgz
NetBSD 9.0x86_64semantic-1.4.4nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.