devel/ruby-term-ansicolor - The NetBSD Packages Collection

Ruby library colors strings using ANSI escape sequences

= Term::ANSIColor - ANSI escape sequences in Ruby

== Description

This library can be used to color/decolor strings using ANSI escape sequences.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/ruby-tins lang/ruby27-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby26-term-ansicolor-1.7.1.tgz
NetBSD 8.0earmv7hfruby27-term-ansicolor-1.7.1.tgz
NetBSD 8.0earmv7hfruby25-term-ansicolor-1.7.1.tgz
NetBSD 8.0earmv7hfruby26-term-ansicolor-1.7.1.tgz
NetBSD 8.0earmv7hfruby27-term-ansicolor-1.7.1.tgz
NetBSD 8.0earmv7hfruby26-term-ansicolor-1.7.1.tgz
NetBSD 8.0earmv7hfruby27-term-ansicolor-1.7.1.tgz
NetBSD 8.0i386ruby25-term-ansicolor-1.7.1.tgz
NetBSD 8.0i386ruby26-term-ansicolor-1.7.1.tgz
NetBSD 8.0i386ruby27-term-ansicolor-1.7.1.tgz
NetBSD 8.0i386ruby26-term-ansicolor-1.7.1.tgz
NetBSD 8.0i386ruby27-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby24-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby25-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby26-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby27-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby24-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby25-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby26-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby27-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby24-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby25-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby26-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby27-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby24-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby25-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby26-term-ansicolor-1.7.1.tgz
NetBSD 8.0powerpcruby27-term-ansicolor-1.7.1.tgz
NetBSD 8.0x86_64ruby25-term-ansicolor-1.7.1.tgz
NetBSD 8.0x86_64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 8.0x86_64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 8.0x86_64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 8.0x86_64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0aarch64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0aarch64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0aarch64ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0aarch64ruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0aarch64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0aarch64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0aarch64ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0aarch64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0aarch64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0aarch64ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0alpharuby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0alpharuby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0alpharuby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0alpharuby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0alpharuby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0alpharuby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0alpharuby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0alpharuby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0alpharuby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv6hfruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv6hfruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv6hfruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv6hfruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv6hfruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv6hfruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv6hfruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv6hfruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv6hfruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv6hfruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0earmv7hfruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0i386ruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0i386ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0i386ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0i386ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0i386ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0i386ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0i386ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0i386ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0i386ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0i386ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0mips64ebruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby24-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby24-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby24-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby24-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0powerpcruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0sparc64ruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0sparc64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0sparc64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0sparc64ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0sparc64ruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0sparc64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0sparc64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0sparc64ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0sparc64ruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0sparc64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0sparc64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0sparc64ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby25-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby30-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby26-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby27-term-ansicolor-1.7.1.tgz
NetBSD 9.0x86_64ruby30-term-ansicolor-1.7.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.