devel/quilt - The NetBSD Packages Collection

Tools to manage series of patches

Quilt is a set of scripts that allows to manage a series of patches by
keeping track of the changes each patch makes.  Patches can be applied,
un-applied, refreshed, etc.

The key philosophical concept is that your primary output is patches.
Not ".c" files, not ".h" files.  But patches.  So patches are the
first-class object here.

Quilt was originally based on Andrew Morton's patch scripts published on
the Linux kernel mailing list a while ago, but were heavily modified
since then.

Build dependencies

pkgtools/cwrappers devel/gmake textproc/gsed

Runtime dependencies

sysutils/coreutils devel/patch shells/bash lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfquilt-0.66nb3.tgz
NetBSD 8.0earmv7hfquilt-0.66nb2.tgz
NetBSD 8.0earmv7hfquilt-0.66nb3.tgz
NetBSD 8.0i386quilt-0.66nb2.tgz
NetBSD 8.0i386quilt-0.66nb3.tgz
NetBSD 8.0powerpcquilt-0.66nb2.tgz
NetBSD 8.0powerpcquilt-0.66nb3.tgz
NetBSD 8.0powerpcquilt-0.66nb3.tgz
NetBSD 8.0powerpcquilt-0.66nb3.tgz
NetBSD 8.0x86_64quilt-0.66nb2.tgz
NetBSD 8.0x86_64quilt-0.66nb3.tgz
NetBSD 9.0aarch64quilt-0.66nb3.tgz
NetBSD 9.0aarch64quilt-0.66nb2.tgz
NetBSD 9.0aarch64quilt-0.66nb3.tgz
NetBSD 9.0alphaquilt-0.66nb3.tgz
NetBSD 9.0alphaquilt-0.66nb2.tgz
NetBSD 9.0alphaquilt-0.66nb3.tgz
NetBSD 9.0earmv6hfquilt-0.66nb3.tgz
NetBSD 9.0earmv6hfquilt-0.66nb2.tgz
NetBSD 9.0earmv6hfquilt-0.66nb3.tgz
NetBSD 9.0earmv7hfquilt-0.66nb3.tgz
NetBSD 9.0earmv7hfquilt-0.66nb2.tgz
NetBSD 9.0earmv7hfquilt-0.66nb3.tgz
NetBSD 9.0earmv7hfquilt-0.66nb3.tgz
NetBSD 9.0i386quilt-0.66nb2.tgz
NetBSD 9.0i386quilt-0.66nb3.tgz
NetBSD 9.0mips64ebquilt-0.66nb3.tgz
NetBSD 9.0mips64ebquilt-0.66nb2.tgz
NetBSD 9.0mips64ebquilt-0.66nb2.tgz
NetBSD 9.0mips64ebquilt-0.66nb2.tgz
NetBSD 9.0mips64ebquilt-0.66nb3.tgz
NetBSD 9.0powerpcquilt-0.66nb3.tgz
NetBSD 9.0powerpcquilt-0.66nb2.tgz
NetBSD 9.0powerpcquilt-0.66nb3.tgz
NetBSD 9.0powerpcquilt-0.66nb3.tgz
NetBSD 9.0sparc64quilt-0.66nb3.tgz
NetBSD 9.0sparc64quilt-0.66nb2.tgz
NetBSD 9.0sparc64quilt-0.66nb3.tgz
NetBSD 9.0sparcquilt-0.66nb3.tgz
NetBSD 9.0sparcquilt-0.66nb2.tgz
NetBSD 9.0sparcquilt-0.66nb2.tgz
NetBSD 9.0sparcquilt-0.66nb3.tgz
NetBSD 9.0x86_64quilt-0.66nb3.tgz
NetBSD 9.0x86_64quilt-0.66nb3.tgz
NetBSD 9.0x86_64quilt-0.66nb2.tgz
NetBSD 9.0x86_64quilt-0.66nb3.tgz
NetBSD 9.0x86_64quilt-0.66nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.